'In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.'
This issue affects ClearOS 7 and ClearOS 6.
This issue was fixed in the backported fixes of versions of:
httpd version 2.4.6-45 and later in ClearOS 7
webconfig-httpd version 2.4.6-45 and later in ClearOS 7
httpd version 2.2.15-47 or later in ClearOS 6
webconfig-httpd version 2.2.15-47 or later in ClearOS 6
This issue was fixed during the maintenance cycle of ClearOS 7.3 and 6.7. ClearOS systems that are up to date do not suffer from this vulnerability. Some vulnerability scanning software may report this bug because their only method for determining the issue is to check the http version number since the exploit requires specific web configurations and has not other means for testing vulnerability. In ClearOS, version numbers stay consistent through the product's life-cycle and will produce a false positive on this issue if the testing software considers only the http version and not the ClearOS patch level.
If you are running ClearOS 6 or 7, please ensure that you are running the latest updates:
You may also validate your version by running:
rpm -qi httpd
You should validate that you are running: