Community Forum

Mansoor
Mansoor
Offline
Resolved
0 votes
I'm trying to build 32-bit version of wine to run some old Windows programmes, but the required development development tools could not be installed on ClearOS 7.2

The commands:
yum install gcc.i686
yum install `rpm -qa |grep devel |sed -e 's/x86_64$/i686/'`

failed to find any packages in the builtin repos.
Friday, September 01 2017, 05:37 PM
Share this post:
Responses (5)
  • Accepted Answer

    Sunday, September 03 2017, 03:57 AM - #Permalink
    Resolved
    0 votes

    [root@alex ~]# yum list libgcc
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * centos-extras-unverified: mirror.optus.net
    * centos-unverified: mirror.ventraip.net.au
    * centos-updates-unverified: mirror.ventraip.net.au
    * centosplus-unverified: mirror.ventraip.net.au
    * clearos: ftp.nluug.nl
    * clearos-centos-sclo-rh: download4.clearsdn.com
    * clearos-contribs: ftp.nluug.nl
    * clearos-fast-updates: download4.clearsdn.com
    * clearos-infra: ftp.nluug.nl
    * clearos-updates: ftp.nluug.nl
    * private-clearcenter-dyndns: download4.clearsdn.com:80
    * private-clearcenter-plex: download2.clearsdn.com:80
    Installed Packages
    libgcc.i686 4.8.5-11.el7 @centos-unverified
    libgcc.x86_64 4.8.5-11.el7 @centos-unverified
    [root@alex ~]# rpm -qa | grep libgcc
    libgcc-4.8.5-11.el7.i686
    libgcc-4.8.5-11.el7.x86_64
    [root@alex ~]#

    EDIT: using the Community Edition here...
    "yum install libgcc.i686 --enablerepo=centos-unverified"

    Tony http://www.sraellis.tk
    The reply is currently minimized Show
  • Accepted Answer

    Mansoor
    Mansoor
    Offline
    Sunday, September 03 2017, 03:42 AM - #Permalink
    Resolved
    0 votes
    Tony Ellis wrote:

    More or less followed the instructions at https://www.systutorials.com/239913/install-32-bit-wine-1-8-centos-7/

    The result

    [root@alex ~]# file `which wine`
    /usr/local/bin/wine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=5ab5eaecc9480c4633a1f4fd6bed9ce0a2708aa8, not stripped
    [root@alex ~]#
    [root@alex ~]# file `which wine64`
    /usr/local/bin/wine64: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=752114cd27eec4f0734c09096d47c8eaa678cc11, not stripped
    [root@alex ~]#

    Evaluate which application libraries you might want to add after the "../configure ....." stages to support the wine functionality you require...

    Thank you for the link. Unfortunately, I could not execute the forth yum install statement because my system did not find any i686 packages in the clearos-centos repo.
    The reply is currently minimized Show
  • Accepted Answer

    Mansoor
    Mansoor
    Offline
    Sunday, September 03 2017, 03:36 AM - #Permalink
    Resolved
    0 votes
    Dave Loper wrote:

    If you can't find the packages in the stock repo you can try looking in clearos-centos. Not everything that is CentOS is included in ClearOS because the outcomes and results are experimental. But that is what the community edition is for so run the following to get the 32 library for gcc:

    yum --enablerepo=clearos-centos install libgcc.i686

    Don't do an upgrade or update with that repo enabled, it will break things.

    Also, I don't think there is a gcc.i686 package. If you want to compile with gcc in 32-bit mode, try the -m32 flag.


    It seems that repo clearos-centos has no 32-bit packages. Here for example what I get when trying to install libgcc.i686:

    [code type="markup"]Dependencies Resolved

    ================================================================================================================================
    Package Arch Version Repository Size
    ================================================================================================================================
    Installing:
    libgcc i686 4.8.5-11.el7 clearos-centos 104 k

    Transaction Summary
    ================================================================================================================================
    Install 1 Package

    Total download size: 104 k
    Installed size: 190 k
    Is this ok [y/d/N]: y
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    libgcc-4.8.5-11.el7.i686.rpm FAILED
    http://download3.clearsdn.com/centos/7.3.1611/os/x86_64/Packages/libgcc-4.8.5-11.el7.i686.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable
    Trying other mirror.
    libgcc-4.8.5-11.el7.i686.rpm FAILED
    http://download2.clearsdn.com/centos/7.3.1611/os/x86_64/Packages/libgcc-4.8.5-11.el7.i686.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable
    Trying other mirror.
    libgcc-4.8.5-11.el7.i686.rpm FAILED
    http://download4.clearsdn.com/centos/7.3.1611/os/x86_64/Packages/libgcc-4.8.5-11.el7.i686.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable
    Trying other mirror.
    libgcc-4.8.5-11.el7.i686.rpm FAILED
    http://download1.clearsdn.com/centos/7.3.1611/os/x86_64/Packages/libgcc-4.8.5-11.el7.i686.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable
    Trying other mirror.


    Error downloading packages:
    libgcc-4.8.5-11.el7.i686: [Errno 256] No more mirrors to try.

    [/code

    I found the 32bit packages in a mirror site here: http://mirror1-orem.clearsdn.com/clearos/7/centos/os/x86_64/Packages/ but I don't know how to update the clearos-centos repo's to include the mirror url.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 02 2017, 02:34 PM - #Permalink
    Resolved
    0 votes
    More or less followed the instructions at https://www.systutorials.com/239913/install-32-bit-wine-1-8-centos-7/

    The result

    [root@alex ~]# file `which wine`
    /usr/local/bin/wine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=5ab5eaecc9480c4633a1f4fd6bed9ce0a2708aa8, not stripped
    [root@alex ~]#
    [root@alex ~]# file `which wine64`
    /usr/local/bin/wine64: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=752114cd27eec4f0734c09096d47c8eaa678cc11, not stripped
    [root@alex ~]#

    Evaluate which application libraries you might want to add after the "../configure ....." stages to support the wine functionality you require...
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 02 2017, 02:10 PM - #Permalink
    Resolved
    0 votes
    If you can't find the packages in the stock repo you can try looking in clearos-centos. Not everything that is CentOS is included in ClearOS because the outcomes and results are experimental. But that is what the community edition is for so run the following to get the 32 library for gcc:

    yum --enablerepo=clearos-centos install libgcc.i686

    Don't do an upgrade or update with that repo enabled, it will break things.

    Also, I don't think there is a gcc.i686 package. If you want to compile with gcc in 32-bit mode, try the -m32 flag.
    The reply is currently minimized Show
Your Reply