Forums

Resolved
0 votes
Running ClearOS release 7.6.0 (Final)

The error appears to be:
Nov 5 22:49:48 mailsvr postfix/pipe[13322]: 516B68011395C: to=<lisa@adsignz.com.au>, relay=mailpostfilter, delay=0.45, delays=0.12/0.06/0/0.28, dsn=4.3.0, status=deferred (temporary failure. Command output: Failed to set recipient: , code=-1, original code -1)
The mail is queued: mail shows
0BBA2801098A2 7414 Tue Nov 5 22:09:06 graeme@computerrepairnorthlakes.com.au
(temporary failure. Command output: Failed to set recipient: , code=-1, original code -1)
lisa@adsignz.com.au
-- 109869 Kbytes in 87 Requests
This occurred after a server crash and filesystem repair..

User can connect to the IMAP server and send outbound email fine.

Any help appreciated

Cheers,
Graeme

Edit - some thoughts: it appears that the user is no longer recognised as a local user by postfix. So maybe an ldap issue? I'm not sure where to start to troubleshoot that. Or how to repair that connection.
In Mail
Tuesday, November 05 2019, 12:53 PM
Share this post:
Responses (15)
  • Accepted Answer

    Wednesday, November 06 2019, 09:09 AM - #Permalink
    Resolved
    0 votes
    Without a transport layer I don't think postfix can deliver to cyrus-imap which is the Inbox. I think it is the transport layer which needs debugging. It may not be a bug per se with the transport layer but it may be it can't lookup the e-mail address to username mapping via LDAP so it still could be an LDAP issue. On the other hand it could even be happening before that but I don't know how to troubleshoot.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, November 06 2019, 03:24 AM - #Permalink
    Resolved
    0 votes
    Another fail .I have reverted to an earlier snapshot of the VM
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 10:33 PM - #Permalink
    Resolved
    0 votes
    For now I have disabled the mail transport - it seems to have delivered the mail but I still cannot see it in the inbox I am doing another reconstruct on the mailbox using the following option.
    -G
    Force re-parsing of the underlying message (checks GUID correctness). Reconstruct with -G should fix all possible individual message issues, including corrupted data files.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 10:16 PM - #Permalink
    Resolved
    0 votes
    The post filter, AFAIK takes the mail from postfix and delivers it to Cyrus. Why ClearOS wrote their own one and did not use something like LMTP I have no idea. You can see where the error is being trapped - line 83 of /usr/clearos/apps/mail_routing/libraries/Transport.php, but I am not a PHP programmer and can't debug it. I think you can add a "print_r($some_variable);" to show the contents of the variable, presumably in one of the webconfig logs.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 09:54 PM - #Permalink
    Resolved
    0 votes
    If you go for the nuclear option, if you are using imap you have options. You can manipulate mailboxes with the cyradm command and if you delete a user you do not delete her mailbox. You can also use imapsync to move mail between mailboxes. Alternatively, if you give her a new username, you can use Thunderbird to do something similar as it can have multiple acounts open at the same time and you can drag and drop between the accounts.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 09:53 PM - #Permalink
    Resolved
    0 votes
    deleted and recreated the user - with different username but with same same email as alias. Mail entered the inbox - but the original email address (alias) still failed with the same error.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 09:28 PM - #Permalink
    Resolved
    0 votes
    so nuclear option? delete and recreate the user? I have a pst backup of existing email. should that fix it?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 09:08 PM - #Permalink
    Resolved
    0 votes
    With verbose smtpd

    root@mailsvr ~]# tail -n 30 /var/log/maillog
    Nov 6 07:04:38 mailsvr postfix/pipe[9700]: 8263180114C8D: to=<lisa@adsignz.com.au>, relay=mailprefilter, delay=1.6, delays=1.1/0.03/0/0.4, dsn=2.0.0, status=sent (delivered via mailprefilter service)
    Nov 6 07:04:38 mailsvr postfix/qmgr[9667]: 8263180114C8D: removed
    Nov 6 07:04:38 mailsvr amavis[8734]: (08734-03) ESMTP :10024 /var/lib/amavis/tmp/amavis-20191106T070246-08734-50XdyBm2: <graeme@computerrepairnorthlakes.com.au> -> <lisa@adsignz.com.au> SIZE=7399 Received: from mailsvr.adsignz.com.au ([127.0.0.1]) by localhost (mailsvr.adsignz.com.au [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <lisa@adsignz.com.au>; Wed, 6 Nov 2019 07:04:38 +1000 (AEST)
    Nov 6 07:04:38 mailsvr amavis[8734]: (08734-03) Checking: IuIARhRE3H24 [127.0.0.1] <graeme@computerrepairnorthlakes.com.au> -> <lisa@adsignz.com.au>
    Nov 6 07:04:38 mailsvr amavis[8734]: (08734-03) p003 1 Content-Type: multipart/alternative
    Nov 6 07:04:38 mailsvr amavis[8734]: (08734-03) p001 1/1 Content-Type: text/plain, size: 346 B, name:
    Nov 6 07:04:38 mailsvr amavis[8734]: (08734-03) p002 1/2 Content-Type: text/html, size: 4143 B, name:
    Nov 6 07:04:40 mailsvr postfix/smtpd[9696]: < unknown[92.118.38.54]: AUTH LOGIN
    Nov 6 07:04:40 mailsvr postfix/smtpd[9696]: xsasl_cyrus_server_first: sasl_method LOGIN
    Nov 6 07:04:40 mailsvr postfix/smtpd[9696]: xsasl_cyrus_server_auth_response: uncoded server challenge: Username:
    Nov 6 07:04:40 mailsvr postfix/smtpd[9696]: > unknown[92.118.38.54]: 334 VXNlcm5hbWU6
    Nov 6 07:04:41 mailsvr postfix/smtpd[9698]: auto_clnt_close: disconnect private/tlsmgr stream
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) spam-tag, <graeme@computerrepairnorthlakes.com.au> -> <lisa@adsignz.com.au>, No, score=-2.597 tagged_above=-99 required=4 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_HELO_NONE=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) dkim: candidate originators: From:<graeme@computerrepairnorthlakes.com.au>
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) dkim: not signing, empty signing domain, From: <graeme@computerrepairnorthlakes.com.au>
    Nov 6 07:04:42 mailsvr postfix/smtpd[9621]: 3380480114C8D: client=localhost[127.0.0.1]
    Nov 6 07:04:42 mailsvr postfix/cleanup[9699]: 3380480114C8D: message-id=<FF0ECB1D-0376-4A5D-A12A-177F31A20D79@computerrepairnorthlakes.com.au>
    Nov 6 07:04:42 mailsvr postfix/qmgr[9667]: 3380480114C8D: from=<graeme@computerrepairnorthlakes.com.au>, size=8073, nrcpt=1 (queue active)
    Nov 6 07:04:42 mailsvr postfix/smtpd[9621]: disconnect from localhost[127.0.0.1]
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) IuIARhRE3H24 FWD from <graeme@computerrepairnorthlakes.com.au> -> <lisa@adsignz.com.au>, BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10026): 250 2.0.0 Ok: queued as 3380480114C8D
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) Passed CLEAN {RelayedInternal}, LOCAL [127.0.0.1]:35458 [120.23.77.78] <graeme@computerrepairnorthlakes.com.au> -> <lisa@adsignz.com.au>, Queue-ID: 9D8E780114C91, Message-ID: <FF0ECB1D-0376-4A5D-A12A-177F31A20D79@computerrepairnorthlakes.com.au>, mail_id: IuIARhRE3H24, Hits: -2.597, size: 7399, queued_as: 3380480114C8D, 3496 ms
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) TIMING-SA total 3218 ms - parse: 4.9 (0.2%), extract_message_metadata: 81 (2.5%), get_uri_detail_list: 8 (0.3%), tests_pri_-1000: 48 (1.5%), tests_pri_-950: 3.0 (0.1%), tests_pri_-900: 2.4 (0.1%), tests_pri_-90: 146 (4.5%), check_bayes: 76 (2.4%), b_tokenize: 42 (1.3%), b_tok_get_all: 12 (0.4%), b_comp_prob: 9 (0.3%), b_tok_touch_all: 0.92 (0.0%), b_finish: 4.8 (0.1%), tests_pri_0: 300 (9.3%), check_dkim_adsp: 51 (1.6%), check_spf: 64 (2.0%), poll_dns_idle: 30 (0.9%), tests_pri_20: 2031 (63.1%), check_razor2: 2021 (62.8%), tests_pri_30: 3.9 (0.1%), check_pyzor: 0.92 (0.0%), tests_pri_500: 14 (0.4%), learn: 536 (16.7%), b_learn: 522 (16.2%), b_count_change: 30 (0.9%), get_report: 1.08 (0.0%)
    Nov 6 07:04:42 mailsvr postfix/smtp[9704]: 9D8E780114C91: to=<lisa@adsignz.com.au>, relay=127.0.0.1[127.0.0.1]:10024, delay=3.7, delays=0.12/0.04/0.02/3.5, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10026): 250 2.0.0 Ok: queued as 3380480114C8D)
    Nov 6 07:04:42 mailsvr postfix/qmgr[9667]: 9D8E780114C91: removed
    Nov 6 07:04:42 mailsvr amavis[8734]: (08734-03) size: 7399, TIMING [total 3508 ms] - SMTP greeting: 12 (0%)0, SMTP EHLO: 1.7 (0%)0, SMTP pre-MAIL: 1.3 (0%)0, SMTP pre-DATA-flush: 10 (0%)1, SMTP DATA: 28 (1%)2, check_init: 1.2 (0%)2, digest_hdr: 3.0 (0%)2, digest_body_dkim: 0.5 (0%)2, collect_info: 9 (0%)2, mime_decode: 29 (1%)3, get-file-type2: 52 (1%)4, parts_decode: 0.4 (0%)4, check_header: 1.3 (0%)4, spam-wb-list: 3.4 (0%)4, SA msg read: 2.6 (0%)4, SA parse: 7 (0%)5, SA check: 3208 (91%)96, decide_mail_destiny: 15 (0%)97, notif-quar: 1.7 (0%)97, fwd-connect: 12 (0%)97, fwd-mail-pip: 11 (0%)97, fwd-rcpt-pip: 0.3 (0%)97, fwd-data-chkpnt: 0.1 (0%)97, write-header: 1.1 (0%)97, fwd-data-contents: 0.2 (0%)97, fwd-end-chkpnt: 69 (2%)99, prepare-dsn: 2.7 (0%)99, report: 3.5 (0%)99, main_log_entry: 11 (0%)100, update_snmp: 4.4 (0%)100, SMTP pre-response: 0.9 (0%)100, SMTP response: 0.5 (0%)100, unlink-2-files: 1.9 (0%)100, rundown: 1.8 (0%)100
    Nov 6 07:04:42 mailsvr mailfilter: starting up (sender=graeme@computerrepairnorthlakes.com.au, recipients=lisa@adsignz.com.au, client_address=127.0.0.1)
    Nov 6 07:04:42 mailsvr master[3268]: process 9708 exited, signaled to death by 11
    Nov 6 07:04:42 mailsvr mailfilter: Failed to set recipient: , code=-1, original code -1 <ID: <FF0ECB1D-0376-4A5D-A12A-177F31A20D79@computerrepairnorthlakes.com.au>>, /usr/clearos/apps/mail_routing/libraries/Transport.php, 83
    Nov 6 07:04:42 mailsvr postfix/pipe[9671]: 3380480114C8D: to=<lisa@adsignz.com.au>, relay=mailpostfilter, delay=0.31, delays=0.07/0/0/0.23, dsn=4.3.0, status=deferred (temporary failure. Command output: Failed to set recipient: , code=-1, original code -1)
    Nov 6 07:04:42 mailsvr postfix/smtpd[9698]: rewrite stream disconnect
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 08:54 PM - #Permalink
    Resolved
    0 votes
    Seeing as the error is related to the post filter is there a way to temporarily disable the post filter and test if she receives email?

    relay=mailpostfilter, delay=0.56, delays=0.08/0.06/0/0.42, dsn=4.3.0, status=deferred (temporary failure. Command output: Failed to set recipient: , code=-1, original code -1)

    It seems that I would edit /etc/postfix/master.cf but what? just hash out the post filter altogether?
    uninstall and reinstall the email anti spam etc?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 08:48 PM - #Permalink
    Resolved
    0 votes
    Thank for the reply Nick,
    I have been doing some digging the user does not appear in the Duplicate Delivery Members area - all other users are listed there.
    Users email address appears the web admin under their user details with 2 aliases.
    A reconstruct was one of the first things I tried.
    How to increase log level - is that in the postfix.conf?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 08:42 PM - #Permalink
    Resolved
    0 votes
    I really don't know now, but at least you are up and running for most of your users.. Are there more errors around this? You may need to increase the log level to get more detail. Have you checked the users e-mail address in the Webconfig Users list? I am not sure how to check much more.

    It may be worth running a reconstruct on the users mailbox. There should be information somewhere in the forum or google "cyrus reconstruct".
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 07:26 PM - #Permalink
    Resolved
    0 votes
    Initial restore failed second restore from the previous day seemed to work with a couple of errors.
    The user is still not receiving email with the same error.

    status=deferred (temporary failure. Command output: Failed to set recipient: , code=-1, original code -1)


    Restore complete. Nov 6, 2019 5:15:17 AM
    Starting event monitor service Nov 6, 2019 5:15:15 AM
    Command execution failed - winbind Nov 6, 2019 5:15:15 AM
    Restarting service: winbind Nov 6, 2019 5:15:13 AM
    Restarting service: udisks2 Nov 6, 2019 5:15:11 AM
    Restarting service: tuned Nov 6, 2019 5:14:58 AM
    Restarting service: syswatch Nov 6, 2019 5:14:57 AM
    Restarting service: system-mariadb Nov 6, 2019 5:14:37 AM
    Restarting service: sysstat Nov 6, 2019 5:14:37 AM
    Restarting service: suvad Nov 6, 2019 5:14:36 AM
    Restarting service: sshd Nov 6, 2019 5:14:34 AM
    Restarting service: saslauthd Nov 6, 2019 5:14:33 AM
    Restarting service: postfix Nov 6, 2019 5:14:29 AM
    Command execution failed - openvpn@ Nov 6, 2019 5:14:29 AM
    Restarting service: openvpn@ Nov 6, 2019 5:14:29 AM
    Restarting service: nslcd Nov 6, 2019 5:14:23 AM
    Restarting service: nscd Nov 6, 2019 5:14:22 AM
    Restarting service: httpd Nov 6, 2019 5:14:09 AM
    Restarting service: firewall Nov 6, 2019 5:14:03 AM
    Restarting service: dnsmasq Nov 6, 2019 5:14:03 AM
    Restarting service: dlad Nov 6, 2019 5:13:58 AM
    Restarting service: cyrus-imapd Nov 6, 2019 5:13:37 AM
    Restarting service: crond Nov 6, 2019 5:13:37 AM
    Restarting service: clamd Nov 6, 2019 5:08:26 AM
    Restarting service: cag Nov 6, 2019 5:08:17 AM
    Restarting service: amavisd Nov 6, 2019 5:07:52 AM
    Restarting service: acpid Nov 6, 2019 5:07:51 AM
    Restarting service: zbootevent Nov 6, 2019 5:07:49 AM
    Restarting service: slapd Nov 6, 2019 4:55:23 AM
    Importing LDAP directory Nov 6, 2019 4:54:48 AM
    Command execution failed. Nov 6, 2019 4:54:48 AM
    Downloading and installing apps. Please be patient. Nov 6, 2019 4:53:20 AM
    Unpacking archive file Nov 6, 2019 4:53:17 AM
    Restore type: match Nov 6, 2019 4:53:17 AM
    Checking archive version compatibility Nov 6, 2019 4:53:16 AM
    Archive File: /var/clearos/configuration_backup/backup-mailsvr_adsignz_com_au-11-04-2019-17-50-01.tgz Nov 6, 2019 4:53:16 AM
    Stopping event monitor service Nov 6, 2019 4:53:15 AM
    Initializing Nov 6, 2019 4:53:14 AM
    Showing 1 to 38 of 38 entries
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 06:52 PM - #Permalink
    Resolved
    0 votes
    hmm so that was a fail now a number of users are missing
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 06:42 PM - #Permalink
    Resolved
    0 votes
    Hi Nick thanks for the reply,
    restore log
    5dc1c245 => bdb_tool_entry_put: id2entry_add failed: BDB0067 DB_KEYEXIST: Key/data pair already exists (-30994)
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 05 2019, 01:58 PM - #Permalink
    Resolved
    0 votes
    Not so easy. LDAP is a PITA if it goes wrong. The first thing to try is a configuration restore from prior to you crash, if you have one. ClearOS keeps a rolling 10 days of backups.
    The reply is currently minimized Show
Your Reply