Forums

Andy
Andy
Offline
Resolved
0 votes
Hi,

My work system is running behind clearos gateway. I want to access my work system from home through Remote Desktop.. I found that for this i have to configure port forwarding in clearos. But i am not able to configure port forwarding for RDP. Can anyone help me how to configure it step by step.





Thanks in advance
Tuesday, September 20 2011, 08:41 AM
Share this post:
Responses (7)
  • Accepted Answer

    Monday, August 21 2017, 04:50 PM - #Permalink
    Resolved
    0 votes
    Hi Dan and welcome. As you are a new poster, your first couple of posts get moderated and I think the relevant people were away last week.

    Anyway you can find guacamole in the clearos-epel repo which should be enabled by default if you're using CelarOS 7.x. From the command line a:
    yum install guacamole
    should install it.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 14 2017, 06:58 PM - #Permalink
    Resolved
    0 votes
    I know this thread is old, but as a general Rule of Thumb when it comes to security, you should really never use 3389 on the public internet.
    While the old saying "Security by Obscurity is No Security at all", you also don't need to make it any easier for people on the internet to find your machine running RDP.

    I think Nick's #3 is the best option.

    If you do decide to port forward, maybe add 1 digit to the end of the public facing side.
    So Target number 1 inside your network would get a NAT rule of 33891 external to 3389:machine1 on the inside.
    Then you can have multiple machines available via RDP and you aren't running on 3389 publicly.

    PS: Does anyone know if ClearOS supports Guacamole? I literally signed up 10 minutes ago and haven't checked myself.

    Location [ View Larger Map ]

    http://maps.googleapis.com/maps/api/staticmap?center=34.0522342,-118.2436849&language=en&maptype=roadmap&zoom=5&size=450x300&sensor=true&markers=color:red|label:S|34.0522342,-118.2436849
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, December 20 2015, 03:01 PM - #Permalink
    Resolved
    1 votes
    Better than bumping a nearly 4 year old thread would be to start a new one.

    You have three options:
    1 - change the RDP port on one of the machines then port forward that port through ClearOS
    2 - use the port forwarding facility (you don't need 1-to-1 NAT) to switch ports as you port forward in the firewall so , for example Public_IP:3388 -> LAN_IP:3389
    3 - my favoured solution is to give up on port forwarding and connect to ClearOS instead with OpenVPN. Then you can RDP directly using the relevant LAN IP
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, December 20 2015, 12:03 PM - #Permalink
    Resolved
    0 votes
    Andy wrote:

    Its' done through 1 to 1 NAT in clearos by mapping public ip to local ip .

    I have managed through 1 to 1 NAT. however i was wondering what if i need to access two devices with different local IP addresses? meaning need to be able to access RDP 1 and RDP 2 while on a single public IP.
    The reply is currently minimized Show
  • Accepted Answer

    Andy
    Andy
    Offline
    Wednesday, February 01 2012, 10:01 AM - #Permalink
    Resolved
    0 votes
    Hi Tim,
    Can you tell me the steps to do port forwarding for RDP. I have 2 IP ( one virtual )configured with one Ethernet card eth2. I want to access the local machine using RDP from ip configured on virtual LAN Interface. In fact there are 3 types of rule for port forwarding , I use the 2 one, but unable to do that.
    Can to tell me the steps as example.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 25 2012, 02:02 PM - #Permalink
    Resolved
    0 votes
    Or just forward port 3389 to 3389 on your local server IP (Use the webconfig port forwarding screen only, also do not add it to the incoming firewall as it will conflict).

    Make sure your work system also has port 3389 open to remote connections, and your system is locked down with good user/password combinations.

    Google for RDP port forward would have got you the same :)
    The reply is currently minimized Show
  • Accepted Answer

    Andy
    Andy
    Offline
    Wednesday, January 25 2012, 06:07 AM - #Permalink
    Resolved
    1 votes
    Its' done through 1 to 1 NAT in clearos by mapping public ip to local ip .
    The reply is currently minimized Show
Your Reply