Forums

Resolved
0 votes
Hi, I am ClearOS community edition for the past 3 yrs, using as gateway/router for my home network. I just installed on new motherboard whisch has on board intel wifi as follows

-Intel® CNVi interface 802.11a/b/g/n/ac, supporting 2.4/5 GHz Dual-Band
-Support for 11ac 160 MHz wireless standard and up to 1.73 Gbps data rate

I installed wifi app using "yum install..." Now I can see the app in NetWork/IP Settings.

But Wireless Interface is not showing any.

Any help would be appreciated. I don't have any programmimg knowledge and I can apply any help or instructions to get it to work..

Thanks,
Ravi
Friday, February 08 2019, 03:12 AM
Share this post:
Responses (32)
  • Accepted Answer

    Tuesday, February 19 2019, 08:25 AM - #Permalink
    Resolved
    0 votes
    Finding a driver for that looks tricky. Probably the easiest answer is to install the latest kernel from ElRepo. If you then want QoS to work, you need to change "QOS_ENABLE_IFB" to "yes" in /etc/clearos/qos.conf.

    If you do try an ElRepo kernel you will be living life on the bleedin' edge and I have no experience ot it.

    As a halfway house, you could try the 7.6 kernel, just in case:
    yum update kernel --enablerepo=clearos-updates-testing,centos-unverified
    Then reboot.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 19 2019, 12:18 AM - #Permalink
    Resolved
    0 votes
    It the driver for Intel WIFI Device(a370) is not in the installation package.

    Intel has linux driver for this card. How do I update the drive?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 15 2019, 08:47 PM - #Permalink
    Resolved
    0 votes
    My hostapd.conf looks like:
    #
    # For more information, look here:
    #
    # http://wireless.kernel.org/en/users/Documentation/hostapd
    #

    ctrl_interface=/var/run/hostapd
    ctrl_interface_group=wheel

    # General settings
    # bridge=br0
    interface=wlp0s16u2
    driver=nl80211
    hw_mode=g
    channel=11
    auth_algs=1
    ssid=microserver
    macaddr_acl=0
    ignore_broadcast_ssid=0
    ieee8021x=0

    # Wireless N
    # wme_enabled=1
    # ieee80211n=1
    # ht_capab=[HT40-][SHORT-GI-40][DSSS_CCK-40]

    # WPA
    wpa=3
    wpa_key_mgmt=WPA-PSK
    wpa_passphrase=!microserver!
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP
    wpa_group_rekey=300
    wpa_gmk_rekey=640

    I'd remove your Wireless N stuff for the moment. Walk before you run. Then I'm afraid google will be your friend. Have a look at your logs (mainly the message log). Try starting hostapd in debug mode (I can't remember how) and research the errors. I have virtually no more knowledge and have failed to get my 8812au NIC running (not that I need it). The Configuration you see is for a different USB NIC.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 15 2019, 07:54 PM - #Permalink
    Resolved
    0 votes
    Not sure whether this hostapd config file is correct?

    /etc/hostapd.hostapd.conf

    interface=wlo1
    driver=n180211
    hw_mode=g
    channel=6
    SSID=BELLCLEAROS
    auth_algs=1
    ctrl_interface=/var/run/hostapd

    #WPA
    wpa=3
    wpa_key_mgmt=WPA-PSK
    wpa_passphrase=Sunrise1
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP
    wpa_group_rekey=300
    wpa_gmk_rekey=640

    #Wireless N
    wme_enabled=1
    ieee80211n=1
    ht_capab=[HT40-][SHORT-GI-40][DSSS_CCK-40]
    ~
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 15 2019, 07:42 PM - #Permalink
    Resolved
    0 votes
    I updated all the required files. And now wireless interface wlo1 is showing in the wireless-app, but app itself is not running. Clicking the start button does not start and it stops.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 15 2019, 10:25 AM - #Permalink
    Resolved
    0 votes
    eno2 should not be listed in LANIF as it is part of your PPPoE.

    To get hostapd, probably the best thing to do is install app-wireless with:
    yum install app-wireless

    If you already have app-wireless, you can try running:
    /usr/clearos/apps/wireless/deploy/install
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 15 2019, 12:32 AM - #Permalink
    Resolved
    0 votes
    /etc/clearos/network.conf
    # Network mode
    MODE="gateway"
    # Network interface roles
    EXTIF="ppp0"
    LANIF="eno2 enp2s0 wlo1"
    DMZIF=""
    HOTIF=""

    /etc/sysconfig/network-scripts/ifcfg-wlo1
    DEVICE=wlo1
    TYPE="Wireless"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    IPADDR="192.168.199.1"
    NETMASK="255.255.255.0"

    Now I can see the wireless interface wlo1 in the app. But app is not running.

    I understand I need a /etc/hostapd/hostapd.conf file. I had one but it is missing.

    What do I need to have in that file?

    Thanks a lot
    Ravi
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 09:38 PM - #Permalink
    Resolved
    0 votes
    I would have expected it to show in "ip addr show" or "ip link show". Anyway, try creating a file /etc/sysconfig/network-scripts/ifcfg-wlo1. In it put:
    DEVICE=wlo1
    TYPE="Wireless"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    IPADDR="192.168.199.1"
    NETMASK="255.255.255.0"
    Change the IPADDR to an unused subnet.

    Edit /etc/clearos/network.conf and add wlo1 to LANIF:
    LANIF="enp1s0 wlo1"
    Saving the file may restart networking, otherwise do a "service network restart" but be prepared to lose your PuTTy session.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 08:59 PM - #Permalink
    Resolved
    0 votes
    When I installed ClearOS, I see these three interfaces

    Enp1s0 used for LAN
    Eno2 used for PPPoE
    Wlo1 This is the wifi not used


    not sure what that means.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 08:03 PM - #Permalink
    Resolved
    0 votes
    In PuTTy you can scroll back up a long way.

    I am stumped. Iwlwifi is being loaded against the device, but no interface is being created. Perhaps some googling is needed.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 02:38 PM - #Permalink
    Resolved
    0 votes
    When typed "lspci -knn" in the clearos pc command line I get this line, which is not showing up when I use Putty.


    Network controller [0280]: Intel Corporation Device [8086:a370] (rev 10)
    Subsystem: Intel Corporation Device [8086:0034]
    Kernel modules: iwlwifi
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 02:13 PM - #Permalink
    Resolved
    0 votes
    login as: root
    root@192.168.1.1's password:
    Last login: Thu Feb 14 08:56:39 2019 from 192.168.1.121
    [root@gateway ~]# modprobe iwlwifi
    [root@gateway ~]# lsmod | grep iwlwifi
    iwlwifi 210814 0
    cfg80211 623433 1 iwlwifi

    [root@gateway ~]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether e0:d5:5e:f6:aa:82 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e2d5:5eff:fef6:aa82/64 scope link
    valid_lft forever preferred_lft forever
    3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e0:d5:5e:f6:aa:83 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global eno2
    valid_lft forever preferred_lft forever
    inet6 fe80::e2d5:5eff:fef6:aa83/64 scope link
    valid_lft forever preferred_lft forever
    4: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp
    inet 70.54.90.160 peer 10.11.2.41/32 scope global ppp0
    valid_lft forever preferred_lft forever
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 01:54 PM - #Permalink
    Resolved
    0 votes
    That is really odd. It shows the device but is not loading the module. Is there any output to "lsmod | grep iwlwifi"? If not, can you do a:
    modprobe iwlwifi
    lsmod | grep iwlwifi
    If the lsmod then returns something, can you do another "ip addr show"?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 01:17 PM - #Permalink
    Resolved
    0 votes
    [root@gateway ~]# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether e0:d5:5e:f6:aa:82 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e2d5:5eff:fef6:aa82/64 scope link
    valid_lft forever preferred_lft forever
    3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e0:d5:5e:f6:aa:83 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global eno2
    valid_lft forever preferred_lft forever
    inet6 fe80::e2d5:5eff:fef6:aa83/64 scope link
    valid_lft forever preferred_lft forever
    4: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp
    inet 76.64.162.167 peer 10.11.2.41/32 scope global ppp0
    valid_lft forever preferred_lft forever
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 01:16 PM - #Permalink
    Resolved
    0 votes
    login as: root
    root@192.168.1.1's password:
    Last login: Thu Feb 14 08:01:43 2019 from 192.168.1.121
    [root@gateway ~]# lspci -knn
    00:00.0 Host bridge [0600]: Intel Corporation Device [8086:3e1f] (rev 08)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:5000]
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e91]
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
    Kernel driver in use: i915
    Kernel modules: i915
    00:12.0 Signal processing controller [1180]: Intel Corporation Device [8086:a379 ] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:8888]
    00:14.0 USB controller [0c03]: Intel Corporation Device [8086:a36d] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:5007]
    Kernel driver in use: xhci_hcd
    00:14.2 RAM memory [0500]: Intel Corporation Device [8086:a36f] (rev 10)
    Subsystem: Intel Corporation Device [8086:7270]
    00:14.3 Network controller [0280]: Intel Corporation Device [8086:a370] (rev 10)
    Subsystem: Intel Corporation Device [8086:0034]
    Kernel modules: iwlwifi
    00:16.0 Communication controller [0780]: Intel Corporation Device [8086:a360] (r ev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:1c3a]
    00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a352] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:b005]
    Kernel driver in use: ahci
    Kernel modules: ahci
    00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:a33d] (rev f0)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:1d.0 PCI bridge [0604]: Intel Corporation Device [8086:a330] (rev f0)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
    00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:a304] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:5001]
    00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a348] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:a0c3]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
    00:1f.4 SMBus [0c05]: Intel Corporation Device [8086:a323] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:5001]
    Kernel driver in use: i801_smbus
    Kernel modules: i2c_i801
    00:1f.5 Serial bus controller [0c80]: Intel Corporation Device [8086:a324] (rev 10)
    Subsystem: Intel Corporation Device [8086:7270]
    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) I2 19-V [8086:15bc] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
    Kernel driver in use: e1000e
    Kernel modules: e1000e
    01:00.0 Ethernet controller [0200]: Intel Corporation I211 Gigabit Network Conne ction [8086:1539] (rev 03)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
    Kernel driver in use: igb
    Kernel modules: igb
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:59 PM - #Permalink
    Resolved
    0 votes
    My egrep command has cut some of the output I wanted. Can you just do a full "lspci -knn" and only post the output from the device using the iwlwifi module. It looks like your wireless device is being detected. Id "ip link show" does not see it, can you try "ip addr show". I am trying to find a way of identifying the device name.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:17 PM - #Permalink
    Resolved
    0 votes
    Here is the output:
    login as: root
    root@192.168.1.1's password:
    Last login: Thu Feb 14 07:07:25 2019 from 192.168.1.121
    [root@gateway ~]# ^C
    [root@gateway ~]# lspci -knn | egrep -i 'eth|wifi|wire' -A 3
    Kernel modules: iwlwifi
    00:16.0 Communication controller [0780]: Intel Corporation Device [8086:a360] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:1c3a]
    00:17.0 SATA controller [0106]: Intel Corporation Device [8086:a352] (rev 10)
    --
    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) I219-V [8086:15bc] (rev 10)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
    Kernel driver in use: e1000e
    Kernel modules: e1000e
    01:00.0 Ethernet controller [0200]: Intel Corporation I211 Gigabit Network Connection [8086:1539] (rev 03)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
    Kernel driver in use: igb
    Kernel modules: igb
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 08:02 AM - #Permalink
    Resolved
    0 votes
    If you're using PuTTy to access ClearOS from a PC, you can copy text just by selecting it and paste it into the forum. You can also paste into PuTTy by right-clicking. I believe the forum supports the jpg and png formats for pictures, but it is much better and easier to read if you can paste text, and preferably, between "code" tags (the piece of paper icon with a <> on it).
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:44 AM - #Permalink
    Resolved
    0 votes
    I took a picture of the output and trying attach it as file. I tried Word, Excell and PDF but seems to unsupported format.

    How do I upload the output file?

    Thanks,
    Ravi
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:40 AM - #Permalink
    Resolved
    0 votes
    Here is file
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:38 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    Output is in the attached file
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:38 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    Output is in the attached file
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 14 2019, 12:36 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    Output is in the attached file
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 13 2019, 08:14 PM - #Permalink
    Resolved
    0 votes
    Sorry:
    lspci -knn | egrep -i 'eth|wifi|wire' -A 3
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 13 2019, 06:58 PM - #Permalink
    Resolved
    0 votes
    Try it without the parenthesis and with double ||'s, or even individually, so
    lspci -knn | egrep -i eth||wifi||wire -A 3
    or
    lspci -knn | egrep -i eth -A 3
    and
    lspci -knn | egrep -i wifi -A 3
    and
    lspci -knn | egrep -i wire -A 3
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 13 2019, 06:42 PM - #Permalink
    Resolved
    0 votes
    I am getting an error message:

    -bash: syntax error near unexpected token '('
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 13 2019, 12:17 PM - #Permalink
    Resolved
    0 votes
    What is the output of:
    lspci -knn | egrep -i (eth|wifi||wire) -A 3
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 13 2019, 03:55 AM - #Permalink
    Resolved
    0 votes
    I tried "ip link show", but no wifi device is listed. attached files is a pic of screen output.

    Not sure wifi device (two radios) not showing?

    Thanks,
    Ravi
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 08 2019, 05:02 PM - #Permalink
    Resolved
    0 votes
    The underlying app, hostapd supports n and ac but you'll have to configure it manually. It gets a bit more tricky if you have dual radios and the show themselves as different NICs. The big disadvantage of using ClearOS directly as an AP is that you generally end up with the antennae in some place which is not optimal for location coverage e.g my server is in my attic but my AP is in the middle of the house, wired into my LAN.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 08 2019, 04:14 PM - #Permalink
    Resolved
    0 votes
    Just plug a wifi router into your ClearOS network without using the WAN port on it or the DHCP server on it. Just use the LAN ports on it and use COS' DHCP server. Works like a charm as an access point.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 08 2019, 04:00 PM - #Permalink
    Resolved
    0 votes
    Thanks Nick for the response.

    I thought it would support N and AC.


    I am not going to use it for WI-FI AP without N or AC supported.


    Regards,

    Ravi
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 08 2019, 09:12 AM - #Permalink
    Resolved
    0 votes
    Unfortunately one of the developers chose to remove Wireless support and I have been unable to get the decision reversed. It was never good as a WAN as it only used WEP security, but it functioned adequately as an AP with WPA/PSK or Radius and 802.11g (no n or ac). I believe it can still be configured, but manually.

    You should have an ifcfg file associated with your NIC, something like /etc/sysconfig/network-scripts/ifcfg-wlp0s18f2u2. If not create one, but you'll need to look through "ip link show" to identify the device name. The contents of mine is:
    DEVICE=wlp0s18f2u2
    TYPE="Wireless"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    IPADDR="192.168.199.1"
    NETMASK="255.255.255.0"
    The second bt of the file name should match the DEVICE. You should be able to bring it up with an "ifup wlp0s18f2u2" and then configure it as an AP using the Access Point Settings and the DHCP server still works
    The reply is currently minimized Show
Your Reply