Community Forum

Resolved
0 votes
For the life of me I can't get flexshare working.

Even on my local network it still refuses to connect.


This is from FileZilla

Status: Connecting to 10.0.0.1:990...
Status: Connection established, initializing TLS...
Status: Verifying certificate...
Status: TLS connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.5b Server (FTP) [::ffff:10.0.0.1]
Command: USER micko
Response: 331 Password required for micko
Command: PASS ************
Response: 530 Login incorrect.
Error: Critical error: Could not connect to server

This is what I get from id micko

id micko
uid=2004(micko) gid=63000(allusers) groups=63000(allusers),60000(openvpn_plugin),60001(user_certificates_plugin),1000513(domain_users),60003(ftp_plugin),60004(ftbac)

The share is shared with the group ftbac which I am apart of.
I have reset the password
I have deleted and recreated the user
I can log into the web interface with the user

Can some guidance on what to do would be great because I am pulling my hair out here trying to figure out why it won't work.
Tuesday, December 05 2017, 09:28 AM
Share this post:
Responses (8)
  • Accepted Answer

    Wednesday, December 06 2017, 10:42 PM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    Still the same issue, it does prompt me for a certificate but still fails.
    I reset the password to '123456' and 'password' and still both don't allow me to connect.

    Status: Connecting to 10.0.0.1:21...
    Status: Connection established, waiting for welcome message...
    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Command: USER micko
    Response: 331 Password required for micko
    Command: PASS ************
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 10:03 PM - #Permalink
    Resolved
    0 votes
    Can you stick with port 21 and no encryption while testing as it removes a couple of variables from the equation?

    I must say I am struggling with this one. My FTP access works fine with port 21 and 990. 990 gives me a certificate prompt with WinSCP but then connects. 21 works directly.

    Do you have any non-alpha-numeric characters in micko's password? If you do, can you test with a basic password?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 09:35 PM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    I have installed and initialised the Windows Networking and still the same error message.

    Status: Connecting to 10.0.0.1:990...
    Status: Connection established, initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established, waiting for welcome message...
    Response: 220 ProFTPD 1.3.5b Server (FTP) [::ffff:10.0.0.1]
    Command: USER micko
    Response: 331 Password required for micko
    Command: PASS ************
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 09:01 PM - #Permalink
    Resolved
    0 votes
    There is something in the back of my mind but I'm not sure. Have you installed and initialised Windows Networking? I think it may be necessary, including the initialisation.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 08:47 PM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    I can confirm the user has been enabled for FTP access
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 08:05 PM - #Permalink
    Resolved
    0 votes
    Has the user "micko" been authorised to use FTP. You can check by going into Webconfig > Server > FIle > FTP Server, then in App Policies > Edit members. Or you can go via the user setup sereen.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 06 2017, 05:56 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    FTP enabled.
    https://puu.sh/yApmT/f300829587.png

    The contents of flex-990.conf is as follows:

    #----------------------------------------------------------------
    # WARNING: This file is automatically created by webconfig.
    #----------------------------------------------------------------

    <VirtualHost 1.41.6.14 10.0.0.1>
    Port 990
    DefaultRoot /var/flexshare/shares/
    RequireValidShell off
    AuthPam on
    AuthPAMConfig proftpd
    PassivePorts 60000 60999
    CapabilitiesEngine on
    CapabilitiesSet +CAP_CHOWN

    <Limit LOGIN CDUP PWD XPWD LIST PROT PASV>
    AllowAll
    </Limit>
    <Limit ALL>
    DenyAll
    </Limit>

    <IfModule mod_tls.c>
    TLSEngine on
    TLSLog /var/log/tls.log
    TLSOptions NoCertRequest UseImplicitSSL
    TLSRequired off
    TLSRSACertificateFile /etc/pki/CA/bootstrap.crt
    TLSRSACertificateKeyFile /etc/pki/CA/bootstrap.key
    TLSVerifyClient off
    </IfModule>


    # DNR:Webconfig start - plexupload
    <Directory /var/flexshare/shares/plexupload>
    AllowOverwrite on
    AllowRetrieveRestart on
    AllowStoreRestart on
    DisplayChdir .flexshare-group.txt TRUE
    HideNoAccess on
    HideFiles (.flexshare)
    GroupOwner "ftbac"
    Umask 0113 0002
    <Limit CWD READ WRITE DIRS PORT QUIT PASV>
    AllowGroup "ftbac"
    IgnoreHidden on
    </Limit>
    <Limit ALL>
    DenyAll
    </Limit>
    </Directory>
    # DNR:Webconfig end - plexupload

    </VirtualHost>


    Here is filezilla's reply on port 21

    Status: Connecting to 10.0.0.1:21...
    Status: Connection established, waiting for welcome message...
    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Command: USER micko
    Response: 331 Password required for micko
    Command: PASS ************
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 05 2017, 02:42 PM - #Permalink
    Resolved
    0 votes
    Can you confirm if you have enabled the flexshare for ftp access?

    What is the contents of /etc/proftpd.d/flex-990.conf?

    Also can you try on port 21 first?
    The reply is currently minimized Show
Your Reply