Forums

Todd
Todd
Offline
Resolved
0 votes
I can't installl clearos-devel on clearos 6.4 or 6.5 beta

yum --enablerepo=clearos-core,clearos-developer,clearos-epel install clearos-devel app-devel

Get the following error.
---> Package php-phpunit-PHPUnit.noarch 0:3.7.22-1.el6 will be installed
--> Processing Dependency: php-pear(pear.symfony.com/Yaml) < 3 for package: php-phpunit-PHPUnit-3.7.22-1.el6.noarch
--> Processing Dependency: php-pear(pear.symfony.com/Yaml) >= 2.0.0 for package: php-phpunit-PHPUnit-3.7.22-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: php-phpunit-PHPUnit-3.7.22-1.el6.noarch (clearos-epel)
Requires: php-pear(pear.symfony.com/Yaml) < 3
Error: Package: php-phpunit-PHPUnit-3.7.22-1.el6.noarch (clearos-epel)
Requires: php-pear(pear.symfony.com/Yaml) >= 2.0.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Monday, December 09 2013, 05:41 AM
Share this post:
Responses (3)
  • Accepted Answer

    Tuesday, December 17 2013, 02:14 AM - #Permalink
    Resolved
    0 votes
    It was fixed upstream, so I removed the temporary workaround. That was fast EPEL guys :-)
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 09 2013, 10:28 PM - #Permalink
    Resolved
    0 votes
    The upstream EPEL bug report has been submitted:

    https://bugzilla.redhat.com/show_bug.cgi?id=1039756

    As an interim workaround, I have pushed the two required packages (php-symfony-common and php-symfony-yaml) into the ClearOS developer repository, so you should be able to install the developer tools in a couple of hours. The software packages in question are not a critical part of the development framework, so it's not a big concern at the moment.

    Thanks for reporting the issue!
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 09 2013, 09:48 PM - #Permalink
    Resolved
    0 votes
    That looks like an EPEL upstream packaging problem! I'll submit a bug report and dig up the old version to get things working again. More to come.
    The reply is currently minimized Show
Your Reply