Community Forum

Resolved
0 votes
Hello,
I’m new to ClearOS, and I searched forum for my question (even Zentyal forum). There are similar questions but no answer solved my problem.

I use VM image of ClearOS Enterprise 5.2 on VMWare Workstation 7.1.2 on Windows 7 Ultimate. There are two physical NIC’s on machine. On VMWare, both NIC’s are attached as Bridge Mode, which means ClearOS on Virtual Machine is directly connected to Wireless Access Point.

My Network topology is below:

ADSL Modem ------- Windows 7 (Clear OS on VM) ------- Wireless Access Point ------- Other Machines

ADSL Modem IP: Works bridge mode, so it has no IP on WAN. Has 192.168.0.1 on LAN for Web GUI, but is irrelevant for this case.
Windows 7 NIC 1 (connected to Access Point): 192.168.1.2 (I use it as a server for music, video etc.)
Windows 7 NIC 2 (connected to ADSL Modem): I don’t know what it should be.
ClearOS LAN: 192.168.1.1
ClearOS WAN (pppoe): 88.X.Y.Z

The problem is:
I want to connect Remote Desktop (RDP) to Windows 7 machine from office over Internet through publick IP (88.X.Y.Z). I forwarded port 3389 to 192.168.1.2, opened the port in Firewall. After login screen, connection drops. For testing purposes, I forwarded other ports for other server applications such as Calibre Book Management Web Interface etc. All they work well.

Worst, I forwarded port 3389 to another machine in the network, say to 192.168.1.104, and Remote Desktop connection even cannot start session over Internet through public IP.
Remote Desktop is enabled in both machines (192.168..1.2 and 104) and they are connectible. I can connect when I connect them in local network.

Definitely I miss something. Either in ClearOS or in VMWare network configuration. Please help. :(

P.S. Same problem and conditions also happened in Zentyal.
Friday, March 18 2011, 08:50 AM
Share this post:
Responses (11)
  • Accepted Answer

    Roberto
    Roberto
    Offline
    Friday, November 18 2011, 04:51 PM - #Permalink
    Resolved
    0 votes
    tnx.! i was having the same issue, i solved this like you say, i had the wrong Gateway in my ClearOS. tnx.!
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 28 2011, 10:23 AM - #Permalink
    Resolved
    0 votes
    Additional Info:
    I connected with TeamViewer to observe what happens when I try to connect with RDP. I checked event viewer and found error below:

    The terminal server security layer detected an error in the protocol stream and has disconnected the client.

    Please note that I can connect RDP when I use adsl modem/router instead of ClearOS.

    Any suggestion?
    The reply is currently minimized Show
  • Accepted Answer

    marports
    marports
    Offline
    Monday, March 21 2011, 03:07 PM - #Permalink
    Resolved
    0 votes
    Ok, i found the answer.

    The gateway ip of my RDP serveur wasn't the same as my ClearOS. The technical guy is charge of the server had changed it.
    GW clearOS = GW RDP Server

    now is OK

    regards stéphane
    The reply is currently minimized Show
  • Accepted Answer

    marports
    marports
    Offline
    Monday, March 21 2011, 01:44 PM - #Permalink
    Resolved
    0 votes
    Hello all !
    I am new too on clearOS. Same as you. My RDP acces throught ClearOS is down !
    It was ok during One week then poufffff.
    And this with out any VPN access.

    On my lan, the connection rdp to my server is OK
    Bur from outside no! I open the 3389 on my inside rule and forwarded it to my ip lan on the 3389.
    normal thing

    the WEb acces is OK
    the pop is ok
    the smtp is OK
    the webmail is ok.

    Please have you got an answer ?

    regards

    Stéphane R
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 21 2011, 09:02 AM - #Permalink
    Resolved
    0 votes
    Thank you John and Nick,

    I'm using other solutions like TeamViewer, VNC etc. temporary. However I want to solve this particular problem because of two reasons. First, I want to learn the solution for future reference. Second, RDP connections seems more responsive to me.

    John, you understand RDP problem correctly. I googled a whole day before posting this forum for RDP problems, VMWare problems with RDP, Zentyal forums. I found only similar problems without a solution or different solutions for irrelevant reasons.

    I can connect same Windows 7 machine with RDP when I use my wireless router (TP-Link 941ND). So RDP seems OK.

    Does anyone have any idea if my network settings are correct for VMWare? (described in my first post.)
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 19 2011, 09:06 PM - #Permalink
    Resolved
    0 votes
    I use TightVNC for remote access. As the free version only supports eight character passwords I access it through a VPN (either IPSec or OpenVPN).
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Saturday, March 19 2011, 08:50 PM - #Permalink
    Resolved
    0 votes
    Hi Ozum,

    When I understand you correctly, you are able to connect with RDP, but when you do the connection breaks.
    This sounds to me like an RDP issue and I've encountered plenty of them myself ... :angry:
    That's the reason why I quit using RDP and started experimenting with the following (free) tools with a lot more options, much more stable & secure than RDP:
    [ul]TeamViewer (no reg. required, but only free for personal use)[/ul][ul]Mikogo(reg. required, but free )[/ul]
    Or you could try to Google the RDP problem itself, but AFAIK the ClearOS settings are no longer the problem.

    Some additional port info:
    [ul]GRC.com[/ul][ul]PortForward.com[/ul][ul]M$ network port requirements[/ul]
    Some additional bandwidth info:
    [ul]Port Ranges in the Bandwidth Rules[/ul]
    Greetings & goodluck,

    John
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 19 2011, 07:34 AM - #Permalink
    Resolved
    0 votes
    I forwarded correct IP, because I see login page in Remote Desktop, I enter my password and only a few seconds later before seeing desktop, connection drops. All obstacles in client machine (i.e. Windows firewall) is already disabled for testing purposes. There is no router besides ClearOS. In ClearOS I tried either way (port opened and closed)
    The reply is currently minimized Show
  • Accepted Answer

    Duncan Rix
    Duncan Rix
    Offline
    Friday, March 18 2011, 02:39 PM - #Permalink
    Resolved
    0 votes
    Hi there. I see you say it works internaly so in thery it should work if you have port forward to the correct IP. But just to hummer my try dissabling your windows firewall as a test.

    Also depending on your setup you may have to open 3389 on your router

    Hope this helps in some way
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 18 2011, 02:27 PM - #Permalink
    Resolved
    0 votes
    Thank you John. I first tried without opening port. Neither of them worked.
    The reply is currently minimized Show
Your Reply