Forums

nuke
nuke
Offline
Resolved
0 votes
Hi.

I was trying to find the clamav log in the webconfig:log list but I don't have one. COS 5.2

I see that I have a daily cron job that runs clamscan each day in the wee hours. But I have neither a record of the run in the Webconfig:Server:File Scanner: Last run nor do I have any log in the Report:Logs.

What do I need to check or set to get the clamscan to create a log?

Thanks in advance.
Wednesday, July 11 2012, 07:05 PM
Share this post:
Responses (3)
  • Accepted Answer

    nuke
    nuke
    Offline
    Friday, June 21 2013, 07:26 PM - #Permalink
    Resolved
    0 votes
    Still having this problem but figured it out today.

    Since I'm forgetful, if I don't post how I fixed the problem, I'll probably forget again in a months time.

    Solution:
    Check the conf file in /etc/.

    The clamd.conf file in my install didn't have logging enabled. Why I have no idea since I've never touched this file and it is still has the same date as the base install.

    vi /etc/clamd.conf


    Look for
    # Uncomment this option to enable logging.
    # LogFile must be writable for the user running daemon.
    # A full path is required.
    # Default: disabled
    # LogFile /var/log/clamav/clamd.log

    Uncomment the last line above.
    You may wish to change this:
    LogFileMaxSize 1M

    Then restart
    service clamd restart
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Wednesday, July 11 2012, 07:54 PM - #Permalink
    Resolved
    0 votes
    Hmm, I don't have the clamd.log.

    But I do have the /var/log/clamav directory with following rwx / ownership / group:

    drwxr-xr-x 2 clamav clamav 1024 Apr 20 2011 clamav

    How do I get COS 5.2 to produce the log file?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 11 2012, 07:14 PM - #Permalink
    Resolved
    0 votes
    Hi Nuke,

    Just checked on my ClearOS 6.2 server. I have clamd.log


    /var/log/clamav/clamd.log
    The reply is currently minimized Show
Your Reply