Forums

Resolved
0 votes
The ClearOS 6.5.0 Beta 3 release is starting to flow to the "clearos-updates-testing" software repository. I'll follow up in this forum thread when the ISOs are released.

Edit: the ISOs are now available :-) The Release Notes have all the details.
Monday, December 02 2013, 04:04 PM
Share this post:
Responses (24)
  • Accepted Answer

    Tuesday, January 28 2014, 08:06 PM - #Permalink
    Resolved
    0 votes
    Does that even work? I guess the PPPoE engine in the ClearOS API is insisting on a real network interface. In theory, you could lift this restriction with some coding changes.
    The reply is currently minimized Show
  • Accepted Answer

    brian
    brian
    Offline
    Tuesday, January 28 2014, 05:26 PM - #Permalink
    Resolved
    0 votes
    Peter,

    just need to ask on COS 6.x, is it not possible for me to create a pppoe interface on top of a VLAN interface? Tried and noticed that it cannot be done over the web UI..
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 06:08 PM - #Permalink
    Resolved
    0 votes
    Tim, Peter, thanks both for your replies.Its clear to me now.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 05:16 PM - #Permalink
    Resolved
    0 votes
    Another customer ran into this issue not too long ago! If you have both a Zarafa Community and Zarafa Small Business subscription, the version mismatch can happen (and will happen again in the future). Please submit a technical support request to move the Zarafa Community subscription. Once that is done, the version conflict will no longer occur.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 05:08 PM - #Permalink
    Resolved
    0 votes
    Peter - it's because the ClearOS Pro repo contains 7.0.13, but Community repo 7.0.15... normally they are in sync. You have a 'problem' because you have both enabled, and yum is preventing you from upgrading because the newer matching version of Zarafa-backup is not available. As I said you can wait until the Pro version is updated (depends on the ClearCenter team) or you can remove zarafa-backup, and manually upgrade it afterwards from the Zarafa RPMs.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 03:34 PM - #Permalink
    Resolved
    0 votes
    Sorry to bother, but as I said we have bought a clearos zarafa subscription (5 users) and also have an 80 user subscription bought here in Holland.

    I have installed the clearos zarafa 5 user package in the webconfig.

    In the past I haven't had to uninstall 'backup' and re-install and this is not very efficient for future backups. I would like to have the system functioning correctly.

    Zarafa shows clearly that Zarafa Small Business for ClearOS is installed, however both the professional and zarafa-community repos are activated -

    Do I need to deactivate - private-clearcenter-zarafa-community, and if so how can I do this? I can't find it in yum/repos and in the clearos interface I can't install it.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 01:19 PM - #Permalink
    Resolved
    0 votes
    Hi Peter,

    Zarafa-backup is not available in the ClearOS Community edition repos, and the ClearCenter-Zarafa-Pro pro repo is only available if you purchase through the Marketplace. Therefore yum cannot complete the transaction because it cannot upgrade the whole zarafa package. Therefore you'll need to remove zarafa-backup temporarily and manually reinstall using the provided RPMs from Zarafa if you want to maintain an independant Zarafa system
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 07:10 AM - #Permalink
    Resolved
    0 votes
    Thanks for the answer, and it explains why its not working, but leads to a further question - We actually have an 80 user license that was bought a few years ago here in Holland and is automatically renewed. We like to keep independent - imagine that we got bored with clearos ( : -)

    To work around the clearos thing we bought a 5 user license, and forgot to install it after migration to version 6 - hence this problem.

    However I can’t seem to activate the 5 user license that I bought from Clearos for 70 dollars in November.

    I have followed the instructions on the Zarafa website that explain the creation of a file “1” (in the “base” file is the main CAL for 80 users).

    What to do so that the system recognises that we have a license for zarafa and can therefore update. Of course we use the brick backup system …
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 20 2014, 09:23 PM - #Permalink
    Resolved
    0 votes
    Hi Peter,

    It looks like you had a Zarafa Professional subscription at one point (evaluation?) but the subscription has expired. You will need to remove the zarafa-backup package in order to upgrade Zarafa Community:

    yum remove zarafa-backup


    Once the Zarafa issue is cleaned up, you will be able to upgrade to the ClearOS Professional 6.5.0 release (now available).
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, January 19 2014, 02:12 PM - #Permalink
    Resolved
    0 votes
    When will is be possible to update 6.5.0 Beta 3 (professional) to the final version? I am still getting

    Error: Package: zarafa-backup-7.0.13-41388.x86_64 (@private-clearcenter-zarafa-pro)
    Requires: zarafa-client = 7.0.13-41388
    Removing: zarafa-client-7.0.13-41388.x86_64 (@private-clearcenter-zarafa-community)
    zarafa-client = 7.0.13-41388
    Updated By: zarafa-client-7.0.15-42709.x86_64 (private-clearcenter-zarafa-community)
    zarafa-client = 7.0.15-42709

    - or have I got something wrong?

    - also, today Zarafa has crashed for the third Sunday in a row - it needs a forced kill to be able to restart it. Is this something heard of before? (I remember that a coupld of years ago webconfig crashed every Sunday for some reason)

    Thanks, regards, Peter
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2013, 04:21 PM - #Permalink
    Resolved
    0 votes
    Yes, the Network Map update was pushed to the testing repositories yesterday. You need to have the Professional Beta installed, then run:

    yum --enablerepo=clearos-professional-testing install app-network-map
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 10 2013, 07:16 PM - #Permalink
    Resolved
    0 votes
    Peter Baldwin wrote:
    We'll have the Professional Edition update out on Tuesday, and that will include the latest Network Map release.


    Thanks, Peter. Is this still on track for today?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 09 2013, 04:37 PM - #Permalink
    Resolved
    0 votes
    I'm glad to see the issue was resolved.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 06 2013, 07:18 AM - #Permalink
    Resolved
    0 votes
    Had a similar problem as with the previous beta and again not fixable using the usual "yum clean all", rebuild rpm database etc options

    error: Failed dependencies:
    libebook-1.2.so.9 is needed by (installed) control-center-1:2.28.1-38.el6.i686
    libecal-1.2.so.7 is needed by (installed) gnome-panel-2.30.2-15.el6.i686
    libedataserver-1.2.so.11 is needed by (installed) gnome-panel-2.30.2-15.el6.i686
    libedataserverui-1.2.so.8 is needed by (installed) gnome-panel-2.30.2-15.el6.i686
    evolution-data-server >= 1.9.1 is needed by (installed) gnome-panel-2.30.2-15.el6.i686
    [root@yenny ~]# rpm -e evolution-data-server control-center gnome-panel
    error: Failed dependencies:
    control-center is needed by (installed) gnome-session-2.28.0-18.el6.i686
    gnome-panel >= 2.20.1-5 is needed by (installed) gnome-applets-1:2.28.0-7.el6.i686
    [root@yenny ~]# rpm -e evolution-data-server control-center gnome-panel gnome-session
    error: Failed dependencies:
    gnome-panel >= 2.20.1-5 is needed by (installed) gnome-applets-1:2.28.0-7.el6.i686
    gnome-session = 2.28.0-18.el6 is needed by (installed) gnome-session-xsession-2.28.0-18.el6.i686

    Finally fixed by simply removing the following and re-installing...
    evolution-data-server control-center gnome-panel gnome-session gnome-applets gnome-session-xsession
    The reply is currently minimized Show
  • Accepted Answer

    anwoke8204
    anwoke8204
    Offline
    Friday, December 06 2013, 02:15 AM - #Permalink
    Resolved
    0 votes
    will the network map be comming to the community edition, I do servers for a couple of non profit organizations, and the network map could help us out
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 06 2013, 02:09 AM - #Permalink
    Resolved
    0 votes
    Ben Edwards wrote:
    When will the license be adjusted for Network Map? I'm still stuck at 10 devices on an Enterprise installation. :)

    I forgot to push that one sooner -- sorry about that. We'll have the Professional Edition update out on Tuesday, and that will include the latest Network Map release.
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Thursday, December 05 2013, 06:26 PM - #Permalink
    Resolved
    0 votes
    Is not set Dynamic DNS!
    The reply is currently minimized Show
  • Accepted Answer

    CooperChi
    CooperChi
    Offline
    Thursday, December 05 2013, 03:35 AM - #Permalink
    Resolved
    0 votes
    Can I use ClearOS as a virtual switch,just like Open vSwitch?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 04 2013, 08:47 PM - #Permalink
    Resolved
    0 votes
    Hey Peter,

    When will the license be adjusted for Network Map? I'm still stuck at 10 devices on an Enterprise installation. :)
    The reply is currently minimized Show
  • Accepted Answer

    bartsidee
    bartsidee
    Offline
    Wednesday, December 04 2013, 05:30 PM - #Permalink
    Resolved
    0 votes
    Would it be possible to update this beta 3 release to a stable ClearOS 6.5 version when it is available?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 03 2013, 04:00 PM - #Permalink
    Resolved
    0 votes
    To add to David's response, the beta 3 release notes contain the highlights (cut and pasted here):

    - Build from source code from upstream's 6.5 release
    - Added "Cloud" category to apps and menu system
    - Moved "My Account" to new top-level menu
    - Improved usability in some areas

    The upgrade to upstream's 6.5 is by far the biggest and most significant change!
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 03 2013, 07:37 AM - #Permalink
    Resolved
    0 votes
    Hi anwoke,

    The roadmap page doesn't show features/bugs once all the items within the 'section' are marked as complete. If you click on 'change log' at the top of the page, this restores the full list view so you can see what has been previously fixed/added against each 'section'.
    The reply is currently minimized Show
  • Accepted Answer

    anwoke8204
    anwoke8204
    Offline
    Tuesday, December 03 2013, 05:31 AM - #Permalink
    Resolved
    0 votes
    whats the difference between beta 2 and beta 3?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 02 2013, 04:38 PM - #Permalink
    Resolved
    0 votes
    Great - thanks Peter!
    The reply is currently minimized Show
Your Reply