Community Forum

Resolved
2 votes
Hi all,

The ClearOS 7.3.0 Beta 1 release is now available via yum. You will first need to install and register a ClearOS 7 system. To upgrade the install to 7.3.0 Beta 1, run:

yum --enablerepo=clearos-updates-testing upgrade app-base
yum upgrade


Here is the full changelog: https://tracker.clearos.com/changelog_page.php?version_id=271

Technical Stuff

ClearOS veterans out there may notice a new yum repository: clearos-qa. What is that? Well, the repository roles have changed since ClearOS 6, so we needed to address a new workflow problem. The clearos-updates-testing repository in ClearOS 6 is for... well... testing updates. Packages in this repository have been verified by someone via the ClearOS 6 QA process. For this reason, all of our ClearOS 6 dog food servers run with this repository enabled!

In ClearOS 7, packages from the build system go directly into the clearos-updates-testing repository without a full QA process. As an end user, you can't tell which packages in clearos-updates-testing are ready for testing, and which packages are experimental builds that should be avoided. For this reason, the clearos-qa repository was born. All packages in clearos-updates-testing that pass the QA process will be moved to clearos-qa. We now have the ability to have a proper staging area for ClearOS 7 betas, and we also regain the ability to have our dog food servers running with clearos-qa enabled all the time.
Wednesday, January 18 2017, 03:56 PM
Like
2
Share this post:
Responses (33)
  • Accepted Answer

    Tuesday, February 21 2017, 04:23 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    It would be nice to have OpenVPN 2.4 pushed through at some point because of the SWEET32 vulnerability. It has not even got to epel-testing.

    In case anyone is interested the vulnerability can be mitigated with the current version of OpenVPN by adding "reneg-bytes 64000" to /etc/clients.conf.


    Hi Nick. I added a bug tracker:
    https://tracker.clearos.com/view.php?id=13151

    Now it's a matter of getting approval from ClearCenter.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 21 2017, 04:18 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Having (accidentally) upgraded my production server, I've had the cron daemon e-mail me an error overnight with a subject of:
    Cron <root@server> /usr/clearos/apps/software_repository/deploy/config-check
    and body:
    PHP notice: Undefined index: event_types - /usr/clearos/apps/events/libraries/Event_Utils.php (221)


    We'll tidy that up in an update this week.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 20 2017, 05:51 PM - #Permalink
    Resolved
    0 votes
    It would be nice to have OpenVPN 2.4 pushed through at some point because of the SWEET32 vulnerability. It has not even got to epel-testing.

    In case anyone is interested the vulnerability can be mitigated with the current version of OpenVPN by adding "reneg-bytes 64000000" to /etc/clients.conf.

    [edit]
    Big typo on the openvpn wiki, now fixed. reneg-bytes should be set to 64000000 and not 64000 as I originally posted.
    [/edit]
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 10:34 AM - #Permalink
    Resolved
    0 votes
    @Patrick
    Thanks. That fixed the warnings on the app/software_repository page. Let's see if cron now runs cleanly tonight. FIngers crossed....
    Nick
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 09:26 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Having (accidentally) upgraded my production server, I've had the cron daemon e-mail me an error overnight with a subject of:
    Cron <root@server> /usr/clearos/apps/software_repository/deploy/config-check
    and body:
    PHP notice: Undefined index: event_types - /usr/clearos/apps/events/libraries/Event_Utils.php (221)

    Nick,

    I'd the same error last night
    This is caused by the repository settings : https://serverip:81/app/software_repository
    You need to disable some repositories, like clearos-epel.
    They are mentioned on top of the page.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 09:15 AM - #Permalink
    Resolved
    0 votes
    Having (accidentally) upgraded my production server, I've had the cron daemon e-mail me an error overnight with a subject of:
    Cron <root@server> /usr/clearos/apps/software_repository/deploy/config-check
    and body:
    PHP notice: Undefined index: event_types - /usr/clearos/apps/events/libraries/Event_Utils.php (221)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 07:01 PM - #Permalink
    Resolved
    0 votes
    performed the update from 7.3b1 to 7.3b3 with no issues so far
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 05:46 PM - #Permalink
    Resolved
    0 votes
    Oh sh1t. I've accidentally upgraded my Production box rather than VM. No wonder the download was so big. At least it still appears to be Pro and has not downgraded unless I'm wrong. Bad day at the office. :(
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 05:36 PM - #Permalink
    Resolved
    0 votes
    Similar to Tony, my VM upgrade from 7.3Beta1 to 7.3Beta3 went through cleanly and the system remained registered.

    I have one question and one sort of issue.

    If I upgrade 7.2 Business to beta 3 does it revert to Community?

    My issue is with the support files for app-attack-detector. There was a thread on it a while ago but after I made my suggestion it fizzled out and there was no response. In various rpm's you are now packaging conf files which go into /etc/fail2ban/jail.d. The list from my upgrade was:
    /etc/fail2ban/jail.d/clearos-cyrus-imap.conf.rpmnew
    /etc/fail2ban/jail.d/clearos-postfix-sasl.conf.rpmnew
    /etc/fail2ban/jail.d/clearos-proftpd.conf.rpmnew
    /etc/fail2ban/jail.d/clearos-sshd-ddos.conf.rpmnew
    /etc/fail2ban/jail.d/clearos-sshd.conf.rpmnew
    To me it is wrong to bring them in enabled as they will immediately impact you if you install or have an installation of fail2ban (rather than app-attack-detector). I would have thought the best way of handling these files is to bring them in disabled (as they come with the underlying package such as proftpd and not with app-attack-detector). Then if you install app-attack-detector, in its post-install script you could flip them to enabled.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 03:52 AM - #Permalink
    Resolved
    0 votes
    Just completed another upgrade ClearOS 7.2 -> 7.3 Beta
    No registration problems this time...
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 30 2017, 07:09 PM - #Permalink
    Resolved
    0 votes
    With the help of Charles @clearos support team my system is registered again. :)
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, January 28 2017, 09:00 AM - #Permalink
    Resolved
    0 votes
    @Ben,
    There must be some sort of issue there. A week or so back I upgraded my Community 7.2 VM to 7.3 and, like Tony, it also became unregistered. Re-registering as a re-install was straightforward. Unfortunately I have no way of rolling back to see what went wrong.
    Nick
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, January 28 2017, 08:51 AM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    For those on Home/Business who upgraded to 7.3, I couldn't reproduce the issue reported in this thread that your system becomes un-registered, but I could reproduce an issue where if it was unregistered, you would have issues with the re-install/upgrade option as described here.

    There's a fix on the way to the mirrors.....

    yum upgrade app-registration


    Should pull down 2.3.1-1.v7. If your Home or Business 7.2, now 7.3, is unregistered, this should allow you to register as a "Reinstal/Upgrade" properly.

    B.

    Ben

    Thanks for the quick support, but there no package available.

    yum upgrade app-registration
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    ClearCenter Marketplace: System not registered. Code: 3
    Loading mirror speeds from cached hostfile
    * clearos: ftp.nluug.nl
    * clearos-centos: download2.clearsdn.com
    * clearos-centos-updates: download2.clearsdn.com
    * clearos-contribs: ftp.nluug.nl
    * clearos-epel: download2.clearsdn.com
    * clearos-fast-updates: download2.clearsdn.com
    * clearos-infra: ftp.nluug.nl
    * clearos-qa: mirror3.egloo.ca
    * clearos-updates: ftp.nluug.nl
    No packages marked for update


    I've managed to download the packaged from the repository diectly http://mirror1-amsterdam.clearos.com/clearos/7.2.0/updates-testing/x86_64/RPMS/ and installed this:

    ================================================================================
    Package Arch Version Repository Size
    ================================================================================
    Updating:
    app-registration
    noarch 1:2.3.1-1.v7 /app-registration-2.3.1-1.v7.noarch 63 k
    app-registration-core
    noarch 1:2.3.1-1.v7 /app-registration-core-2.3.1-1.v7.noarch 132 k

    Transaction Summary
    ================================================================================
    Upgrade 2 Packages

    Total size: 195 k
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Updating : 1:app-registration-core-2.3.1-1.v7.noarch 1/4
    Updating : 1:app-registration-2.3.1-1.v7.noarch 2/4
    Cleanup : 1:app-registration-2.3.0-1.v7.noarch 3/4
    Cleanup : 1:app-registration-core-2.3.0-1.v7.noarch 4/4
    Verifying : 1:app-registration-core-2.3.1-1.v7.noarch 1/4
    Verifying : 1:app-registration-2.3.1-1.v7.noarch 2/4
    Verifying : 1:app-registration-core-2.3.0-1.v7.noarch 3/4
    Verifying : 1:app-registration-2.3.0-1.v7.noarch 4/4

    Updated:
    app-registration.noarch 1:2.3.1-1.v7
    app-registration-core.noarch 1:2.3.1-1.v7

    Complete!
    [root@pdebrabander tmp]# service webconfig restart



    Unfortunately no luck.
    It looks my registration is lost in your system.

    http://i66.tinypic.com/29wx0xz.png

    http://i68.tinypic.com/2i0uc6r.png
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, January 28 2017, 08:48 AM - #Permalink
    Resolved
    0 votes
    Jon Eames wrote:

    Patrick,

    My registration problem was because I was using a paid for Home Essentials version which was not expected to be upgraded to the beta. I could not resolve this directly on my server and had to contact ClearOS for them to resolve at their end. I am not sure exactly what was done to resolve it but I think you will also have to contact them directly. In my case this issue was resolved very quickly and easily. Make sure you have rebooted the server after the upgrade also.
    My initial point of contact was through the purchases@clearcenter.com who forwarded my system details to the correct person to resolve.


    I think i have the same problem as you.
    It looks my system is disappered and i can not select a system to register.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 27 2017, 11:50 PM - #Permalink
    Resolved
    0 votes
    For those on Home/Business who upgraded to 7.3, I couldn't reproduce the issue reported in this thread that your system becomes un-registered, but I could reproduce an issue where if it was unregistered, you would have issues with the re-install/upgrade option as described here.

    There's a fix on the way to the mirrors.....

    yum upgrade app-registration


    Should pull down 2.3.1-1.v7. If your Home or Business 7.2, now 7.3, is unregistered, this should allow you to register as a "Reinstal/Upgrade" properly.

    B.
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Friday, January 27 2017, 10:41 PM - #Permalink
    Resolved
    0 votes
    Patrick,

    My registration problem was because I was using a paid for Home Essentials version which was not expected to be upgraded to the beta. I could not resolve this directly on my server and had to contact ClearOS for them to resolve at their end. I am not sure exactly what was done to resolve it but I think you will also have to contact them directly. In my case this issue was resolved very quickly and easily. Make sure you have rebooted the server after the upgrade also.
    My initial point of contact was through the purchases@clearcenter.com who forwarded my system details to the correct person to resolve.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 27 2017, 08:30 PM - #Permalink
    Resolved
    0 votes
    Found the "settings" option under marketplace and cleared Cache.

    System registration is still not possible and my system looks not listed any more.
    The only thing i can to is a "New Install" with a 30-days Evaluation license
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 26 2017, 07:28 PM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    @Jon - your Marketplace should be populating the available apps properly now on your upgraded Business or Home. You may want to clear any cached data - In Webconfig, click on Settings (Gear Icon), then click on the "Clear Cache" button.

    B.


    Upgraded to 7.3b1 and system registration is not working..
    I can not find the Clear Cache" button in Webconfig under settings.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 24 2017, 01:23 PM - #Permalink
    Resolved
    0 votes
    @Jon - your Marketplace should be populating the available apps properly now on your upgraded Business or Home. You may want to clear any cached data - In Webconfig, click on Settings (Gear Icon), then click on the "Clear Cache" button.

    B.
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Monday, January 23 2017, 09:05 PM - #Permalink
    Resolved
    0 votes
    Hi Ben,
    Many thanks registration is complete, thank you for this very quick fix.

    regards

    Jon
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 23 2017, 06:02 PM - #Permalink
    Resolved
    0 votes
    You should be able to register your Home or Business edition that you upgraded to 7.3 now. Will have apps showing up in the marketplace properly by the end of the day.

    B
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 23 2017, 04:40 PM - #Permalink
    Resolved
    0 votes
    Tony Ellis wrote:
    I suspect ClearOS did not expect anybody with a paid for version to upgrade to a beta...
    Since you paid real money - raise a support ticket as I suspect there is nothing you can do at your end without ClearOS intervention...


    Yup, that's correct, but we should have planned for that scenario! The ISO install doesn't show Home/Business options available, but upgrading Home/Business via the command line is possible. There's nothing wrong with running the beta on Home/Edition, but the registration system does think those versions exist.

    We're on it.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 23 2017, 05:11 AM - #Permalink
    Resolved
    0 votes
    That's not quite right...

    Community is free - no formal support
    Home and Business are paid and varying levels of support...

    I suspect ClearOS did not expect anybody with a paid for version to upgrade to a beta...
    Since you paid real money - raise a support ticket as I suspect there is nothing you can do at your end without ClearOS intervention...

    see https://www.clearos.com/products/clearos-editions/clearos-7-compare-editions
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Monday, January 23 2017, 04:50 AM - #Permalink
    Resolved
    0 votes
    Hi,

    I upgraded a relatively clean 7.2 Home Essentials which i think is the community edition. I can still see the systemname in the Clear Center but I think i might have deleted the upgrade.
    A little knowledge is always a dangerous thing!

    regards

    Jon
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 23 2017, 04:17 AM - #Permalink
    Resolved
    0 votes
    My /etc/clearos/registration.conf is also empty...

    What edition of ClearOS 7 did you upgrade? - mine is Community...

    Here's my registration from the portal
    alex alex-1.poweredbyclear.com Community 7.3 Active
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Monday, January 23 2017, 03:54 AM - #Permalink
    Resolved
    0 votes
    Hi,

    Im getting closer, now after a reboot I have a register option, but this fails with a notice " invalid operating system type". No eligible systems are displayed. I note that the file in /etc/clearos/registration.conf is empty. I was hoping to find a saved copy of this file but I don't have this. Do you know the format of this file. I am thinking if this has the correct information then this might fix this error.

    regards

    J
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, January 22 2017, 05:07 AM - #Permalink
    Resolved
    0 votes
    Webconfig -> System -> Settings -> System Registration
    on mine...
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Sunday, January 22 2017, 04:10 AM - #Permalink
    Resolved
    0 votes
    Hi Tony,

    Yes I meant re-register not fix. Unfortunately there is no option to re-register in the marketplace. The error on the registration page is Error record not found displayed in a red font, so I am some what at a loss now. Everything else seems to be functional
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, January 22 2017, 03:38 AM - #Permalink
    Resolved
    0 votes
    By 'fix' do you mean re-register?

    If so, start webconfig and click to MARKETPLACE at the top of the page.
    When I did this it after a few seconds it displayed the registration page...

    I simply re-registered as an upgrade using the original details...

    Be careful - I found that the system name in the panel had been changed to the first character being a capital - the original was all lower case... I changed the name back to how it was initially...
    The reply is currently minimized Show
  • Accepted Answer

    Jon Eames
    Jon Eames
    Offline
    Sunday, January 22 2017, 03:09 AM - #Permalink
    Resolved
    0 votes
    Hi,
    I just ran also the upgrade to the beta which has proceeded smoothly but my system has also lost its registration records.
    Any pointers on how to fix this?
    regards
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 19 2017, 10:27 PM - #Permalink
    Resolved
    0 votes
    Upgraded another system to ClearOS 7.3 Beta 1

    This system also lost its registration and needed to be re-registered.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 18 2017, 09:57 PM - #Permalink
    Resolved
    0 votes
    Thanks - this upgraded my 7.3 test machine with a further 31 packages over what I had already done earlier...
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 18 2017, 05:09 PM - #Permalink
    Resolved
    0 votes
    The ISO that accompanies the beta 1 build is also now available and can be downloaded from any of the mirrors here:

    http://mirror.clearos.com/clearos/testing/daily_iso/

    The known bug here is that the installer will provide you with the ability to create a local user account which should NOT be done. ClearOS relies on directory services such as OpenLDAP and Samba directory. As such, set the password for root only and leave the other alone until this bug is fixed. The final version will not have this option enabled.

    Here is the bug.
    The reply is currently minimized Show
Your Reply