Community Forum

Share this post:
Responses (19)
  • Accepted Answer

    Friday, March 24 2017, 03:33 PM - #Permalink
    Resolved
    0 votes
    Please note Incorrect 7.3.0 ISO md5 sum on download web page: https://www.clearos.com/products/purchase/clearos-download Shows: SHA256sum: b4da8ffa10945e4d95478edb32f7a3dd9691f9a6c6d7820b1ffa346f6eb6a878 and does not match mirrors: 0ba358dddf233f1631db8bf48911c1a7838887a1c854980c5a1d17c1a59d5812 *ClearOS-DVD-x86_64-7.3.0.180516.iso
    The reply is currently minimized Show
  • Accepted Answer

    MikeCindi
    MikeCindi
    Offline
    Thursday, March 16 2017, 04:12 AM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    My bad....It's not enough to have the updated clearos-base pkg if you've already installed some of the web server or flexshare packages. You needed to also run:

    /usr/sbin/addsudo /usr/sbin/httpd app-flexshare-core


    B

    That seemed to fix the flexshare issue. Thank you.

    I noted on reboot (due to updated kernel today) that flexshares were not available. The folders were intact but they were empty.

    I have a couple of "custom" mounts that I add to /etc/clearos/flexshare.conf:
    storage:/mnt/storage which is physically /dev/sdb1
    backup:/mnt/backup which is physically /dev/sdc1
    When I checked mount points I noted that my root partition (/dev/sda2) was mounted on the COS generated flexshare directories (/var/flexshare/shares/backup and /var/flexshare/shares/storage)! Those two folders were empty too. This was easily fixed (umount /dev/sda2 twice although it was with some trepidation with the first one). Then all was well...so far. While I rarely need to reboot the server I would rather not have to go through this process each time. I will test whether it is truly "fixed" this weekend and report back.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 15 2017, 07:29 AM - #Permalink
    Resolved
    0 votes
    My bad....It's not enough to have the updated clearos-base pkg if you've already installed some of the web server or flexshare packages. You needed to also run:

    /usr/sbin/addsudo /usr/sbin/httpd app-flexshare-core


    B
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 15 2017, 07:17 AM - #Permalink
    Resolved
    0 votes
    Dave,

    FYI, I’m tight on memory (1.2gb) on the virtual share where my ClearOS 7 is installed it work fine on day to day but yesterday update required a lot of free memory to complete.
    The process was stuck in the middle with the ClearOS front web returning blank page (by chance website were up). I had to create a 2gb swap for the process to run.

    Thanks for your work !
    The reply is currently minimized Show
  • Accepted Answer

    MikeCindi
    MikeCindi
    Offline
    Wednesday, March 15 2017, 01:49 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:
    ...
    For the first error, do you have the Web Server app installed?
    For the second, have you chosen your directory server?

    Note these are only guesses.

    The web server app is installed and running and OpenLDAP has been configured is running as well.
    Ben Chambers wrote:

    @mikecindi

    For flexshare issue, make sure you have latest clearos-base:

    # rpm -qv clearos-base
    clearos-base-7.0.1-1.v7.x86_64

    ...
    B

    Yep, that's what I get when i run the command.

    I find this all very odd as I have setup 7.3.0 final three times on this hardware now and each time there are different issues. I loaded this once in a VM (HP DL380 G6 running ESXi 6.5) and have had no issues with that install but I also don't put it through the same rigors as I do on this hardware (HP DL360 G6). I will try again and install various apps one at a time instead of several at once. Who knows perhaps the fourth time is a charm... ;)
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 10:05 PM - #Permalink
    Resolved
    0 votes
    Frank Horsfall wrote:

    Nick Howitt wrote:

    I find the devel packages occasionally get in the way especially when the repos change during the update. Try removing openldap-devel on its own then do the update from the command line.



    Thanks Nick that worked however I have one last small irritant.

    Error: Package: 1:app-smtp-2.2.1-1.v7.noarch (@clearos-verified)

    Frank
    That one is weird. I see 2.3.22-1.v7 in clearos-updates, clearos-verified and private-clearcenter-verified-updates. Can you try a "yum clean all && yum update".

    If that does not work, try updating without app-smtp:
    yum update --exclude=app-smtp*
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 09:47 PM - #Permalink
    Resolved
    0 votes
    Hi Dave I am still looking forward to the reverse proxy app you mentioned?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 09:35 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I find the devel packages occasionally get in the way especially when the repos change during the update. Try removing openldap-devel on its own then do the update from the command line.



    Thanks Nick that worked however I have one last small irritant.

    Error: Package: 1:app-smtp-2.2.1-1.v7.noarch (@clearos-verified)

    Frank
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 08:47 PM - #Permalink
    Resolved
    0 votes
    I find the devel packages occasionally get in the way especially when the repos change during the update. Try removing openldap-devel on its own then do the update from the command line.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 08:23 PM - #Permalink
    Resolved
    0 votes
    Hello Benjamin et al.

    I updated one of my instances today and ran into a small dependencies error.

    Error: Package: 1:app-smtp-2.2.1-1.v7.noarch (@clearos-verified)
    Requires: app-smtp-core = 1:2.2.1-1.v7
    Removing: 1:app-smtp-core-2.2.1-1.v7.noarch (@clearos-verified)
    app-smtp-core = 1:2.2.1-1.v7
    Updated By: 1:app-smtp-core-2.3.0-1.v7.noarch (clearos)
    app-smtp-core = 1:2.3.0-1.v7
    Error: Package: openldap-devel-2.4.40-9.v7.1.x86_64 (@clearos-updates)
    Requires: openldap(x86-64) = 2.4.40-9.v7.1
    Removing: openldap-2.4.40-9.v7.1.x86_64 (@clearos-updates)
    openldap(x86-64) = 2.4.40-9.v7.1
    Updated By: openldap-2.4.40-13.v7.1.x86_64 (clearos)
    openldap(x86-64) = 2.4.40-13.v7.1


    Any ideas?

    Frank
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 08:43 AM - #Permalink
    Resolved
    0 votes
    @mikecindi

    For flexshare issue, make sure you have latest clearos-base:

    # rpm -qv clearos-base
    clearos-base-7.0.1-1.v7.x86_64


    For system resources and network report, install this update:


    yum --enablerepo=clearos-updates-testing upgrade app-reports-database-core


    For the note about repo warning on clearos-updates... It should already be fixed.

    B
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, March 14 2017, 06:52 AM - #Permalink
    Resolved
    0 votes
    MikeCindi wrote:
    Here's what was in the system log:
    Mar 13 21:52:39 dl360g6 installer: app-flexshare - installing
    Mar 13 21:57:11 dl360g6 flexshare: Invalid httpd configuration!
    Mar 13 21:57:11 dl360g6 flexshare: sudo: no tty present and no askpass program specified
    Mar 13 21:57:11 dl360g6 engine: exception: error: /usr/clearos/apps/flexshare/libraries/Flexshare.php (3126): Update failed - unable to validate new configuration - check logs for more information.
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/libraries/Flexshare.php (1715): _generate_web_flexshares
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/controllers/share.php (231): update_share
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/controllers/share.php (84): _form
    For the first error, do you have the Web Server app installed?
    For the second, have you chosen your directory server?

    Note these are only guesses.
    The reply is currently minimized Show
  • Accepted Answer

    MikeCindi
    MikeCindi
    Offline
    Monday, March 13 2017, 11:30 PM - #Permalink
    Resolved
    0 votes
    After install, first setup, then reboot -- at the server's console I get the traditional red box for the Administrator password that is filled with "[sudo] password for clearconsole:" It does not allow any entry and typing the proper password get the same text offset down a couple of rows and over several columns on the screen. To use the console I have to open up a different one (i.e. Alt-F2). I have loaded 7.3.0 three times (for different reasons) and all have this same issue.

    Also of note is that I used the iso to create a install from USB flash but that hangs trying to get a write cache (or some such) until I get a screen full of timeout errors and drops out to a recovery console. I had to burn a DVD to be able to install.

    edit: reloading again corrected the first issue. I won't try with a USB install anytime soon again. I now have a new issue with flexshares getting this error:

    Ooops!
    Update failed - unable to validate new configuration - check logs for more information.

    Here's what was in the system log:
    Mar 13 21:52:39 dl360g6 installer: app-flexshare - installing
    Mar 13 21:57:11 dl360g6 flexshare: Invalid httpd configuration!
    Mar 13 21:57:11 dl360g6 flexshare: sudo: no tty present and no askpass program specified
    Mar 13 21:57:11 dl360g6 engine: exception: error: /usr/clearos/apps/flexshare/libraries/Flexshare.php (3126): Update failed - unable to validate new configuration - check logs for more information.
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/libraries/Flexshare.php (1715): _generate_web_flexshares
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/controllers/share.php (231): update_share
    Mar 13 21:57:11 dl360g6 engine: exception: debug backtrace: /usr/clearos/apps/flexshare/controllers/share.php (84): _form

    I tried simply removing the app and reinstalling it but that made no difference.
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Friday, March 10 2017, 04:00 PM - #Permalink
    Resolved
    0 votes
    We are on 7.3 Business and have the following problems:

    1) Warning re disabled "clearos-updates" repo since 1st March - the day ClearOS updated to new verision


    The following recommendations/warnings have been identified:

    Consider enabling "clearos-updates" repository... it provides software updates to fix bugs, add features and in some cases, patch critical security vunerabilities.


    2) Not working "Network Report"

    3) Not working "Network Visualiser" - loads for ages

    4) Not working "Resource Report"

    ...
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 06 2017, 10:53 AM - #Permalink
    Resolved
    0 votes
    I can't find the Reverse Proxy App jet, I'am very curious for it. And I have got a small problem after the update. The Network Report and the Resource Report apps no longer work, or at least there is no more data after 24 februari, the day of update.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 04 2017, 07:37 PM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    I've updated my server from 7.3b3 to the latest version by yum upgrade, but the external certifcates are not working any more.
    The option is also removed from webconfig.


    We had to remove that feature at the last minute...it will be re-added as an update...hopefully in the near future.

    B


    That's to bad.

    To get the certificate working, please see this post how i've done it in the past LINK
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 04 2017, 07:18 PM - #Permalink
    Resolved
    0 votes
    I've updated my server from 7.3b3 to the latest version by yum upgrade, but the external certifcates are not working any more.
    The option is also removed from webconfig.


    We had to remove that feature at the last minute...it will be re-added as an update...hopefully in the near future.

    B
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 04 2017, 07:05 PM - #Permalink
    Resolved
    0 votes
    Other issue:

    Marketplace is not loading and in the webconfig is see the message :
    Additional info : Check Internet connection
    (in the info box on the right side)

    I've have normal internet access from the the server and from every device (laptop, pc, phones)

    ----------------- UPDATE -----------------

    The message is dissapeared
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 04 2017, 06:47 PM - #Permalink
    Resolved
    0 votes
    Dave,

    I've updated my server from 7.3b3 to the latest version by yum upgrade, but the external certifcates are not working any more.
    The option is also removed from webconfig.

    See also this thread LINK

    How can we use the external certificates again for webconfig ?
    The reply is currently minimized Show
Your Reply