2 votes
Following the release of Centos 7.9 last week, ClearOS 7.9 is now available for beta testing. To try it out please do:
yum update app-base initscripts --enablerepo=clearos-updates-testing
yum update --enablerepo=centos-unverified --disablerepo=clearos-centos-sclo-rh,clearos-centos,clearos-centos-updates
Optional updates are available to app-dhcp and app-network-map:
yum update app-network-map app-dhcp --enablerepo=clearos-updates-testing
These can be updated at the same time as the first update.

This should just be a maintenance release but it is important that people check out the Samba update for flexshares and domains.

Note that following this beta update you will get errors about the clearos-centos-sclo-rh as it will no longer be accessible. If you need packages from this repo, you can either edit /etc/yum.repos.d/clearos-centos-sclo-scl-rh.repo and change all instances of 7.9.2009 back to 7.8.2003 or you can pull the packages from centos-sclo-sclo-unverified. This will only affect people who use the PHP Engines app or command-line users.

Please post any issues to this thread.
Thursday, November 19 2020, 10:09 AM
Share this post:
Responses (5)
  • Accepted Answer

    Monday, November 23 2020, 04:45 AM - #Permalink
    0 votes
    First line OK - then this from the second line...

    [root@may ~]# yum update --enablerepo=centos-unverified --disablerepo=clearos-centos-sclo-rh

    Loaded plugins: clearcenter-marketplace, fastestmirror, verify
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * centos-unverified:
    * clearos:
    * clearos-centos:
    * clearos-centos-updates:
    * clearos-contribs:
    * clearos-epel:
    * clearos-fast-updates:
    * clearos-infra:
    * clearos-paid:
    * clearos-updates:
    * nux-dextop:
    centos-unverified | 3.6 kB 00:00:00
    clearos | 3.7 kB 00:00:00 [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror.
    To address this issue please refer to the below wiki article

    If above article doesn't help to resolve this issue please use [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror. [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror. [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror.

    One of the configured repositories failed (CentOS-7 - x86_64 - Base),
    and yum doesn't have enough cached data to continue. At this point the only
    safe thing yum can do is fail. There are a few ways to work "fix" this:

    1. Contact the upstream for the repository and get them to fix the problem.

    2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

    3. Run the command with the repository temporarily disabled
    yum --disablerepo=clearos-centos ...

    4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

    yum-config-manager --disable clearos-centos
    subscription-manager repos --disable=clearos-centos

    5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

    yum-config-manager --save --setopt=clearos-centos.skip_if_unavailable=true

    failure: repodata/repomd.xml from clearos-centos: [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found [Errno 14] HTTP Error 404 - Not Found [Errno 14] HTTP Error 404 - Not Found [Errno 14] HTTP Error 404 - Not Found
    [root@may ~]#

    As before - see this type of error too much from ClearOS repositories... No internet connection issues... Other distributions update OK.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 23 2020, 08:04 AM - #Permalink
    0 votes
    Hi Tony, thanks for trying. It is not a repo problem and my Community system I am just testing on survives it. It is more of an instruction problem. As we are testing the clearos-centos and clearos-centos-updates have not been updated to 7.9.2009. I am updating the instructions to skip those repos.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 23 2020, 09:37 AM - #Permalink
    0 votes
    Whatever... Last time I do any testing for ClearOS if this is the sort of time wasting it involves... Would have thought by now ClearOS could have provided a better experience for testing a new release considering how many times it has done it in the past. In fact - last time I append here - it is becoming more like pre-alpha not beta testing. Why does ClearOS provide instructions that don't work at all? Anyway - bye to ClearOS, the early days were good, but now now...
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 23 2020, 11:50 AM - #Permalink
    0 votes
    I am sorry you feel like that. Unfortunately the original instructions worked for me so I was happy enough with them. There must be something different between our Community setups. I did check to see if I had skip_if_unavailable=1 set in yum.conf and I don't. That is only in my production box. I don't know why yours didn't skip over the error. I have just tried on a much more recent Community install and it also continued past the error. I do, however admit it would have been better to start with the fuller command.

    Any help you can give would be appreciated.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 05 2021, 03:04 PM - #Permalink
    0 votes
    With a couple of VM's, I have done some successful domain join testing and flexshares still work for allusers and specific groups. I'll now move onto testing my development and production servers.
    The reply is currently minimized Show
Your Reply