Forums

Resolved
0 votes
The ClearOS Community 6.5.0 release is hitting the repos! Depending on the mirrors, the ISOs will be released late tonight or on Friday. More to come!

Edit: it's now out :-)
Thursday, December 19 2013, 08:04 PM
Share this post:
Responses (48)
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Tuesday, February 04 2014, 03:19 AM - #Permalink
    Resolved
    0 votes
    I'm lost. I don't know how to install some of those, and I have no idea why they are gone. Until this issue started I was only updating things from Webconfig, but it started to always tell me it was busy, so I tried yum update from the CLI.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 03 2014, 06:12 PM - #Permalink
    Resolved
    0 votes
    The yum/rpm system is just not happy. Here's one example:

    gnupg is needed by clearos-base-6.5.0-1.v6.x86_64


    The [b]gnupg[b] package is one of the packages that is always installed by default, but it has since been removed. Where did it go! To get the yum/rpm system happy again, you will need to install all the missing dependencies, .e.g.:

    yum install gnupg2


    Once those dependencies and duplicates are resolved, you should be okay.
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Sunday, February 02 2014, 12:01 AM - #Permalink
    Resolved
    0 votes
    Good idea, Tim.
    That removed 47 extraneous packages, but yum update still fails.


    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    rp-pppoe >= 3.10-8.1 is needed by app-network-core-1:1.5.15-1.v6.noarch
    libdevmapper.so.1.02()(64bit) is needed by parted-2.1-21.el6.x86_64
    libdevmapper.so.1.02(Base)(64bit) is needed by parted-2.1-21.el6.x86_64
    gnupg is needed by clearos-base-6.5.0-1.v6.x86_64
    mdadm is needed by clearos-base-6.5.0-1.v6.x86_64
    selinux-policy-targeted is needed by clearos-base-6.5.0-1.v6.x86_64
    ** Found 22 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:app-mysql-core-1.4.14-1.v6.noarch has missing requires of phpMyAdmin >= ('0', '3.4.7', None)
    1:app-network-core-1.4.40-1.v6.noarch has missing requires of rp-pppoe >= ('0', '3.10', '8.1')
    chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of gnupg
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of mdadm
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of selinux-policy-targeted
    crda-1.1.1_2010.11.22-1.el6.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of device-mapper-libs >= ('0', '1.02.61', None)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libdevmapper.so.1.02()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libdevmapper.so.1.02(Base)(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    gconsole-17.0.8-1.v6.x86_64 has installed conflicts xulrunner >= ('0', '17.0.9', None): xulrunner-17.0.9-1.el6_4.x86_64
    gconsole-17.0.9-1.v6.x86_64 is a duplicate with gconsole-17.0.8-1.v6.x86_64
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt >= ('0', '1.2.2', None)
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    gpgme-1.1.8-3.el6.x86_64 has missing requires of gnupg2
    libxslt-1.1.26-2.el6_3.1.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    libxslt-1.1.26-2.el6_3.1.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    parted-2.1-19.el6.x86_64 has missing requires of libdevmapper.so.1.02()(64bit)
    parted-2.1-19.el6.x86_64 has missing requires of libdevmapper.so.1.02(Base)(64bit)
    Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2014-02-01-17-59QGK6Ka.yumtx
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 01 2014, 08:56 PM - #Permalink
    Resolved
    0 votes
    I dont use the content filter updates, but strikes me as a little odd that you have multiple installed versions of the same RPM. Perhaps someone from the dev team can comment?

    A random suggestion is to remove them all, then reinstall as this seems to be holding up your yum upgrades
    yum remove clearsdn-content-filter*
    yum install clearsdn-content-filter
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Friday, January 31 2014, 07:16 PM - #Permalink
    Resolved
    0 votes
    Still unable to do a yum update :(
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Tuesday, January 21 2014, 04:34 PM - #Permalink
    Resolved
    0 votes
    Yes, I did a 'yum clean all' first. Also an 'rpm --rebuilddb'

    [root@gateway ~]# rpm -qa | grep clearsdn-content-filter
    clearsdn-content-filter-6.1-20140114.1048.noarch
    clearsdn-content-filter-6.1-20140113.1053.noarch
    clearsdn-content-filter-6.1-20131201.1031.noarch
    clearsdn-content-filter-6.1-20131125.1031.noarch
    clearsdn-content-filter-6.1-20131128.1031.noarch
    clearsdn-content-filter-6.1-20131220.1108.noarch
    clearsdn-content-filter-6.1-20131216.1031.noarch
    clearsdn-content-filter-6.1-20131212.1032.noarch
    clearsdn-content-filter-6.1-20131122.1030.noarch
    clearsdn-content-filter-6.1-20131130.1032.noarch
    clearsdn-content-filter-6.1-20131206.1030.noarch
    clearsdn-content-filter-6.1-20131222.1031.noarch
    clearsdn-content-filter-6.1-20131207.1032.noarch
    clearsdn-content-filter-6.1-20131211.1032.noarch
    clearsdn-content-filter-6.1-20131215.1031.noarch
    clearsdn-content-filter-6.1-20131219.1030.noarch
    clearsdn-content-filter-6.1-20131209.1030.noarch
    clearsdn-content-filter-6.1-20131223.1032.noarch
    clearsdn-content-filter-6.1-20131227.1033.noarch
    clearsdn-content-filter-6.1-20131231.1032.noarch
    clearsdn-content-filter-6.1-20131210.1031.noarch
    clearsdn-content-filter-6.1-20131123.1031.noarch
    clearsdn-content-filter-6.1-20131221.1038.noarch
    clearsdn-content-filter-6.1-20131225.1032.noarch
    clearsdn-content-filter-6.1-20131229.1031.noarch
    clearsdn-content-filter-6.1-20131129.1034.noarch
    clearsdn-content-filter-6.1-20131121.1030.noarch
    clearsdn-content-filter-6.1-20131213.1030.noarch
    clearsdn-content-filter-6.1-20131217.1030.noarch
    clearsdn-content-filter-6.1-20131124.1029.noarch
    clearsdn-content-filter-6.1-20131218.1031.noarch
    clearsdn-content-filter-6.1-20131208.1031.noarch
    clearsdn-content-filter-6.1-20131230.1032.noarch
    clearsdn-content-filter-6.1-20131203.1034.noarch
    clearsdn-content-filter-6.1-20140111.1031.noarch
    clearsdn-content-filter-6.1-20131202.1030.noarch
    clearsdn-content-filter-6.1-20131226.1033.noarch
    clearsdn-content-filter-6.1-20131205.1033.noarch
    clearsdn-content-filter-6.1-20131224.1032.noarch
    clearsdn-content-filter-6.1-20131204.1031.noarch
    clearsdn-content-filter-6.1-20131228.1031.noarch
    clearsdn-content-filter-6.1-20140112.1048.noarch
    clearsdn-content-filter-6.1-20131127.1030.noarch
    clearsdn-content-filter-6.1-20131126.1031.noarch
    clearsdn-content-filter-6.1-20131214.1029.noarch
    [root@gateway ~]#
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2014, 01:49 PM - #Permalink
    Resolved
    0 votes
    Not sure why it's reporting duplicates for clearsdn-content-filter when the versions are different

    Whats the output of 'rpm -qa | grep clearsdn-content-filter'?

    Have you run 'yum clean all' since?
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Monday, January 20 2014, 08:02 PM - #Permalink
    Resolved
    0 votes
    The clearsdn-content-filter problem remains :(
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Monday, January 20 2014, 07:50 PM - #Permalink
    Resolved
    0 votes
    http://mirror2-houston.clearsdn.com/clearos/community/6/extras/x86_64/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for clearos-extras: Damaged repomd.xml file


    Running it now. Got the above error but it continued on so far.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 20 2014, 06:29 PM - #Permalink
    Resolved
    0 votes
    J Kelly.

    I just (like 5 minutes ago) made a change to the Marketplace...the content filter update service somehow got updated with an invalid repo.

    It stores the package clearsdn-content-filter.

    With any luck, if you try again, your problem (or at least that one) will be gone.

    B
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Monday, January 20 2014, 06:25 PM - #Permalink
    Resolved
    0 votes
    I still can't get my system to update. I get errors about duplicate packages and missing dependencies.

    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    rp-pppoe >= 3.10-8.1 is needed by app-network-core-1:1.5.15-1.v6.noarch
    libdevmapper.so.1.02()(64bit) is needed by parted-2.1-21.el6.x86_64
    libdevmapper.so.1.02(Base)(64bit) is needed by parted-2.1-21.el6.x86_64
    gnupg is needed by clearos-base-6.5.0-1.v6.x86_64
    mdadm is needed by clearos-base-6.5.0-1.v6.x86_64
    selinux-policy-targeted is needed by clearos-base-6.5.0-1.v6.x86_64
    ** Found 66 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:app-mysql-core-1.4.14-1.v6.noarch has missing requires of phpMyAdmin >= ('0', '3.4.7', None)
    1:app-network-core-1.4.40-1.v6.noarch has missing requires of rp-pppoe >= ('0', '3.10', '8.1')
    chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of gnupg
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of mdadm
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of selinux-policy-targeted
    clearsdn-content-filter-6.1-20131122.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131121.1030.noarch


    it goes on and on like that..
    The reply is currently minimized Show
  • Accepted Answer

    Robert
    Robert
    Offline
    Friday, January 17 2014, 04:21 PM - #Permalink
    Resolved
    0 votes
    Hi David,

    I also have had this problem (see post above), but it is gone now. Likely the developers quickly fixed it.

    Thanks.

    Best

    Robert
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 17 2014, 04:06 PM - #Permalink
    Resolved
    0 votes
    I know this thread is getting hijacked slightly, but I've just tried a yum update (6.4 pro) and expecting to see no update available, I too am getting several screens of packages to be updated and
    Error: Package: libsndfile-1.0.20-5.el6.x86_64 (@anaconda-ClearOSProfessional-201204201349
    .x86_64/6.2)
    Requires: libvorbisenc.so.2()(64bit)
    Removing: 1:libvorbis-1.2.3-4.el6_2.1.x86_64 (@anaconda-ClearOSProfessional-201
    204201349.x86_64/6.2)
    libvorbisenc.so.2()(64bit)
    Updated By: 1:libvorbis-1.2.3-6.el6.x86_64 (clearos-updates)
    Not found
    Error: Package: libcanberra-gtk2-0.22-1.el6.x86_64 (@anaconda-ClearOSProfessional-20120420
    1349.x86_64/6.2)
    Requires: libvorbis.so.0()(64bit)
    Removing: 1:libvorbis-1.2.3-4.el6_2.1.x86_64 (@anaconda-ClearOSProfessional-201
    204201349.x86_64/6.2)
    libvorbis.so.0()(64bit)
    Updated By: 1:libvorbis-1.2.3-6.el6.x86_64 (clearos-updates)
    Not found
    Error: Package: libcanberra-0.22-1.el6.x86_64 (@anaconda-ClearOSProfessional-201204201349.
    x86_64/6.2)
    Requires: libvorbisfile.so.3()(64bit)
    Removing: 1:libvorbis-1.2.3-4.el6_2.1.x86_64 (@anaconda-ClearOSProfessional-201
    204201349.x86_64/6.2)
    libvorbisfile.so.3()(64bit)
    Updated By: 1:libvorbis-1.2.3-6.el6.x86_64 (clearos-updates)
    Not found
    Error: Package: libsndfile-1.0.20-5.el6.x86_64 (@anaconda-ClearOSProfessional-201204201349
    .x86_64/6.2)
    Requires: libvorbis.so.0()(64bit)
    Removing: 1:libvorbis-1.2.3-4.el6_2.1.x86_64 (@anaconda-ClearOSProfessional-201
    204201349.x86_64/6.2)
    libvorbis.so.0()(64bit)
    Updated By: 1:libvorbis-1.2.3-6.el6.x86_64 (clearos-updates)
    Not found


    David
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Friday, January 17 2014, 04:59 AM - #Permalink
    Resolved
    0 votes
    Still not working.

    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    rp-pppoe >= 3.10-8.1 is needed by app-network-core-1:1.5.15-1.v6.noarch
    libdevmapper.so.1.02()(64bit) is needed by parted-2.1-21.el6.x86_64
    libdevmapper.so.1.02(Base)(64bit) is needed by parted-2.1-21.el6.x86_64
    gnupg is needed by clearos-base-6.5.0-1.v6.x86_64
    mdadm is needed by clearos-base-6.5.0-1.v6.x86_64
    selinux-policy-targeted is needed by clearos-base-6.5.0-1.v6.x86_64
    ** Found 66 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:app-mysql-core-1.4.14-1.v6.noarch has missing requires of phpMyAdmin >= ('0', '3.4.7', None)
    1:app-network-core-1.4.40-1.v6.noarch has missing requires of rp-pppoe >= ('0', '3.10', '8.1')
    chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of gnupg
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of mdadm
    clearos-base-6.2.2-1.v6.x86_64 has missing requires of selinux-policy-targeted
    clearsdn-content-filter-6.1-20131122.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131121.1030.noarch
    clearsdn-content-filter-6.1-20131123.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131122.1030.noarch
    clearsdn-content-filter-6.1-20131124.1029.noarch is a duplicate with clearsdn-content-filter-6.1-20131123.1031.noarch
    clearsdn-content-filter-6.1-20131125.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131124.1029.noarch
    clearsdn-content-filter-6.1-20131126.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131125.1031.noarch
    clearsdn-content-filter-6.1-20131127.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131126.1031.noarch
    clearsdn-content-filter-6.1-20131128.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131127.1030.noarch
    clearsdn-content-filter-6.1-20131129.1034.noarch is a duplicate with clearsdn-content-filter-6.1-20131128.1031.noarch
    clearsdn-content-filter-6.1-20131130.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131129.1034.noarch
    clearsdn-content-filter-6.1-20131201.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131130.1032.noarch
    clearsdn-content-filter-6.1-20131202.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131201.1031.noarch
    clearsdn-content-filter-6.1-20131203.1034.noarch is a duplicate with clearsdn-content-filter-6.1-20131202.1030.noarch
    clearsdn-content-filter-6.1-20131204.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131203.1034.noarch
    clearsdn-content-filter-6.1-20131205.1033.noarch is a duplicate with clearsdn-content-filter-6.1-20131204.1031.noarch
    clearsdn-content-filter-6.1-20131206.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131205.1033.noarch
    clearsdn-content-filter-6.1-20131207.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131206.1030.noarch
    clearsdn-content-filter-6.1-20131208.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131207.1032.noarch
    clearsdn-content-filter-6.1-20131209.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131208.1031.noarch
    clearsdn-content-filter-6.1-20131210.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131209.1030.noarch
    clearsdn-content-filter-6.1-20131211.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131210.1031.noarch
    clearsdn-content-filter-6.1-20131212.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131211.1032.noarch
    clearsdn-content-filter-6.1-20131213.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131212.1032.noarch
    clearsdn-content-filter-6.1-20131214.1029.noarch is a duplicate with clearsdn-content-filter-6.1-20131213.1030.noarch
    clearsdn-content-filter-6.1-20131215.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131214.1029.noarch
    clearsdn-content-filter-6.1-20131216.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131215.1031.noarch
    clearsdn-content-filter-6.1-20131217.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131216.1031.noarch
    clearsdn-content-filter-6.1-20131218.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131217.1030.noarch
    clearsdn-content-filter-6.1-20131219.1030.noarch is a duplicate with clearsdn-content-filter-6.1-20131218.1031.noarch
    clearsdn-content-filter-6.1-20131220.1108.noarch is a duplicate with clearsdn-content-filter-6.1-20131219.1030.noarch
    clearsdn-content-filter-6.1-20131221.1038.noarch is a duplicate with clearsdn-content-filter-6.1-20131220.1108.noarch
    clearsdn-content-filter-6.1-20131222.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131221.1038.noarch
    clearsdn-content-filter-6.1-20131223.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131222.1031.noarch
    clearsdn-content-filter-6.1-20131224.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131223.1032.noarch
    clearsdn-content-filter-6.1-20131225.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131224.1032.noarch
    clearsdn-content-filter-6.1-20131226.1033.noarch is a duplicate with clearsdn-content-filter-6.1-20131225.1032.noarch
    clearsdn-content-filter-6.1-20131227.1033.noarch is a duplicate with clearsdn-content-filter-6.1-20131226.1033.noarch
    clearsdn-content-filter-6.1-20131228.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131227.1033.noarch
    clearsdn-content-filter-6.1-20131229.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131228.1031.noarch
    clearsdn-content-filter-6.1-20131230.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131229.1031.noarch
    clearsdn-content-filter-6.1-20131231.1032.noarch is a duplicate with clearsdn-content-filter-6.1-20131230.1032.noarch
    clearsdn-content-filter-6.1-20140111.1031.noarch is a duplicate with clearsdn-content-filter-6.1-20131231.1032.noarch
    clearsdn-content-filter-6.1-20140112.1048.noarch is a duplicate with clearsdn-content-filter-6.1-20140111.1031.noarch
    clearsdn-content-filter-6.1-20140113.1053.noarch is a duplicate with clearsdn-content-filter-6.1-20140112.1048.noarch
    clearsdn-content-filter-6.1-20140114.1048.noarch is a duplicate with clearsdn-content-filter-6.1-20140113.1053.noarch
    crda-1.1.1_2010.11.22-1.el6.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of device-mapper-libs >= ('0', '1.02.61', None)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libdevmapper.so.1.02()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libdevmapper.so.1.02(Base)(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    cryptsetup-luks-libs-1.2.0-7.el6.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    gconsole-17.0.8-1.v6.x86_64 has installed conflicts xulrunner >= ('0', '17.0.9', None): xulrunner-17.0.9-1.el6_4.x86_64
    gconsole-17.0.9-1.v6.x86_64 is a duplicate with gconsole-17.0.8-1.v6.x86_64
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt >= ('0', '1.2.2', None)
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    gnutls-2.8.5-10.el6_4.2.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    gpgme-1.1.8-3.el6.x86_64 has missing requires of gnupg2
    libxslt-1.1.26-2.el6_3.1.x86_64 has missing requires of libgcrypt.so.11()(64bit)
    libxslt-1.1.26-2.el6_3.1.x86_64 has missing requires of libgcrypt.so.11(GCRYPT_1.2)(64bit)
    parted-2.1-19.el6.x86_64 has missing requires of libdevmapper.so.1.02()(64bit)
    parted-2.1-19.el6.x86_64 has missing requires of libdevmapper.so.1.02(Base)(64bit)
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Thursday, January 16 2014, 06:30 PM - #Permalink
    Resolved
    0 votes
    Thanks, Peter! I'll try again later on tonight.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 16 2014, 06:01 PM - #Permalink
    Resolved
    0 votes
    The Community Edition issue was resolved, but it takes a bit of time for the mirrors to update (can be up to 6 hours)
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Thursday, January 16 2014, 01:07 PM - #Permalink
    Resolved
    0 votes
    I did

    rpm --rebuilddb

    which solved my original issue, but now I'm also getting dependency issues that stop the update process.
    The reply is currently minimized Show
  • Accepted Answer

    Robert
    Robert
    Offline
    Thursday, January 16 2014, 07:49 AM - #Permalink
    Resolved
    0 votes
    Hi,

    I am getting suddenly dependency problems for the last update. Packages:

    libogg
    libvorbis

    does this have something to do with minidlna? I do not need it anymore and removed it (yum remove minidlna) but it does not help.

    What can I do?

    Thanks a lot for the help.

    Robert
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Tuesday, January 14 2014, 09:36 PM - #Permalink
    Resolved
    0 votes
    Yes. It makes no difference.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 14 2014, 01:08 PM - #Permalink
    Resolved
    0 votes
    Have you tried running 'yum clean all' first?
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Tuesday, January 14 2014, 01:07 PM - #Permalink
    Resolved
    0 votes
    Tried again today. Same problem, but a different package now.

    # yum upgrade
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-dc.clearsdn.com
    * clearos-addons: mirror2-dc.clearsdn.com
    * clearos-contribs: mirror2-dc.clearsdn.com
    * clearos-core: mirror2-dc.clearsdn.com
    * clearos-extras: mirror2-dc.clearsdn.com
    * clearos-updates: mirror2-dc.clearsdn.com
    * contribs: download1.clearsdn.com
    * private-clearcenter-content-filter: download2.clearsdn.com:80
    * private-clearcenter-dyndns: download3.clearsdn.com:80
    Setting up Upgrade Process
    Error: Package tuple ('kernel', 'x86_64', '0', '2.6.32', '358.23.2.v6') could not be found in rpmdb
    The reply is currently minimized Show
  • Accepted Answer

    J Kelly
    J Kelly
    Offline
    Monday, January 13 2014, 10:07 PM - #Permalink
    Resolved
    0 votes
    Tried to upgrade to 6.5. What now?


    # yum upgrade
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-houston.clearsdn.com
    * clearos-addons: mirror2-houston.clearsdn.com
    * clearos-contribs: mirror2-houston.clearsdn.com
    * clearos-core: mirror2-houston.clearsdn.com
    * clearos-extras: mirror2-houston.clearsdn.com
    * clearos-updates: mirror2-houston.clearsdn.com
    * contribs: download4.clearsdn.com
    * private-clearcenter-content-filter: download4.clearsdn.com:80
    * private-clearcenter-dyndns: download4.clearsdn.com:80
    Setting up Upgrade Process
    Error: Package tuple ('clearsdn-content-filter', 'noarch', '0', '6.1', '20140112.1048') could not be found in rpmdb
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Saturday, January 04 2014, 07:36 PM - #Permalink
    Resolved
    0 votes
    khvalera wrote:
    In the established and updated ClearOS, the GUI item for "Incoming Firewall". In the Marketplace "Firewall" installed. What do I need to install?

    ...miracles, one day, he came :)
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Friday, January 03 2014, 07:34 PM - #Permalink
    Resolved
    0 votes
    In the established and updated ClearOS, the GUI item for "Incoming Firewall". In the Marketplace "Firewall" installed. What do I need to install?
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Monday, December 30 2013, 04:11 PM - #Permalink
    Resolved
    0 votes
    Peter Baldwin wrote:
    Hi khvalera,

    The "clearos-dev" repository is enabled -- that should be disabled! More information is in the User Guide:

    http://www.clearcenter.com/support/documentation/user_guide/software_repository#clearos-dev


    Really a problem in repository clearos-dev included! Thank you and Happy Holidays!
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 30 2013, 03:31 PM - #Permalink
    Resolved
    0 votes
    Hi khvalera,

    The "clearos-dev" repository is enabled -- that should be disabled! More information is in the User Guide:

    http://www.clearcenter.com/support/documentation/user_guide/software_repository#clearos-dev
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Monday, December 30 2013, 01:55 PM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:
    If that's the only dependency, try this:
    yum install --enablerepo=clearos-epel perl-CGI
    yum upgrade


    # yum install --enablerepo=clearos-epel perl-CGI
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Determining fastest mirrors
    * clearos: mirror.1000mbps.com
    * clearos-addons: mirror.1000mbps.com
    * clearos-core: mirror.1000mbps.com
    * clearos-dev: mirror.1000mbps.com
    * clearos-epel: mirror.euserv.net
    * clearos-extras: mirror.1000mbps.com
    * clearos-updates: mirror.1000mbps.com
    * contribs: download3.clearsdn.com
    * private-clearcenter-backuppc: download2.clearsdn.com:80
    * private-clearcenter-dyndns: download1.clearsdn.com:80
    clearos | 3.1 kB 00:00
    clearos/primary_db | 924 kB 00:00
    clearos-addons | 2.9 kB 00:00
    clearos-addons/primary_db | 32 kB 00:00
    clearos-core | 3.0 kB 00:00
    clearos-core/primary_db | 6.7 MB 00:04
    clearos-dev | 2.9 kB 00:00
    clearos-dev/primary_db | 863 kB 00:00
    clearos-extras | 2.9 kB 00:00
    clearos-extras/primary_db | 131 kB 00:00
    clearos-updates | 2.9 kB 00:00
    clearos-updates/primary_db | 660 kB 00:00
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-CGI.x86_64 0:3.51-131.el6_4 will be updated
    ---> Package perl-CGI.noarch 2:3.52-9.el6 will be an update
    --> Processing Dependency: perl(FCGI) for package: 2:perl-CGI-3.52-9.el6.noarch
    --> Processing Dependency: atrpms-perl-module-helper for package: 2:perl-CGI-3.52-9.el6.noarch
    --> Running transaction check
    ---> Package perl-CGI.noarch 2:3.52-9.el6 will be an update
    --> Processing Dependency: atrpms-perl-module-helper for package: 2:perl-CGI-3.52-9.el6.noarch
    ---> Package perl-FCGI.x86_64 1:0.71-4.el6 will be installed
    --> Finished Dependency Resolution
    Error: Package: 2:perl-CGI-3.52-9.el6.noarch (clearos-dev)
    Requires: atrpms-perl-module-helper
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 30 2013, 01:21 PM - #Permalink
    Resolved
    0 votes
    If that's the only dependency, try this:
    yum install --enablerepo=clearos-epel perl-CGI
    yum upgrade


    B
    The reply is currently minimized Show
  • Accepted Answer

    khvalera
    khvalera
    Offline
    Monday, December 30 2013, 12:41 PM - #Permalink
    Resolved
    0 votes
    When upgrading from ClearOS 6.4 get:

    --> Processing Dependency: atrpms-perl-module-helper for package: 2:perl-CGI-3.52-9.el6.noarch
    --> Finished Dependency Resolution
    Error: Package: 2:perl-CGI-3.52-9.el6.noarch (clearos-dev)
    Requires: atrpms-perl-module-helper
    Error: Package: 2:perl-CGI-3.52-9.el6.noarch (clearos-dev)
    Requires: perl(FCGI)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 26 2013, 03:03 AM - #Permalink
    Resolved
    0 votes
    I will do the write up with Shad on Friday and publish it as a howto.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 26 2013, 01:59 AM - #Permalink
    Resolved
    0 votes
    I'm seeding in my Transmission App also 24/7

    Dave, could you give me details for making ClearOS Public mirror?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 26 2013, 12:28 AM - #Permalink
    Resolved
    0 votes
    Thanks Marcel.

    I will also start seeding for everyone as well. There are currently 2-3 on the network now. I'll leave mine up on my Transmission app. :)
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 25 2013, 06:54 AM - #Permalink
    Resolved
    0 votes
    Peter Baldwin wrote:
    Hi Nick,

    Does anyone know if a torrent has been started yet?

    The torrent links have been updated and there are a 20-ish seeds available for the 64-bit version right now:
    http://terasaur.org/item/show/clearos-community-6-5-0/6701


    To support the community i'm also seeding.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 24 2013, 10:12 AM - #Permalink
    Resolved
    0 votes
    @ Ben Chambers - Ben thanks for the confirmation that was the case. I've been away for a day or two hence the late reply. I thought the release might go community > professional as you suggested, although I was initially confused by the full download being available (with the missing dependencies mentioned earlier in this thread). With the few updates the system did on the 21st, I noticed a few minor changed to the GUI. I'll keep watching!

    @Brian - I think you may also have seen the same as me, and your professional installation perhaps didn't do the full installation, only a few minor updates in preparation? I don't know (if you didn't experience the dependency issue) whether your professional box might have done the full upgrade before Peter made changes, i.e. was there a brief window where a professional edition upgrade could have happened.
    The reply is currently minimized Show
  • Accepted Answer

    Brian
    Brian
    Offline
    Monday, December 23 2013, 08:12 PM - #Permalink
    Resolved
    0 votes
    Out of curiosity, when will the Administrators app be available for Professional?

    I installed it at home on my Community system (from shell, yum install app-administrators), but of course Professional is not finding it.

    The two Professional systems I manage were automatically updated to 6.5 when I was out of town, but would like to get the Administrators app installed.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 23 2013, 07:35 PM - #Permalink
    Resolved
    0 votes
    Peter Baldwin wrote:
    Hi Nick,

    Does anyone know if a torrent has been started yet?

    The torrent links have been updated and there are a 20-ish seeds available for the 64-bit version right now:
    http://terasaur.org/item/show/clearos-community-6-5-0/6701
    Thanks. I'm joining in for both versions.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 23 2013, 07:01 PM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    Does anyone know if a torrent has been started yet?

    The torrent links have been updated and there are a 20-ish seeds available for the 64-bit version right now:
    http://terasaur.org/item/show/clearos-community-6-5-0/6701
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, December 21 2013, 01:23 PM - #Permalink
    Resolved
    0 votes
    David,

    If you're on Professional Edition, your updates repo now points to a different location than Community Edition users. This allows us to make sure Professional users get the highest stability/quality updates (eg. after they pass through the Community Edition).

    You'll see Professional updates (including 6.5) in a few weeks.

    B.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, December 21 2013, 01:15 PM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    I thought about the auto update. Log shows the following packages:

    Nov 20 04:10:22 Updated: 7:squid-3.1.10-19.el6_4.x86_64
    Nov 28 06:52:12 Updated: perl-Mail-DKIM-0.37-3.v6.noarch
    Dec 11 02:10:29 Updated: iscsi-initiator-utils-6.2.0.873-10.el6.x86_64
    Dec 21 03:15:43 Updated: clearos-framework-6.5.6-1.v6.noarch
    Dec 21 03:15:44 Updated: theme-default-6.5.6-1.v6.noarch
    Dec 21 03:15:44 Updated: syswatch-6.5.0-1.v6.noarch
    Dec 21 03:15:45 Installed: acpid-1.0.10-2.1.el6.x86_64
    Dec 21 03:15:48 Updated: 1:app-base-core-1.5.20-1.v6.noarch
    Dec 21 03:15:49 Updated: 1:app-base-1.5.20-1.v6.noarch
    Dec 21 03:15:49 Updated: 1:app-remote-backup-core-1.5.20-1.v6.noarch
    Dec 21 03:15:50 Updated: 1:app-network-core-1.5.15-1.v6.noarch
    Dec 21 03:15:51 Updated: 1:app-network-1.5.15-1.v6.noarch
    Dec 21 03:15:52 Updated: 1:app-users-core-1.4.21-1.v6.noarch
    Dec 21 03:15:52 Updated: yum-marketplace-plugin-1.6-1.v6.noarch
    Dec 21 03:15:52 Updated: 1:app-marketplace-core-1.5.16-1.v6.noarch
    Dec 21 03:15:53 Updated: 1:app-marketplace-1.5.16-1.v6.noarch
    Dec 21 03:15:53 Updated: 1:app-users-1.4.21-1.v6.noarch
    Dec 21 03:15:54 Updated: 1:app-remote-backup-1.5.20-1.v6.noarch


    Dec 21 03:16:02 cb300 software-updates: log: Transaction Summary
    Dec 21 03:16:02 cb300 software-updates: log: ================================================================================
    Dec 21 03:16:02 cb300 software-updates: log: Install 1 Package(s)
    Dec 21 03:16:02 cb300 software-updates: log: Upgrade 14 Package(s)
    Dec 21 03:16:02 cb300 software-updates: log:
    Dec 21 03:16:02 cb300 software-updates: log: Total download size: 2.1 M
    Dec 21 03:16:02 cb300 software-updates: log: Downloading Packages:
    Dec 21 03:16:02 cb300 software-updates: log: --------------------------------------------------------------------------------
    Dec 21 03:16:02 cb300 software-updates: log: Total 141 kB/s | 2.1 MB 00:15


    no where near the full number that I got running yum from the CL yesterday :-)

    did your system get the full download? (I've done a yum clean all in case it thought it had them already), but its still showing no packages marked for update.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, December 21 2013, 12:50 PM - #Permalink
    Resolved
    0 votes
    Does anyone know if a torrent has been started yet?
    The reply is currently minimized Show
Your Reply