Community Forum

Resolved
0 votes
Hi Guys, i have a issue with a new installation on a supermicro server, i cant install clearos. The monitor i going out of range !!!
Can i change bootparameters ? So i can install in 1024*750 pix ?
i can not add a other graficcard.

regards Steffen
In Gateway
Saturday, May 12 2018, 10:54 AM
Share this post:
Responses (14)
  • Accepted Answer

    Tuesday, May 15 2018, 07:52 PM - #Permalink
    Resolved
    0 votes
    Hi dave, yes i have installed this system with the option inst.text
    I can try the option nomodeset in my next setup tomorow. Its the same hardware :-)

    When i have no network, its easy to setup :-)

    Thanks for all, have a nice day
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, May 15 2018, 07:22 PM - #Permalink
    Resolved
    0 votes
    Graphic-wise, if you must have video output, you may have a bit of a road to travel for obscure monitor and video card drivers. Luckily, ClearOS is meant to operate headless, so if you can get the IP address off of the server, skip the pain and torture and just use the web interface. You can find the IP address by using CTRL+ALT+F3 to switch to the F3 console. Log in as root and run:

    ip address

    This will show your your ip addresses if your box is on DHCP. Simply put that into your browser and go to town.

    If you need to manually set up a static IP address, you can modify the appropriate NIC file in /etc/sysconfig/network-scripts/ifcfg-NICNAME using 'Method 1' here:

    https://www.itzgeek.com/how-tos/linux/centos-how-tos/how-to-configure-static-ip-address-in-centos-7-rhel-7-fedora-26.html
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, May 15 2018, 07:00 PM - #Permalink
    Resolved
    0 votes
    You can also do the install in text mode with no video. Parameters to try on the grub line are:

    nomodeset

    and/or

    inst.text

    Worst case scenario, you can install via console over serial.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 14 2018, 06:22 PM - #Permalink
    Resolved
    0 votes
    I've dug out some old posts about configuring x11/xorg:

    https://www.clearos.com/clearfoundation/social/community/graphics-resolution-of-local-graphical-console
    https://www.clearos.com/clearfoundation/social/community/howto-configure-your-webconfig-x-resolution
    https://www.clearos.com/clearfoundation/social/community/blank-screen-after-clean-install-no-login

    The first one indicates you may need to create your own xorg.conf before you can adjust it.

    Do you know if your card supports 60Hz? I think you only need an 800x600 display for ClearOS but I'm not sure.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 14 2018, 12:48 PM - #Permalink
    Resolved
    0 votes
    Oddly, when I had the issue it was with a relatively recent Core I-3 processor with integrated graphics and an oldish 1024*768 LCD monitor when installing 6.x. The same combination works fine on 7.x.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 14 2018, 12:35 PM - #Permalink
    Resolved
    0 votes
    hm i think thats my old graficcard :-) ATI Range XL and this has default 48Hz.
    So i must find a old CRT Monitor :-)

    I have try to install the ati-drivers but still not work.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 14 2018, 09:46 AM - #Permalink
    Resolved
    0 votes
    Hi to all,
    ok i have try this: as root

    # GRUB_GFXMODE=1024x768x16
    # GRUB_GFXPAYLOAD_LINUX=keep
    # grub2-mkconfig -o /boot/grub/grub.cfg
    # reboot

    i can login in the red text box, after this F2 and there is coming the same issue.
    So the bootparameters are ok but the resolution of Clearosapi or X11 is :(
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 14 2018, 07:26 AM - #Permalink
    Resolved
    0 votes
    Maybe since the vga= method was deprecated a while ago, it has now been removed from the kernel.From one of the links I used, instead, please try setting the lines:
    GRUB_GFXMODE=1024x768x16
    GRUB_GFXPAYLOAD_LINUX=keep
    after you interrupt the start up process.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 13 2018, 10:04 PM - #Permalink
    Resolved
    0 votes
    Hi Rick, i have successfully installed clearos by using the text install, so i can also login to the text console.
    But when i start the F2 optin after login, is the monitor out of range, i have try the 'vga=791' and 'set gfxpayload=1024x768x16' but still the same issue.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 13 2018, 07:44 PM - #Permalink
    Resolved
    0 votes
    You are virtually back to where you started, but you've done the installation. Now try to insert the vga=791 during start up or even try 788 for 800*600, 16bit. Don't worry about the API. It should follow - or mine did when I had the same issue with 6.x years ago.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 13 2018, 03:34 PM - #Permalink
    Resolved
    0 votes
    Hi, hm can i change the ClearOS API resolution ? The login is in text mode and when i login to the graficalkonsole with F2 is the resulution out of range !!!!
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 13 2018, 03:08 PM - #Permalink
    Resolved
    0 votes
    ok i have installed this with install.text option and its fine.
    So i must change the resulution of the ClearosApi on the server.
    I reply later ......
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 13 2018, 02:06 PM - #Permalink
    Resolved
    0 votes
    Hej Nick, thanks i try it :-) Have a nice day
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 12 2018, 12:39 PM - #Permalink
    Resolved
    0 votes
    I presume you meant 1024*768?

    See this post for interrupting the boot. On the linux/linuxefi line, try adding vga=791 (16-bit colour) or 773 (8-bit colour). This is method is deprecated but probably still works. If it works for you,then you have to make it permanent by changing grub2 as this only changes it for the one boot.

    The preferred method is using something like "set gfxpayload=1024x768x16" higher up the boot options and it would be best to use this when you regenerate grub2 if the vga=791 works.
    The reply is currently minimized Show
Your Reply