Forums

Resolved
0 votes
Hi,
I have setup and configured a 5.2 deployment of ClearOS for hyper-v. This includes the Linux Integration Components. I am intending to run a number of deployments and potentially client deployments of ClearOS from this template. I followed this thread successfully http://www.clearfoundation.com/component/option,com_kunena/Itemid,232/catid,40/func,view/id,6152 .

I registered a deployment and then tried to clone the VM for future deployments. This only needed one modification to bring up the network interfaces, which involved changing the hard coded mac address's in here /etc/iftab .

So far so good all appeared to be working fine after a reboot but.... i don't seem to be able to register the system with ClearSDN. Whatever i name the machine it always claims that 'This system has already been registered with a different name or registered under a different account'

I know i have 1 system registered and i have checked the naming of the system and it is unique.

Is there something else identifying the machine install that would have carried over from the original installation?

Any clues welcome.
Monday, September 06 2010, 02:39 PM
Share this post:
Responses (1)
  • Accepted Answer

    gergull
    gergull
    Offline
    Wednesday, September 08 2010, 03:47 AM - #Permalink
    Resolved
    0 votes
    Hi Matthew,

    I've faced the same problem with Citrix XenServer.

    You can try the following:

    Edit /etc/suvad.conf and erase the following key values:

    <device></device>
    <hostkey></hostkey>

    Note, erase just the values, no the key itself.

    Then run following command to generate a new host key:

    /usr/bin/mkhost.sh /etc/suvad.conf

    You're ready to register.

    Don't know if it's the right way to go, but it worked for me. Do it at your own risk.

    rgrds,
    Bráulio Gergull
    The reply is currently minimized Show
Your Reply