Forums

John
John
Offline
Resolved
0 votes
Hi all,

For the purpose of using an NFS server for PXE, I was looking for a way to implement it on COS 5.2 & -6.4.
I found this thread, but it didn't answer my questions.

COS 5.2:
I was able to install the NFS utilities by doing the following:
yum install nfs-utils rpcbind

But when I attempted to start the service I received the following error message:
# service nfs start
Starting NFS services: [ OK ]
Starting NFS quotas: Cannot register service: RPC: Unable to receive; errno = Connection refused
rpc.rquotad: unable to register (RQUOTAPROG, RQUOTAVERS, udp).
[FAILED]
Starting NFS daemon: [FAILED]

To set the service to start on boot I was supposed to do the following:
# chkconfig rpcbind on
error reading information on service rpcbind: No such file or directory

Only the following command did not give an error:
chkconfig nfs on

According to this thread, I am supposed to edit /etc/exports and add the following (on my box it was an empty file):
/var/flexshare/shares/pxe *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)

I didn't attempt this yet on my COS 6.4 box.

Please assist,

John

Ps. I don't understand any of this, so please keep it simple.
Saturday, May 25 2013, 11:22 PM
Share this post:
Responses (7)
  • Accepted Answer

    John
    John
    Offline
    Thursday, June 06 2013, 04:49 PM - #Permalink
    Resolved
    0 votes
    Hi all,

    After testing the PXE setup on a COS 6.4 box, I can now confirm that the problem is "portmap" on the COS 5.2 box.
    I tested all live versions several times successfully, on 4 different clients with "rpcbind" on a COS 6.4 box.
    I have updated the 1st post of my HowTo add functionality to your PXE server thread.

    Closing this thread until further notice.

    John
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Wednesday, June 05 2013, 02:26 PM - #Permalink
    Resolved
    0 votes
    Hi all,

    I discovered that it is not possible to run "rpcbind" on COS 5.2.
    I tried to fix this issue by using the "/etc/exports" file, but the results are still as unstable as when not using "/etc/exports".
    "/etc/exports" looks something like this:
    /var/flexshare/shares/pxe/ubuntulive/32b/12.04 *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure,no_subtree_check)
    /var/flexshare/shares/pxe/ubuntulive/32b/13.04 *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure,no_subtree_check)
    /var/flexshare/shares/pxe/mint/32b/14 *(ro,no_root_squash,async,no_subtree_check)

    After making any changes to "/etc/exports" I restarted the NFS server with:
    service nfs restart

    Sometimes Mint- & Ubuntu live run from the PXE boot on the COS 5.2 box and sometimes they don't.
    The error message that keeps returning is:
    IP-Config: no response after # secs - giving up

    This problem only occurs on 1 of my clients, but at another location where I run a COS 6.4 box with "rpcbind", I have an exact same client without these problems.
    If someone knows how to solve this instability issue, please respond.

    Thanks in advance,

    John
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Tuesday, June 04 2013, 03:47 PM - #Permalink
    Resolved
    0 votes
    Hi all,

    I have another NFS related question so I reopened this thread.
    At home I run COS 5.2 in gateway mode.
    On some of my clients I cannot PXE boot Ubuntu- & Mint live.
    At another location I run COS 6.4 in gateway mode.
    There I am able to PXE boot Ubuntu- & Mint live on exactly the same hardware clients.

    I suspect that the difference is the older "portmap" on COS 5.2 and the newer "rpcbind" on COS 6.4.
    I tried to install and start "rpcbind" on my COS 5.2 box by doing the following:
    # yum install rpcbind
    Loading "protect-packages" plugin
    Loading "kmod" plugin
    base-supplements | 951 B 00:00
    base-kernels | 951 B 00:00
    base-updates | 951 B 00:00
    clearcentos-os | 951 B 00:00
    base-os | 1.1 kB 00:00
    clearcentos-updates | 951 B 00:00
    base-console | 951 B 00:00
    Setting up Install Process
    Parsing package install arguments
    No package rpcbind available.
    Nothing to do
    # service rpcbind start
    rpcbind: unrecognized service

    I wonder if and how it is possible to run the "rpcbind" service on a COS 5.2 box, so my clients at home can PXE boot with Ubuntu- & Mint live too.

    Please advice,

    John

    Ps.
    Currently the COS box 6.4 is not operational due to Internet problems, so I am unable to continue testing this.
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Tuesday, May 28 2013, 03:06 PM - #Permalink
    Resolved
    0 votes
    Thanks Bryan,

    I really appreciate your compliment.
    I have a lot more tools and stuff I want to share about PXE booting, but unfortunately I don't have the time until next week to add this to the thread.

    Your answer was right on the money.
    It seems that "rpcbind" is the new version of "portmap" (how should I ever know that ...).
    Obviously on COS 5.2 "portmap" is used and on COS 6.4 it's "rpcbind".

    Greetings,

    John

    EDIT:
    The first post of my PXE tutorial has been updated.
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Tuesday, May 28 2013, 08:38 AM - #Permalink
    Resolved
    0 votes
    Ok ... sorry to bother you guys with maybe another simple question ... :blush:
    But after successfully enabling an NFS server on my COS 5.2 box, I am unable to do so with my COS 6.4 box.
    I successfully installed the NFS service with:
    yum install nfs-utils rpcbind

    I added the following line to "/etc/exports" (not sure what this means):
    /var/flexshare/shares/pxe *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)

    But when I attempt to start portmap I get the following error message:
    # service portmap start
    portmap: unrecognized service

    Please advice & thanks in advance,

    John
    Ps.
    When I searched this forum for "portmap", the only result was this non related post:
    Use one UPS for graceful shutdown of multiple machines
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Sunday, May 26 2013, 02:40 PM - #Permalink
    Resolved
    0 votes
    Thanks Bryan,

    I will look into it and keep you posted about my discoveries.

    Greetings,

    John

    EDIT:
    The first answer to the same question that I had, solved it for me.
    I implemented this with this thread: HowTo: Add functionality to your PXE server
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, May 25 2013, 11:49 PM - #Permalink
    Resolved
    0 votes
    It's been a while since I've used NFS, but take a look at this. It may give you a starting point.

    http://www.linuxquestions.org/questions/linux-software-2/nfsd-fails-to-start-due-to-rpc-224200/
    The reply is currently minimized Show
Your Reply