0 votes
This would be the first time I have ever tried to compile code. So if what I am saying does not make sense, or is very "noob" like I apologize in advance. I am accustom to using nmon to capture reports regarding overall system performance, and to help in troubleshooting issues because of this I would like to get it working on clearos. However seem to be running into issues.

To this point i have enabled the developer repos
 yum-config-manager --enable clearos-core clearos-developer 

Installed what I belive to be the devel tools
 yum --enablerepo=clearos-core,clearos-developer,clearos-epel,clearos-updates-testing install clearos-devel app-devel 

Downloaded the make file along with lmon14g.c from the source forge project. I am following instructions that I found on google which seem to indicate to look in the make file for the os version you are using and execute the name represented onto the command line in the syntax

 make nmon_x86_rhel152 

The reason i chose rhel52 is because it said x86 which is what I am running and figured rhel is the closest thing to clearos. When i ran the command i get error cc command not found. I would guess this is a c compiler? I am not sure what package I needing to get this to work. I also tried to do a yum whatprovides on cc and a slew of packages was returned, most of which i am sure are not needed however I am not sure what to pick. If anyone could help get this working I would greatly appreciate it.
Friday, November 08 2013, 03:15 AM
Share this post:
Responses (1)
  • Accepted Answer

    Friday, November 08 2013, 08:25 AM - #Permalink
    0 votes
    For ClearOS 6.x use either nmon_x86_64_rhel6 or nmon_x86_rhel6.
    The reply is currently minimized Show
Your Reply