Forums

Resolved
0 votes
Hi, I'm new to the community. I need to insert a hostname in the client IP field in RADIUS configuration. When I try, the answer is "ivalid ip address". Can someone help me? Thanks...
Wednesday, April 11 2018, 11:35 AM
Share this post:
Responses (6)
  • Accepted Answer

    Wednesday, April 11 2018, 03:26 PM - #Permalink
    Resolved
    0 votes
    If it is a public IP, is Radius the right answer? Would a VPN connection be more suitable. Note I am not very familiar with what Radius can do.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2018, 03:12 PM - #Permalink
    Resolved
    0 votes
    sorry .. I have not read your second answer because I was writing ... The problem is that the IP is a remote IP (public and dynamic) and therefore I can not control it locally from the DHCP server

    Now I try to modify the configuration lines as you wrote.
    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2018, 02:49 PM - #Permalink
    Resolved
    0 votes
    But if you understood the quote from /etc/raddb/clients.conf, the hostname is evaluated once only and even if the IP changes the Radius will keep pointing to the old IP so using the hostname will fail. If the host is getting its IP from the DHCP server, can you use "Static Leases" in the DHCP server so it always gets the same IP?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2018, 02:37 PM - #Permalink
    Resolved
    0 votes
    Thanks for your reply. The problem is that IP is dynamic and so I need a dynamic dns to refer to it. I had read in the documentation that you could enter a "hostname"
    Documentation
    Is there a different way to solve the problem?
    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2018, 02:26 PM - #Permalink
    Resolved
    0 votes
    Note I am just identifying a possible bug in the installation where you may have to add a line to the bottom of /etc/raddb/radiusd.conf:
    $INCLUDE clearos-eap.conf
    And also rename /etc/raddb/mods-enabled/eap to /etc/raddb/mods-enabled/.eap so it gets hidden.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2018, 01:34 PM - #Permalink
    Resolved
    0 votes
    It is asking for an IP address and not a hostname. The use of hostnames is not recommended by the authors of Freeradius and therefore have not been allowed by ClearOS.

    Here is an excerpt from /etc/raddb/clients.conf:
    	#
    # A note on DNS: We STRONGLY recommend using IP addresses
    # rather than host names. Using host names means that the
    # server will do DNS lookups when it starts, making it
    # dependent on DNS. i.e. If anything goes wrong with DNS,
    # the server won't start!
    #
    # The server also looks up the IP address from DNS once, and
    # only once, when it starts. If the DNS record is later
    # updated, the server WILL NOT see that update.
    #
    The reply is currently minimized Show
Your Reply