Community Forum

Resolved
0 votes
Hello all,
I've a Proliant server with 4 physical nics. I'd like to install it as a gateway and use the 1st nic as the external role. Now, with the remaining 3 nics, I'd like to make a trunk and use it as my lan interface to increase the speed. Is there a way to do that ?
thanks to all for your help
Arnaud
Thursday, March 08 2018, 10:26 AM
Share this post:
Responses (43)
  • Accepted Answer

    Friday, March 09 2018, 09:13 PM - #Permalink
    Resolved
    0 votes
    No worry Nick, there's a long time I'm out of idea :)
    Unfortunately I can't disconnected the switch, i'm not on site yet but will still try that.
    I was able this afternoon to have the bond0 displaying in the ifconfig command. Maybe at this time a 'ifup bond0' would have been successful :)
    I dont know why I can't get it anymore ;maybe because I made too much tests and ... so I'm going to restart with a fresh new installation .
    But thanks so much for your help and I wish you a wonderful week-end :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:01 PM - #Permalink
    Resolved
    0 votes
    I'm pretty much out of ideas now. Can you disconnect the switch and see if it comes up?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:01 PM - #Permalink
    Resolved
    0 votes
    it's look fine..

    [root@localhost ~]# lsmod | grep bond
    bonding 145728 0
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 07:34 PM - #Permalink
    Resolved
    0 votes
    Can you check the "bonding" module is loaded:
    lsmod | grep bond
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 07:06 PM - #Permalink
    Resolved
    0 votes
    ok, I remove the type line, thanks.
    this time it is displayed in the webconfig but still impossible to start my bond (device no present) ...
    and I've absolutely no idea where to look. I could understand that for a physical network card but here... !
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 06:50 PM - #Permalink
    Resolved
    0 votes
    My bad I've edited my post. TYPE="Bonded" is correct, but the devs have said the type is not used and can left off like you did or it must be set to Bonded. If left blank it takes it type from DEVICE setting.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 06:43 PM - #Permalink
    Resolved
    0 votes
    Thanks Nick,
    I'm going to restart my server. My 2 nics are connected to a switch so should be fine fine :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 06:33 PM - #Permalink
    Resolved
    0 votes
    If you have /etc/sysconfig/modules/bonding.modules set up, can I suggest a reboot. It tidied up problems I was having.

    Your NICs are all the same as I suspected and they all use the tg3 driver which is correct so nothing obvious. I'll try to check some time if they support bonding.

    My IP link show is::
    ip link show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,SLAVE,UP> mtu 1500 qdisc pfifo_fast master bond0 state DOWN mode DEFAULT qlen 1000
    link/ether 00:1f:d0:97:f7:b1 brd ff:ff:ff:ff:ff:ff
    3: enp3s7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 00:1d:0f:be:4e:95 brd ff:ff:ff:ff:ff:ff
    4: bond0: <NO-CARRIER,BROADCAST,MULTICAST,MASTER,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT qlen 1000
    link/ether 00:1f:d0:97:f7:b1 brd ff:ff:ff:ff:ff:ff
    5: enp3s6: <NO-CARRIER,BROADCAST,MULTICAST,SLAVE,UP> mtu 1500 qdisc pfifo_fast master bond0 state DOWN mode DEFAULT qlen 1000
    link/ether 00:30:bd:70:ca:22 brd ff:ff:ff:ff:ff:ff
    But I have nothing connected to the NICs so they show as down.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 06:25 PM - #Permalink
    Resolved
    0 votes
    another information but ... don't know if it's useful :

    [root@localhost ~]# ip link show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether 9c:8e:99:4f:61:98 brd ff:ff:ff:ff:ff:ff
    3: eno2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 9c:8e:99:4f:61:99 brd ff:ff:ff:ff:ff:ff
    4: eno3: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP mode DEFAULT qlen 1000
    link/ether 9c:8e:99:4f:61:9a brd ff:ff:ff:ff:ff:ff
    5: eno4: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP mode DEFAULT qlen 1000
    link/ether 9c:8e:99:4f:61:9a brd ff:ff:ff:ff:ff:ff
    6: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 9c:8e:99:4f:61:9a brd ff:ff:ff:ff:ff:ff

    I think this is normal that my eno3, eno4 and bond0 have the same link/ether address ... ?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 06:08 PM - #Permalink
    Resolved
    0 votes
    .. i just realized : according to the command ( cat /proc/net/bonding/bond0 ) i get the following result :

    Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
    Bonding Mode: load balancing (round-robin)
    ...

    but round-robin is BONDING_OPTS="mode= 0... " and in my ifcfg-bond0 file this is mode 5, so should be Load Balancing.

    DEVICE=bond0
    TYPE="Bonding"
    IPADDR="192.168.1.70"
    NETMASK="255.255.255.00"
    BONDING_MASTER="yes"
    BOOTPROTO="static"
    ONBOOT="yes"
    BONDING_OPTS="mode=5 miimon=100"

    I changed the value (mode=1, 2) but I always get the round-robin mode ... means the config file is not read/played till the end ?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 05:49 PM - #Permalink
    Resolved
    0 votes
    Maybe I should start again with a fresh new installation. After my last installation, I was able to see my bond0 through the ifconfig commmand, even it had no ip address. Now I can't see it anymore...
    I dont know ..
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 05:39 PM - #Permalink
    Resolved
    0 votes
    Hello Nic :)
    so, here's the result of the command :
    [root@localhost ~]# lspci -k | grep Eth -A 3
    02:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Hewlett-Packard Company Device 3372
    Kernel driver in use: tg3
    Kernel modules: tg3
    02:00.1 Ethernet controller: Broadcom Limited NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Hewlett-Packard Company Device 3372
    Kernel driver in use: tg3
    Kernel modules: tg3
    02:00.2 Ethernet controller: Broadcom Limited NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Hewlett-Packard Company Device 3372
    Kernel driver in use: tg3
    Kernel modules: tg3
    02:00.3 Ethernet controller: Broadcom Limited NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Hewlett-Packard Company Device 3372
    Kernel driver in use: tg3
    Kernel modules: tg3

    for the command ; I tried : ifup bond0 but same result :(
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 05:14 PM - #Permalink
    Resolved
    0 votes
    I've got it to show read-only in the webconfig now with TYPE="Bonding"

    [edit]
    Should be TYPE="Bonded"
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 05:06 PM - #Permalink
    Resolved
    0 votes
    Can you do a quick hardware check with:
    lspci -k | grep Eth -A 3


    The command to up the interface would be:
    ifup bond0
    Not:
    ifup ifcfg-bond0


    If you have the interface in the webconfig it is probably because you have TYPE="Ethernet". Can you change it to TYPE="Bond" when it will disappear from the webconfig (bug) but it may behave better. When I set mine to TYPE="Bridge" the webconfig looked much better but in the background it really misbehaved and gave errors in /var/log/messages when trying to bring it up.

    It is possible that my bonding is showing sifferent from yours as I have two very unequal NICs (one is 10/100/1000 and the other is 10/100)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 03:43 PM - #Permalink
    Resolved
    0 votes
    pfff... no way ! The most I've been able to do is having my eno3 and eno4 up but not my bond0.
    in my web config I've my bond0 display with an IP address, the correct speed (the concatenatino of my 2 network cards) but no link

    my cat /proc/net/bonding/bond0 seems fine :
    [root@localhost bond0]# cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

    Bonding Mode: load balancing (round-robin)
    MII Status: up
    MII Polling Interval (ms): 0
    Up Delay (ms): 0
    Down Delay (ms): 0

    Slave Interface: eno3
    MII Status: up
    Speed: 1000 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 9c:8e:99:4f:61:9a
    Slave queue ID: 0

    Slave Interface: eno4
    MII Status: up
    Speed: 1000 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 9c:8e:99:4f:61:9b
    Slave queue ID: 0

    but impossible to start it :
    [root@localhost bond0]# ifup ifcfg-bond0
    not present, delaying initialization bond0

    before playing with the type, I could have in my ifconfig the bond0 displaying but without any IP address.
    I wonder if my hardware could be the reason of fhat
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 01:18 PM - #Permalink
    Resolved
    0 votes
    No worry Nic and thank so much for your great help and the time you gave to me !!
    I really appreciated, thanks :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 12:58 PM - #Permalink
    Resolved
    0 votes
    I might have mixed and matched my bonding options as I lost them when I edited the interface when it was TYPE=Ethernet. I may have done a wrong edit. All I know is that it was working. The machine is off at the moment and I have to stop further playing as I have a webinar to attend.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 12:54 PM - #Permalink
    Resolved
    0 votes
    i just realized I dont have the exact same output as you in the cat /proc/net/bonding/bond0 :

    [root@localhost ~]# cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

    Bonding Mode: load balancing (round-robin)
    MII Status: up
    MII Polling Interval (ms): 0
    Up Delay (ms): 0
    Down Delay (ms): 0


    Slave Interface: eno3
    MII Status: up
    Speed: 1000 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 9c:8e:99:4f:61:9a
    Slave queue ID: 0

    Slave Interface: eno4
    MII Status: up
    Speed: 1000 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 9c:8e:99:4f:61:9b
    Slave queue ID: 0
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 12:45 PM - #Permalink
    Resolved
    0 votes
    ok, now I've the exact same configuration as you except that my nics are eno3 and eno4.
    I created the file /etc/sysconfig/modules/bonding.modules and put "modprobe bonding" inside.

    I restarted my server and :
    ifup ifcfg-eno3 and eno4 OK
    ifup ifcfg-bond0 failed

    in cat /proc/net/bonding/bond0 I've the same as you but is it normal that for both interfaces we have slave queue ID : 0 ?
    finally, in my weconfig, my bond0 is not displayed but my eno3 and eno4 are under the 'Ethernet' section.

    both have the link to yes, have the DHCP option crossed but impossible to get an IP address :(
    I think I'm really stupid :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 12:02 PM - #Permalink
    Resolved
    0 votes
    The Link Status stays as no until you have a physical connection. Unplug the connection again and it goes back to no. Remember to set up your DHCP server on bond0.

    I was using 7.4 for all my testing.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 11:41 AM - #Permalink
    Resolved
    0 votes
    Wow, I need to check all of this, thanks so much !
    In the meantime, I installed the las COS version (7.4). The config files are a little bit different (no more quotes requested) but ...
    I was able to make up my eno2 nic but not the bond0 .. what is strange is the following :

    [root@localhost /]# cat /proc/net/bonding/bond0
    Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

    Bonding Mode: load balancing (round-robin)
    MII Status: up
    MII Polling Interval (ms): 0
    Up Delay (ms): 0
    Down Delay (ms): 0

    Slave Interface: eno3
    MII Status: up
    Speed: 1000 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 9c:8e:99:4f:61:9a
    Slave queue ID: 0

    it seems that bond is up but in the webconfig, it is written as linked :no
    I'll check to see if I receive an Ip address
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 11:34 AM - #Permalink
    Resolved
    0 votes
    I created a file /etc/sysconfig/modules/bonding.modules with execute permissions and put in it:
    modprobe bonding
    I have TYPE="Bond" and LANIF="bond0", rebooted end everything came up as expected. I can even restart networking OK! It is the same with LANIF="bond0 enp2s0 enp3s6".
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 11:10 AM - #Permalink
    Resolved
    0 votes
    Don't use TYPE="Bridge". It causes other problems!
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 10:54 AM - #Permalink
    Resolved
    0 votes
    I tend to agree with you. I've just fired up my old server, stuck in an old ethernet card, bust the SATA connector on the disk, panicked then set up bonding like this:
    /etc/sysconfig/network-scripts/ifcfg-bond0:
    DEVICE=bond0
    TYPE="Ethernet"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    IPADDR="192.168.1.1"
    NETMASK="255.255.255.0"
    BONDING_OPTS="mode=5 miimon=100"
    BONDING_MASTER="yes"


    /etc/sysconfig/network-scripts/ifcfg-enp2s0:
    DEVICE=enp2s0
    TYPE="Ethernet"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="none"
    MASTER="bond0"
    SLAVE="yes"


    /etc/sysconfig/network-scripts/ifcfg-enp3s6:
    DEVICE=enp3s6
    TYPE="Ethernet"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="none"
    MASTER="bond0"
    SLAVE="yes"


    /etc/clearos/network.conf:
    # Network mode
    MODE="gateway"

    # Network interface roles
    EXTIF="enp3s7"
    LANIF="bond0 enp2s0 enp3s6"
    DMZIF=""
    HOTIF=""

    # Domain and Internet Hostname
    DEFAULT_DOMAIN="oldserver.lan"
    INTERNET_HOSTNAME="gateway-i.oldserver.lan"

    # Extra LANS
    EXTRALANS=""

    # ISP Maximum Speeds
    ENP3S7_MAX_DOWNSTREAM=0
    ENP3S7_MAX_UPSTREAM=0


    "systemctl status network.service" fails but I can do an "ifup bond0", "ifup enp2s0" and "ifup enp3s6"

    I set up the DHCP server on bond0 and I can get a network connection on my laptop from either physical NIC. I have not tried the failover bonding but it may be a good test.

    cat /proc/net/bonding/bond0 gives:
    Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

    Bonding Mode: transmit load balancing
    Transmit Hash Policy: layer2 (0)
    Primary Slave: None
    Currently Active Slave: enp3s6
    MII Status: up
    MII Polling Interval (ms): 100
    Up Delay (ms): 0
    Down Delay (ms): 0

    Slave Interface: enp2s0
    MII Status: down
    Speed: 10 Mbps
    Duplex: half
    Link Failure Count: 0
    Permanent HW addr: 00:1f:d0:97:f7:b1
    Slave queue ID: 0

    Slave Interface: enp3s6
    MII Status: up
    Speed: 100 Mbps
    Duplex: full
    Link Failure Count: 0
    Permanent HW addr: 00:30:bd:70:ca:22
    Slave queue ID: 0


    Note that if you configure bond0 through the webconfig you lose your specific bonding settings:
    BONDING_OPTS="mode=5 miimon=100"
    BONDING_MASTER="yes"
    which is not good.

    Also note the webconfig seems not to be aware of the "Bond" Type so I had to set it to Ethernet to get it to show.

    I'll have to ask about the failure of the network restart with "service network restart" as it seems to be working one way but not the other:
    systemctl status network.service
    ● network.service - LSB: Bring up/down networking
    Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
    Active: failed (Result: exit-code) since Fri 2018-03-09 10:39:11 GMT; 12min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 22530 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)
    CGroup: /system.slice/network.service
    └─17203 /sbin/dhclient -1 -q -lf /var/lib/dhclient/dhclient--enp3s...

    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan network[22530]: RTNETLINK answers: Fi...
    Mar 09 10:39:11 gateway-h.oldserver.lan systemd[1]: network.service: control ...
    Mar 09 10:39:11 gateway-h.oldserver.lan systemd[1]: Failed to start LSB: Brin...
    Mar 09 10:39:11 gateway-h.oldserver.lan systemd[1]: Unit network.service ente...
    Mar 09 10:39:11 gateway-h.oldserver.lan systemd[1]: network.service failed.
    Hint: Some lines were ellipsized, use -l to show in full.
    But:
    service network status
    Configured devices:
    lo bond0 enp2s0 enp3s6 enp3s7 wlp0s18f2u4
    Currently active devices:
    lo enp2s0 enp3s7 enp3s6 bond0


    [edit]:
    I did a "modprobe bonding" manually.

    Also if you change TYPE to "Bridge" it shows it in the Webconfig but does not allow you to edit it which is safer as it forces you to edit the underlying file and not lose your bonding settings.

    Can you get your eno3 to work on its own? I can "ifup" both my underlying interfaces
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 10:04 AM - #Permalink
    Resolved
    0 votes
    if I make a #ifconfig, none are displayed (nor bond0 neither nic cards attached to it) . Maybe the problem comes from the error message when I try to make up my nic card ?

    #ifup eno3 -> device not present
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:51 AM - #Permalink
    Resolved
    0 votes
    Ok thanks. I added the quotes again and type=ethernet. Bond0 displaying again but not nic attached to it !
    Grrr :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:47 AM - #Permalink
    Resolved
    0 votes
    I'd add the:
    TYPE="Ethernet"
    as well - in quotes as you've found out.

    Your last reference looks old as it talks about loading NIC drivers through modprobe.conf and this no longer happens. It stopped in ClearOS 6.x
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:42 AM - #Permalink
    Resolved
    0 votes
    ok, i just copied and paste the given files of the post you sent. Of course, I changed the mac address and the nic names. I let the config file without the quotes.
    After restarting the network service, my bond disappeard from the interface.
    So I'm going to edit my files and add the quotes again and see what's happen

    Thanks :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:34 AM - #Permalink
    Resolved
    0 votes
    Thanks,
    I found the post here : https://wiki.linuxfoundation.org/networking/bonding
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:23 AM - #Permalink
    Resolved
    0 votes
    I've also been looking at this link. There they also have:
    TYPE=Ethernet
    BOOTPROTO=none
    in their physical interface files. I believe the "Type" line governs where it shows in the Webconfig IP Settings.

    I don't see that we don't have bonding support as we're both using Centos and RHEL guides so out ifup script should be the same. What is your reference about ifenslave?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 09:15 AM - #Permalink
    Resolved
    0 votes
    i'm a litte bit confused because I found a post to check if the dystro support bonding. I had to do that :

    The first command determines if the use of sysconfig or initscripts. Here it is initscripts
    [root@localhost /]# rpm -qf /sbin/ifup
    initscripts-9.49.30-1.v7.1.x86_64

    Then, the following commande shoud return something, if not, could mean bonding is not supported !
    [root@localhost /]# grep ifenslave /sbin/ifup
    [root@localhost /]#
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:54 AM - #Permalink
    Resolved
    0 votes
    After the command
    [root@localhost /]# modprobe bonding

    I added the line : TYPE="bond" to my ifcfg-bond0 file.
    In my network interfaces, it didn't disappeared so progressing :)

    but still no nic under my bond0 and still unable to make my eno3 card up :
    [root@localhost /]# ifup eno3
    not present, delaying initialization eno3

    I checked all modprobe files but it doesnt seem I can change something there ..
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:43 AM - #Permalink
    Resolved
    0 votes
    sorry, I made a mistake.

    I was able to start "modprobe bonding "
    Now I'll have a look into
    ./etc/modprobe.d
    ./usr/sbin/modprobe
    ./usr/lib/modprobe.d

    thanks :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:40 AM - #Permalink
    Resolved
    0 votes
    Thanks Nic :)
    modeprobe bonding doesn't work :

    [root@localhost /]# modeprobe bonding
    -bash: modeprobe : commande introuvable

    If I write into the ifcfg-bond0 file "TYPE="bond0" it disappear from my network interfaces. When not, I have my 2 parts in network interfaces : Ethernet with my eno1, eno2 interfaces and Bonded with my bond0 interface. So this seems to work. The really problem seems to be making up the eno3 and 4 interfaces...
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:20 AM - #Permalink
    Resolved
    0 votes
    Re-reading, you've put "alias bond0 bonding" into network.conf. It should be in a conf file under /etc/modprobe.d but I think the alias bit may be a v5 thing. Try modprobe'ing it manually and don't worry about the alias. It may be that you need to put a line:
    modprobe bonding
    in a file called /etc/sysconfig/modules/something.modules for it to be loaded on boot up. You'd have to play between the two locations. I know the ip_set module loads from /etc/sysconfig/modules/ but not from /etc/modprobe.d/.

    [edit]
    In ifcfg-bond0, please also add "TYPE=Bond"
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:12 AM - #Permalink
    Resolved
    0 votes
    Hi Arnaud,
    Reading the docs you linked to and trying to mix and match the instructions, do you need to load the "bonding" module?
    modprobe --first-time bonding
    I've not seen the --first-time switch before and don't know if it is needed.

    From what you have just posted and the ClearOS doc which is not clear, have you tried:
    LANIF="eno2 en03 en04 bond0"
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 08:04 AM - #Permalink
    Resolved
    0 votes
    OK, in fact it seems system can't make the nics up. When I do a ifup eno3 i get the following answer : does not seem to be present, delaying initialization. I made a check with ifconfig and uuidgen and the nic is found... so I'm a little bit lost yet :(

    [root@localhost /]# uuidgen eno3
    9537e1b9-e558-47da-941b-205b7e879f47

    [root@localhost /]# ifconfig eno3
    eno3: flags=4098<BROADCAST,MULTICAST> mtu 1500
    ether 9c:8e:99:4f:61:9a txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 16
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 09 2018, 07:13 AM - #Permalink
    Resolved
    0 votes
    Hello Nic,
    Thanks for the post. I reinstalled the system and re-configured the nics but still the problem. Here a my confg files :

    network.conf :
    # Network mode
    MODE="gateway"

    alias bond0 bonding

    # Network interface roles
    EXTIF="eno1"
    LANIF="eno2 bond0"
    DMZIF=""
    HOTIF=""

    # Domain and Internet Hostname
    DEFAULT_DOMAIN=""
    INTERNET_HOSTNAME=""

    # Extra LANS
    EXTRALANS=""

    # ISP Maximum Speeds


    ifcfg-bond0

    DEVICE=bond0
    NAME="bond0"
    BONDING_MASTER="yes"
    BOOTPROTO="none"
    IPADDR="192.168.50.9"
    NETMASK="255.255.255.0"
    ONBOOT="yes"
    BONDING_OPTS="mode=5 miimon=100"


    eno3 and 4 a nearly the same except the name
    DEVICE=eno4
    MASTER="bond0"
    SLAVE="yes"
    ONBOOT="yes

    if I make a service network status, I get the following result :
    [root@localhost ~]# service network status
    Périphériques configurés :
    lo bond0 eno1 eno2 eno3 eno4
    Périphériques actuellement actifs :
    lo eno1 eno2

    so bond0 is not active...
    and with the command :

    [root@localhost ~]# systemctl status network.service
    ● network.service - LSB: Bring up/down networking
    Loaded: loaded (/etc/rc.d/init.d/network)
    Active: failed (Result: exit-code) since ven 2018-03-09 07:52:00 CET; 41s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 17556 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)

    mar 09 07:52:00 localhost systemd[1]: Failed to start LSB: Bring up/down ne...g.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 08 2018, 03:03 PM - #Permalink
    Resolved
    0 votes
    Does your system come from a v6 system-restore? I seem to remember we had to edit the file before. Remove eth0 from EXTIF if it does not exist. Add bond0 to the existing LANIF line.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 08 2018, 02:49 PM - #Permalink
    Resolved
    0 votes
    What I dont understand is that in my network.conf file, I've the following :

    EXIF="eno1 eth0" # why eth0 ?
    LANIF="eno2

    my eno3 and eno4 nics are added to my bond0 , so can I create a new line "LANIF="bond0" or add bond0 to the existing line (LANIF="eno2 bond0") ?

    Thanks for your help
    The reply is currently minimized Show
Your Reply