Forums

Resolved
0 votes
Okay, to start off I have used PFsense for a long time. I have changed (Attempted) to change to ClearOS, however I am having issues with DHCP.
I will explain my setup. I have two AT&T wan devices that will get load balanced by the ClearOS server. The ClearOS server will also need to act as a proxy, firwall, and FTP server. Behind the ClearOS server will be my clients. So below is the setup I have.

WAN 1 --- Client 1
ClearOS ------------- Client 2
WAN 2 --- Client 3

Okay, Both of my WAN devices are set up for DHCP and I can actually run the built in speed test and get my speeds. So, I know that part is configured some what correctly. The issue is none of my client devices are getting an IP address from the clearOS server. I can go in and view the network map and see all the clients, but and it shows an IP address. Under the DHCP leases there is none. What am I doing wrong????

http://www.new.readysethosting.com/wp-content/uploads/2019/11/wan-wan-clearos-client-client.png
http://www.new.readysethosting.com/wp-content/uploads/2019/11/Network-Map.png
http://www.new.readysethosting.com/wp-content/uploads/2019/11/IP-Settings.png
http://www.new.readysethosting.com/wp-content/uploads/2019/11/dchp.png
Wednesday, November 27 2019, 09:31 PM
Share this post:
Responses (1)
  • Accepted Answer

    Wednesday, November 27 2019, 10:11 PM - #Permalink
    Resolved
    1 votes
    I think there are a number of things going on. When an interface says Type = DHCP it means it gets it IP address by DHCP. This means your LAN interfaces are trying to get their IP addresses from a DHCP server rather than act as a DHCP server. Normally you'd set LAN interfaces to Static and give it an IP address and subnet which is different for any of the other interfaces, including other LAN's. Also keep clear of 192.168.0.0/24 and 192.168.1.0/24. You can enable the DHCP server with a check box on each LAN NIC, but, once the NIC is set up, you'll need to access the DHCP server through Network > Infrastructure > DHCP Server.
    Your next problem is your WAN's as they are on the same subnet. ClearOS will probably struggle. Can you change your modems to different subnets, again avoiding 192.168.0.0/24 and 192.168.1.0/24.
    Also please delete the DHCP Servers on your WAN interfaces as they serve no purpose.

    Longer term it would be better if you could get your Modems into Bridge mode so ClearOS gets a proper routable, non-private IP.
    The reply is currently minimized Show
Your Reply