Forums

Resolved
0 votes
Version 6.3 Since installing cyrus-imapd I have had literally thousands of "error sending to idled: 3" type entries - over 5,000 in fact as seen below...

[root@alice log]# grep -c "error sending to idled: 3" /var/log/maillog*
/var/log/maillog:386
/var/log/maillog-20120729:0
/var/log/maillog-20120805:0
/var/log/maillog-20120812:2147
/var/log/maillog-20120819:2685
[root@alice log]#

Now idled is running and has a socket...

[root@alice log]# fuser -u /var/lib/imap/socket/idle
/var/lib/imap/socket/idle: 4578(cyrus)
[root@alice log]# ls -ld /var/lib/imap/socket
drwxr-x--- 2 cyrus mail 4096 Aug 19 21:29 /var/lib/imap/socket
[root@alice log]# ls -l /var/lib/imap/socket/idle
srwxrwxrwx 1 cyrus mail 0 Aug 19 21:29 /var/lib/imap/socket/idle
[root@alice log]#

Now when we check the configuration files we find :-

/etc/imapd.conf is missing the idled entries one would expect ie

idlesocket: /var/lib/imap/socket/idle
imapidlepoll: 60

and /etc/syrus is also missing the idled entries ie

# this is only necessary if using idled for IMAP IDLE
idled cmd="idled"

Stopping cyrus-imapd, editing these two files and starting cyrus-imapd has completely stopped these error messages - Comments anyone?

I have even more "SQUAT failed to open index file" messages. Waiting to see if a fix that has been applied works - if so, will create another report...

With this idled 'fix' I have put my ClearOS 64-bit machine into production, at last, as my main firewall. It's running multi-wan (cable and adsl). Secondary function is mail backup whereby imapsync synchronises mail every 4 hour from the main mail-server. For mail running cyrus-impd and squirrelmail, for news leafnode and have installed my usual suite of reports as seen here... http://danda.poweredbyclear.com/frame-34-sysinfo.html . BOINC is running to use up idle cycles.
In Mail
Sunday, August 19 2012, 01:07 PM
Share this post:
Responses (2)
  • Accepted Answer

    Wednesday, August 22 2012, 07:00 AM - #Permalink
    Resolved
    0 votes
    Interesting - thanks... since "Push E-mail" is not enabled here, the problem always manifested itself until the 'fix''...
    The reply is currently minimized Show
  • Accepted Answer

    nello
    nello
    Offline
    Wednesday, August 22 2012, 06:50 AM - #Permalink
    Resolved
    0 votes
    After the first test installation, I had a similar problem. After a couple of re-install, I discovered that enabling the option "Push E-mail" under "Advanced Settings" would add the line:

    idled cmd="idled"

    to the imapd.conf file and, it seems, would make the log message disappear.
    The reply is currently minimized Show
Your Reply