Community Forum

Resolved
0 votes
Hi all -

i'm trying to get my Qnap NAS attached to my domain.

this is the error i recieve from the Qnap box:
Microsoft network settings failed. Please check the DNS server, domain name, and user name and password for logging in the domain.

======== DEBUG START =======
/usr/local/samba/bin/net time set -S server.datalab.co.nz
[command] echo ******** | /usr/bin/kinit "winadmin@DATALAB.CO.NZ"
kinit(v5): Cannot contact any KDC for requested realm while getting initial credentials
[command] echo ******** | /usr/bin/kinit "winadmin@DATALAB.CO.NZ"


Any ideas on this?

My Config:
ClearOS domain: datalab.co.nz
ClearOS server hostname: server
Windows Domain: HOME
Windows DNS Lookup: home.datalab.co.nz

Qnap Windows Domain Config:
Server Description (Optional):
Domain NetBIOS Name: HOME
AD Server Name: server
Domain: datalab.co.nz
Organization Unit (Optional):
Domain Administrator Username: winadmin
Domain Administrator Password: ***********

-yes, i have DNS, NTP, WINS configured correctly on the Qnap box = all pointing to server IP
Tuesday, August 17 2010, 11:16 PM
Share this post:
Responses (9)
  • Accepted Answer

    Sunday, July 06 2014, 06:00 AM - #Permalink
    Resolved
    0 votes
    @Nick: Thanks for encouraging me

    Ok, I find it out: :lol:
    On the qnap I had to add 2 lines in the nss_ldap.conf:

    nss_schema rfc2307bis
    nss_map_attribute uniqueMember member

    Hope it helps someone. I spent many hours for this (simple) solution.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, July 04 2014, 04:49 PM - #Permalink
    Resolved
    0 votes
    @Alexander, O/T PM sent

    [edit]
    Never mind, after many weeks I've just worked it out.
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, July 04 2014, 09:05 AM - #Permalink
    Resolved
    0 votes
    I know that this thread is old. But I think it could be an important Information:

    The connection to the QNAP with ldap works fine and you see the clearos-users and groups. But the qnap does not have the Information who is member in the groups.

    You can test it on the qnap-shell with getent group:
    [~] # getent group 
    administrators:x:0:admin,alex
    everyone:x:100:admin
    guest:x:65534:guest
    allusers:*:63000:
    guests:*:1000546:
    domain_admins:*:1000512:
    domain_users:*:1000513:
    domain_guests:*:1000514:
    domain_computers:*:1000515:
    administrators:*:1000544:
    users:*:1000545:
    power_users:*:1000547:
    account_operators:*:1000548:
    server_operators:*:1000549:
    print_operators:*:1000550:
    backup_operators:*:1000551:
    mygroup:*:60012:


    You see the groups but not the mebmers. The reason is that in the clearos the groupmembers are explained like this:
    member: cn=Alexander Gehrer,ou=Users,ou=Accounts,dc=alexunil,dc=net

    The qnap would need an answer like that:
    memberUid: alex

    I dont have a solution for this. I installed phpLDAPadmin and added the memberUids manually to the groups but this could not be the best Solution.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, January 02 2012, 06:34 PM - #Permalink
    Resolved
    0 votes
    SWEET! Good work...
    I'll check it out...



    Steve Lennox
    HeavyH2O.com
    QNAP TS-859 Pro+ TurboNAS
    3.5.2 Build 1126T
    The reply is currently minimized Show
  • Accepted Answer

    Duncan Rix
    Duncan Rix
    Offline
    Monday, January 02 2012, 06:00 PM - #Permalink
    Resolved
    0 votes
    Hi Guys

    Thought Id share this with you all though this appears to be an old post!

    For Christmas I got a Qnap TS-412 and have spent the past 24 hour trying to connect it to my ClearOS server's LDAP.

    After many hours of not really getting any where and realising that Qnap logs where not giving an error's when joining. I started to look more at the LDAP server its self.

    I ran the first command listed here under the heading "Accessing the LDAP Directory via Command Line".

    Using the info listed I found my Qnap NAS in there all ready connected. So after some more perusing of the command line output I found where my user accounts where.

    So for Users Base DN I used

    ou=Users,ou=Accounts,dc=example,dc=co,dc=uk

    and for Group Base DN

    ou=Groups,ou=Accounts,dc=example,dc=co,dc=uk

    I can now see all my user's and group's from the Qnap YAY

    Now thats as far as iv got so far so iv not tested adding a domain user and file share, I was just well chuffed to have it working. Hope this helps you all, and I shall report back after more testing.

    Happy new Year all
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, November 30 2011, 10:21 PM - #Permalink
    Resolved
    0 votes
    The device has 5TB of DATA on the array... it appears , in order create an ISSCI system we need to format the array and start from scratch.. not an option at this time.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, November 19 2011, 09:56 PM - #Permalink
    Resolved
    0 votes
    Just thinking about something different but have you thought about using issci option of your qnap and creating lun then try to get the flexshare to use it as storage instead? Not sure if its possible

    As opposed to adding the unit to the domain as a workstation esk type of device via samba
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 07 2011, 11:09 PM - #Permalink
    Resolved
    0 votes
    Anyone manage to resolve this ? We are in the process of bringing up a ClearOS system as a PDC to replace the existing Windos2008 DC.
    We have (2) QNAP NAS boxes running without a problem in Active directory... but LDAP / Samba access control to these is not working out at all.... Worst case ...is there a way to "flexshare" the NAS folder shares and maintain some sort of read / write / access control ?
    The reply is currently minimized Show
  • Accepted Answer

    Paul Gale
    Paul Gale
    Offline
    Sunday, December 19 2010, 11:10 AM - #Permalink
    Resolved
    0 votes
    Did you get this to work? I'm having the same problem.
    The reply is currently minimized Show
Your Reply