Forums

A Brandsma
A Brandsma
Offline
Resolved
0 votes
Hey guys,

I just recently setup my ClearOS (v7) gateway. The two eth interfaces work great, and I'm typing to you from a computer currently connected through the ClearOS router.

I have tried to install 'app-wireless' with yum, which succeeded, but when I try to connect to the wireless network (which does show up among the wifi networks on my phone), it simply says 'incorrect password'. Which is most likely not my problem, seeing as I could read it directly from the screen.
A while later, after trying several times with the same password and such, it seems to hang on 'connecting...' and eventually says 'Failed to obtain IP address'. This might be a security measure or my phone cannot acquire an IP address from the wireless interface.

https://ibb.co/bNZpLR


These settings all seem fine, I believe.

https://ibb.co/mHn4n6

Both ethernet gates work fine. The blackening of my IP is for privacy reasons, but you can assume that it gives a nice and healthy xx.xx.xxx.xxx.

I currently haven't added any configuration to the wireless port. I've tried to configure it manually with both static and DHCP settings, however that did not seem to help.

https://ibb.co/dex9LR

It seems like my wireless network interface is both sending and receiving packets. Although my knowledge is limited here.

I tried the following:
<ul>
Restart the 'app-wireless' service
Restart the router
Configured the wireless interface manually, with 'app-wireless' still running
Asked you nice people
</ul>

I saw something about bridging between the WAN gate and my wireless interface, is this something I should do?
Or any other ideas why I cannot connect to my wifi?

P.S. It seems that my laptop manages to connect to the network. However, it still has no internet access.

https://ibb.co/cRvDfR

It isn't receiving any packets.

https://ibb.co/hJMVS6

It seems to have a IPv4 adress, but not a default gateway. A default gateway is necessary right?
Thursday, December 14 2017, 10:53 PM
Share this post:

Accepted Answer

Sunday, December 17 2017, 09:16 PM - #Permalink
Resolved
0 votes
This is not looking so easy to resolve. References such as this say the stock driver does not work. It does refer you to the ElRepo kmod-wl package and ElRepo have these instructions on how to build it. I've followed them (departing a bit as I have a build environment already) and I've ended up with the kmod-wl package which you are welcome to try here. It does the blacklisting for you (in /usr/lib/modprobe.d/blacklist-Broadcom.conf).

Please post back with the results. If it does not work you should simply be able to remove the package again and reboot.

BTW Master Mode is good but then something is still not working, and for what it is worth you are currently using the bcma/bcma-pci-bridge driver (from the lspci command) and not the brcmsmac driver which is not included in ClearOS.
The reply is currently minimized Show
Responses (15)
  • Accepted Answer

    Wednesday, December 20 2017, 03:14 PM - #Permalink
    Resolved
    0 votes
    From what I've read, if your two radios can operate at the same time, you may still have an issue as you have only one NIC interface. It may be worth looking at the ElReop driver if that is the case.
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Wednesday, December 20 2017, 02:50 PM - #Permalink
    Resolved
    0 votes
    Hey Nick,

    I am yet to update my wireless to 5GHz n, but will probably take on that endeavour soon.

    As it stands I'm going to up my security a bit with SSH, fail2ban, etc.

    This is just a status update, in case you're interested, I'll come back to you when I change the modulation of my radio.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 18 2017, 09:56 PM - #Permalink
    Resolved
    0 votes
    Google "hostapd.conf" and scroll down to the section headed:
    ##### IEEE 802.11n related configuration ######################################
    ;)

    [edit]
    I don't think you have a 5GHz radio
    [/edit]

    [edit2]
    I'm wrong, you have both radios. You'll need to read the man page to see if you can get 5GHz n with 2.4GHz g
    [/edit2]
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Monday, December 18 2017, 09:24 PM - #Permalink
    Resolved
    0 votes

    # General settings
    #bridge=br0
    interface=wlp3s0b1
    driver=nl80211
    hw_mode=g
    channel=9
    auth_algs=1
    ssid=Untrusted Network
    macaddr_acl=0
    ignore_broadcast_ssid=0
    ieee8021x=0


    So, there are the settings of hostapd. I've tried to switch things up a little, however all these changes resulted in 'app-wireless' not starting.

    Change hw_mode to 'n'
    Change hw_mode to 'a'
    Change channel to '120' (This seemed to be 5.6 ghz according to iwlist channel)


    Changing the wireless interface channel by using the command iw did work, however it won't let me get up to channels with frequencies of around 5.4 GHz.

    It's starting to look like my hardware does not support 802.11n, despite the letter showing up at the drivers.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 18 2017, 02:48 PM - #Permalink
    Resolved
    0 votes
    hostapd is installed with app-wireless:
    [root@gateway-h ~]# locate hostapd
    /etc/hostapd
    /etc/hostapd/hostapd.conf
    /etc/sysconfig/hostapd
    /etc/systemd/system/multi-user.target.wants/hostapd.service
    /usr/clearos/apps/wireless/deploy/hostapd.conf
    /usr/lib/systemd/system/hostapd.service
    /usr/sbin/hostapd
    /usr/sbin/hostapd_cli
    /usr/share/doc/hostapd-2.4
    /usr/share/doc/hostapd-2.4/README
    /usr/share/doc/hostapd-2.4/README-WPS.hostapd
    /usr/share/doc/hostapd-2.4/README.hostapd
    /usr/share/doc/hostapd-2.4/hostapd.accept
    /usr/share/doc/hostapd-2.4/hostapd.conf
    /usr/share/doc/hostapd-2.4/hostapd.deny
    /usr/share/doc/hostapd-2.4/hostapd.eap_user
    /usr/share/doc/hostapd-2.4/hostapd.radius_clients
    /usr/share/doc/hostapd-2.4/hostapd.vlan
    /usr/share/doc/hostapd-2.4/hostapd.wpa_psk
    /usr/share/doc/hostapd-2.4/wired.conf
    /usr/share/licenses/hostapd-2.4
    /usr/share/licenses/hostapd-2.4/COPYING
    /usr/share/man/man1/hostapd_cli.1.gz
    /usr/share/man/man8/hostapd.8.gz
    /var/clearos/base/daemon/hostapd.php
    /var/clearos/wireless/backup/hostapd.conf.Nov-14-2017-17:37:54
    I have just put a cheap 11ac USB dongle on my list for Santa.

    I've just tried installing wireless-tools (for iwlist and iwconfig) and it does not seem to give much. Like you, "iwlist modulation", gave nothing. "iwlist channel" listed the channels available but "iwconfig wlp0s18f2u4 channel 4" failed with "SET failed on device wlp0s18f2u4 ; Operation not supported.". Searching further it looks like it was deprecated in 7.x. This makes me think it is not the right way of managing wireless on ClearOS. The link says wireless-tools is replaced by the iw command which I've just been playing with. To change the channel you have to down the interface first, change the channel then up it:
    ifconfig wlp0s18f2u4 down
    iw dev wlp0s18f2u4 set channel
    ifconfig wlp0s18f2u4 up
    But it does not overwrite the value in hostapd.conf. If you then restart hostapd or the server, you'll get your old channel back. Also the ClearOS webconfig does not see the change of channel using the iw command.

    I think that for any changes not through the webconfig, it is a good, old fashioned manual edit of hostapd.conf then a restart of hostapd which is needed.
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Monday, December 18 2017, 09:36 AM - #Permalink
    Resolved
    0 votes
    It seems like I can't set it to a different modulation.


    [root@gateway ~]# iwlist modulation
    wlp3s0b1 unknown modulation information.
    lo no modulation information.
    enp1s0 no modulation information.
    enp2s0 no modulation information.

    [root@gateway ~]# iwconfig wlp3s0b1 modu auto
    Error for wireless request "Set Modulation" (8B2F) :
    SET failed on device wlp3s0b1 ; Operation not supported.

    [root@gateway ~]# iwconfig wlp3s0b1 modu 11n
    Error for wireless request "Set Modulation" (8B2F) :
    invalid argument "11n".


    The network controller does seem to show me that the hardware supports it.


    03:00.0 Network controller [0280]: Broadcom Limited BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
    Subsystem: Hewlett-Packard Company Device [103c:1510]
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma


    I didn't edit any 'hostapd.conf' files, since it did not exist (or I couldn't find it) . The packages for hostapd do exist though.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 18 2017, 08:52 AM - #Permalink
    Resolved
    0 votes
    I'm glad you have it working. I think the ClearOS interface only supports 802.11g - I can't test as my USB NIC also only supports 802.11g. It would be interesting to see if you can get 802.11n going as well. Have a look at "man hostapd.conf" for the configuration options.
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Sunday, December 17 2017, 09:48 PM - #Permalink
    Resolved
    0 votes
    Hey Nick,

    Don't know what I did, but it worked. I was fiddling around aimlessly before you responded, and I am able to connect to my wireless interface now and get a valid IP address.
    It doesn't seem like what I did actually had any effect, but I'll name them anyway.

    I first installed 'lshw' with yum.

    Then I installed 'wireless-tools' with yum.

    I believe both to be mainly diagnostic tools, so I didn't expect any change from them.

    After this I changed my SSID and Passphrase of the wireless network, and suddenly I could connect with all my devices.


    So, it does seem that the stock driver for BMC43224 works on CentOS. Since I haven't changed it.

    Thanks for all the help Nick!
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Sunday, December 17 2017, 08:48 PM - #Permalink
    Resolved
    0 votes
    After some extra digging, I found out that the wireless interface is in 'Master Mode'.

    I don't quite understand what the other things mean here.


    wlp3s0b1 IEEE 802.11 Mode:Master Tx-Power=19 dBm
    Retry short limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Sunday, December 17 2017, 08:01 PM - #Permalink
    Resolved
    0 votes
    Hey Nick,

    There I am again. Found the network controller among the list.


    03:00.0 Network controller [0280]: Broadcom Limited BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
    Subsystem: Hewlett-Packard Company Device [103c:1510]
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma


    Following from a list of drivers found on internet for Broadcom devices, it seems that, with the proper drivers, AP (master) mode is supported.

    I found the driver that is currently installed to my wireless interface. The current driver is 'brcmsmac'. This driver apparently supports AP (master) mode.


    *-network
    description: Wireless interface
    product: BCM43224 802.11a/b/g/n
    vendor: Broadcom Limited
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlp3s0b1
    version: 01
    serial: ac:81:12:9c:02:13
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=brcmsmac driverversion=3.10.0-693.2.2.v7.x86_64 firmware=610.812 ip=192.168.98.1 latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:18 memory:d0600000-d0603fff


    Nick Howitt wrote:

    If it is internal wireless, have a look at the output from "lspci -knn". It should be easy to spot. It won't necessarily come up with the exact model but the underlying technology and that is more useful.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, December 16 2017, 09:25 AM - #Permalink
    Resolved
    0 votes
    If it is internal wireless, have a look at the output from "lspci -knn". It should be easy to spot. It won't necessarily come up with the exact model but the underlying technology and that is more useful.
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Saturday, December 16 2017, 12:03 AM - #Permalink
    Resolved
    0 votes
    I unfortunately don't know this out of the top of my head. Nor can I find it with the model mini PC online.
    So I'll have to open uo the server, which I won't be able to do for the weekend. I'll get back to you once I get more information.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 15 2017, 10:11 PM - #Permalink
    Resolved
    0 votes
    Your settings look OK. Which wireless NIC do you have and do you know if it supports AP or master mode?
    The reply is currently minimized Show
  • Accepted Answer

    A Brandsma
    A Brandsma
    Offline
    Friday, December 15 2017, 09:03 PM - #Permalink
    Resolved
    0 votes
    Hey Nick,

    Thanks for the editing, I wanted to post the images in directly, however that didn´t seem to work properly.

    I set up wlp3s0p1 with a lan IP (192.168.98.1), and a netmask of 255.255.255.128. Where the netmask of my main LAN NIC (enp2s0) is 255.255.255.0.

    https://imgur.com/BCPrjcZ

    However, my devices still cannot connect. My phone keeps telling me 'authentication error'. And my laptop connects, but still acquires the same 169.x.x.x IP adress.
    The network connection details on my laptop seem to show 255.255.0.0.

    I setup the subnet of wlp3s0p1 as follows:
    https://imgur.com/7lB8ql9


    Nick Howitt wrote:

    Hi, I've edited your post as the image tags weren't working and I've converted them to links.

    You've missed a couple of stages. If you get a 169.x.y.z IP address it means you don't really have a proper IP address. In the Network Interfaces, please configure wlp3s0p1 with a LAN IP in a different subnet from your normal LAN NIC. 192.168.98.1 may be a good one to use (but not 100.1). Then go the the DHCP server and configure the wireless NIC as a DHCP server. All should then work.

    I strongly suggest you don't go down the bridging route until you get the wireless NIC working on its own. It just introduces more variables to a non-working set up.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 15 2017, 06:18 PM - #Permalink
    Resolved
    0 votes
    Hi, I've edited your post as the image tags weren't working and I've converted them to links.

    You've missed a couple of stages. If you get a 169.x.y.z IP address it means you don't really have a proper IP address. In the Network Interfaces, please configure wlp3s0p1 with a LAN IP in a different subnet from your normal LAN NIC. 192.168.98.1 may be a good one to use (but not 100.1). Then go the the DHCP server and configure the wireless NIC as a DHCP server. All should then work.

    I strongly suggest you don't go down the bridging route until you get the wireless NIC working on its own. It just introduces more variables to a non-working set up.
    The reply is currently minimized Show
Your Reply