Community Forum

nuke
nuke
Offline
Resolved
0 votes
Hi.
There used to (COS5.2) a menu driven way to forward one user's email to an external email account. In COS 7 I can't find this.

I've been reading how to do this with postfix main.cfg but I'm worried that it will break something with my virtual domain etc. I found a post that was speaking directly to Zafara but I don't have that installed. My home COS is just stock build with IMAP,, POP and SMTP for two domains.

Since I can't do this (as far as I can tell) from the webconfig, then what is the best way to do this?

Thanks.
In Mail
Monday, January 01 2018, 09:05 PM
Share this post:
Responses (9)
  • Accepted Answer

    nuke
    nuke
    Offline
    Friday, January 12 2018, 02:24 PM - #Permalink
    Resolved
    0 votes
    Mansoor wrote:

    This might help: https://support.google.com/mail/answer/175365

    Thank you Mansoor!
    The reply is currently minimized Show
  • Accepted Answer

    Mansoor
    Mansoor
    Offline
    Friday, January 12 2018, 03:35 AM - #Permalink
    Resolved
    0 votes
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Thursday, January 11 2018, 11:20 PM - #Permalink
    Resolved
    0 votes
    I had all sorts of problems with email since I did the forwarding. I'm not quite sure what the problem was but suspect that this forwarding was the problem or a part of it.

    Ben I tried your suggestions and I liked the fact that I could add forwards from the GUI.

    However it looked like all outbound mail was not leaving. I followed up with a number of people who I sent emails to but they never received anything. So for about 3 days we didn't send any emails. The logs show the email going to mailfilter and then being deleted.

    As I said, there may have been other factors in play because I fixed a certificate issue and imapd failure at the same time as removing the /var/clearos/mail_routing/forwarders file. Upon deleting the forwarders file, doing the aliases command and then reloading postfix, it looks like it's working properly again.

    I think this forwarders file solution needs some more testing.
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Monday, January 08 2018, 02:30 AM - #Permalink
    Resolved
    0 votes
    nuke wrote:

    Ben Chambers wrote:

    Ya...if you've already done custom changes, I'd undo them and try the "ClearOS" way. If things don't work out, you can always 'redo' them.

    B

    Thanks Ben,
    That worked really nicely and via the webconfig too!


    Ben,
    It appears that google is now blocking the emails that are forwarded and everything else sent to Gmail.

    I've seen this in the log this morning.

    Our system has detected that this message is 550-5.7.1 likely unsolicited mail. To reduce the amount of spam sent to Gmail, 550-5.7.1 this message has been blocked. Please visit 550-5.7.1 https://support.google.com/mail/?p=UnsolicitedMessageError 550 5.7.1 for more information.

    Now no mail arrives at Google but it is sent when I look at the logs.

    I have antispam and antivirus running and added spamhaus and barracudacentral.org to my postfix main.cf so the spams getting through are not many.

    Any suggestions on what to check or do?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Thursday, January 04 2018, 08:19 PM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    Ya...if you've already done custom changes, I'd undo them and try the "ClearOS" way. If things don't work out, you can always 'redo' them.

    B

    Thanks Ben,
    That worked really nicely and via the webconfig too!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 03 2018, 02:31 AM - #Permalink
    Resolved
    0 votes
    Ya...if you've already done custom changes, I'd undo them and try the "ClearOS" way. If things don't work out, you can always 'redo' them.

    B
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Tuesday, January 02 2018, 11:52 PM - #Permalink
    Resolved
    0 votes
    Ben Chambers wrote:

    Pete did a bit of experimental work on this for a university that needed this feature.

    To enable the forwarding feature, touch a file:

    touch /var/clearos/mail_routing/forwarders


    At this point, you should be able to see a new "Forwarders" section when adding/editing a user.

    B

    Thanks Ben.
    Since I've already manually changed the aliases file, should I undo those changes or will enabling the forwarders file take the existing changes to the aliases file?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 02 2018, 02:11 PM - #Permalink
    Resolved
    0 votes
    Pete did a bit of experimental work on this for a university that needed this feature.

    To enable the forwarding feature, touch a file:

    touch /var/clearos/mail_routing/forwarders


    At this point, you should be able to see a new "Forwarders" section when adding/editing a user.

    B
    The reply is currently minimized Show
  • Accepted Answer

    nuke
    nuke
    Offline
    Monday, January 01 2018, 09:48 PM - #Permalink
    Resolved
    0 votes
    Here is what I've done so far. Please let me know if you see any problems with this.

    I edited the /etc/aliases file and added at the very bottom
    username: email_address@gmail.com

    Then did
    # newaliases

    # systemctl restart postfix

    As a test, I sent the root emails to my username and forwarded my userid to gmail. It looks like it is forwarding OK.
    The reply is currently minimized Show
Your Reply