Community Forum

Resolved
0 votes
First of all I have to thank and compliment the ClearOS people on the work they do and the product the deliver.
So there's no way I want to be ungrateful or greedy, however there's one thing I have to be critical about and that's the (S)FTP approach to flexshares and web domains. It simply doesn't work. I hear many people complain and struggling (as I do) to get this thing up and running.

Maybe someone from the team can provide us with a simple howto (server and client side)?

I would be even more grateful and enthousiast about this great product!

Thanks in advance....
Wednesday, January 20 2010, 09:22 AM
Share this post:
Responses (5)
  • Accepted Answer

    Wednesday, January 20 2010, 01:47 PM - #Permalink
    Resolved
    0 votes
    I've found a tweak!

    I use Filezilla as the client. The problem was that the ClearOS server replied with it local IP address (192.168.etc). So I told Filezilla to use the external IP address.
    Now it works (so far).

    In Filezilla:

    Settings -> Connection -> FTP -> Passive mode -> Check "Use servers external IP address.."

    Thanks.

    :laugh:
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 20 2010, 01:21 PM - #Permalink
    Resolved
    0 votes
    Also if your using Windows Explorer, it will attempt to login anonymously and then try the user credentials both of which will fail so...try

    ftp://user:password@servername:2121
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 20 2010, 01:18 PM - #Permalink
    Resolved
    0 votes
    Ok you may have more luck by specifying the full path. 550 errors can be caused by clients inadvertently trying to connect to the root of the share first.

    What FTP client are you using? are you connecting from the LAN? if not, have you opened the PASSIVE port range too?

    Make sure Flexshare is set to FTP so it uses port 2121, then connect to:-
    ftp://servername:2121/mypathname
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 20 2010, 10:43 AM - #Permalink
    Resolved
    0 votes
    The issue is that I can't get access to the flexshares, whether I use SFTP or FTP. I opened the ports 2120 to 2123. When I open a session on port 2121 (2123 doesn't work at all) I always get an error on receiving directory contents. I don't see any file or directory at all. The same goes for uploading content to virtual hosts and/or subdomains. If I enable the FTP upload I just can't figure out how to reach these shares.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, January 20 2010, 09:55 AM - #Permalink
    Resolved
    0 votes
    FTP is a funny protocol at the best of times (some say archaic), and getting it to work can be a pain in general not just with flexshares! Problems are often caused by incorrect firewall settings, DNS problems, or dodgy FTP clients. However saying that the flexshares go a long way to making creating an FTP Flexshare much easier

    A browse over the ProFTPD docs will give you some idea as the complexity that you can put in place on an FTP server
    http://www.proftpd.org/docs/directives/linked/by-name.html

    I guess you have seen these docs?
    http://www.clearfoundation.com/docs/user_guide/clearos_enterprise_5.1/flexshares

    That aside, it works just fine here...my biggest tip is NOT to use internet browsers to access FTP shares....they are very bad at following standards. Use a decent standalone FTP client like Filezilla for example, or even Windows Explorer

    Can you elaborate a bit more on what is causing the problem?
    The reply is currently minimized Show
Your Reply