Community Forum

Resolved
0 votes
Context
Running ClearOS downloaded from the site today (so it'll be whatever the latest edition is?) inside a VirtualBox 5.2 environment, and passing in a USB Ralink 5730 Wifi adaptor. Completed install as "Gateway" but with only the wired interface attached. Installed app-wireless and app-hostap. Tried to configure the interface, noticed an error in /var/log/system that suggested the firmware was ancient, so obtained the latest firmware blob from https://www.mediatek.com/products/broadbandWifi/rt5370, unpacked blob and transferred the rt2870.bin file from the common path in there to /lib/firmware/. Rebooted. Tried again....

Issue
Clicking on Network -> Settings -> IP Settings, "Add" Wifi interface (wlp0s12u2). Settings are:

  • Role: LAN
  • Connection Type: Static
  • IP Address: 192.168.2.1
  • Netmask: 255.255.255.0
  • Enable DHCP Server: Yes
  • Wireless Mode: WPA Pre-Shared Key
  • SSID: restricted
  • Passphrase: <somestring>
  • Channel: 3

Click "Update". Get "Ooops! Command execution failed".

Tailing /var/log/system while this occurs shows this log: https://gist.github.com/JonTheNiceGuy/9df3c506dacb469b491596b7fea45304
Tuesday, November 14 2017, 02:08 PM
Share this post:
Responses (1)
  • Accepted Answer

    Tuesday, November 14 2017, 07:23 PM - #Permalink
    Resolved
    0 votes
    Hi Jon,
    I've just tried setting up my USB NIC and it was pretty straightforward. I installed the drivers (mine aren't included in the kernel) and did a "yum install app-wire*". From there I configured the Wireless Access Point settings with WPA-PSK mode and also configured the IP Settings as Role = LAN and Type = Static. I gave it an IP on a different subnet from my normal LAN subnet. I did not even have to configure the DHCP server. It was automatically enabled. Initially I could not connect so I rebooted and it all worked.

    From your set up, you should not need to install rt2870.bin as it is already in /usr/lib/firmware.

    I notice you only have one other NIC in your log dump. Can I check you are in Gateway mode? Also is the Webconfig Wireless Access Point running?

    Otherwise can you try editing your /etc/sysconfig/network-scripts/ifcfg-wlp0s12u2 manually? My equivalent looks like:
    DEVICE=wlp0s18f2u4
    TYPE="Wireless"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    IPADDR="192.168.199.1"
    NETMASK="255.255.255.0"
    It is the last three lines you would need to fix. After that you will need to restart networking or reboot.

    For reference, my hostapd.conf looks like:
    #
    # For more information, look here:
    #
    # http://wireless.kernel.org/en/users/Documentation/hostapd
    #

    ctrl_interface=/var/run/hostapd
    ctrl_interface_group=wheel

    # General settings
    #bridge=br0
    interface=wlp0s18f2u4
    driver=nl80211
    hw_mode=g
    channel=6
    auth_algs=1
    ssid=test
    macaddr_acl=0
    ignore_broadcast_ssid=0
    ieee8021x=0

    # Wireless N
    # wme_enabled=1
    # ieee80211n=1
    # ht_capab=[HT40-][SHORT-GI-40][DSSS_CCK-40]

    # WPA
    wpa=3
    wpa_key_mgmt=WPA-PSK
    wpa_passphrase=my_passphrase
    wpa_pairwise=TKIP
    rsn_pairwise=CCMP
    wpa_group_rekey=300
    wpa_gmk_rekey=640
    The reply is currently minimized Show
Your Reply