Forums

Resolved
0 votes
I cannot find a way to set the global DNS IP.
I don't want to use my ISP's DNS, if i uncheck "Automatic DNS Servers" even though there is 1.1.1.1 in DNS Server, DNS does not work.
Each time the internet disconnects I need to manually use edit the DNS Servers ib "Temporary Override" in /app/network.

How can I turn off "Automatic DNS Servers" and set the global DNS server IP? (from webconfig or CLI)
(I am using multiwan)

Thanks
Sruli
Thursday, May 23 2019, 02:13 PM
Share this post:
Responses (3)
  • Accepted Answer

    nuke
    nuke
    Offline
    Saturday, June 15 2019, 04:03 PM - #Permalink
    Resolved
    0 votes
    Thank you Nick for this. I spent an hour trying to figure this out before I chanced upon this note. I completely forgot (or didn't realize) that the check mark on a completely other setup screen (WAN) had this Automatic DNS checkbox.

    I think that there should be a note on the IP Settings > Network about the Temporary DNS vs Automatic and where to find it. Can I log an improvement suggestion somewhere?

    Thanks again
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 23 2019, 06:06 PM - #Permalink
    Resolved
    0 votes
    Can you access your Webconfig from a browser on your LAN network, e.g. https://192.168.1.254:81, then goto Network->Settings->IP Settings and edit your DNS entries?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 23 2019, 05:58 PM - #Permalink
    Resolved
    0 votes
    Hmm. The normal way is to go into IP settings and, for your WAN, uncheck the Automatic DNS Servers. Go back to the previous screen and the Temporary Override will have changed to Edit and you can enter your settings there. If this does not work, what is the contents of /etc/resolv.conf?
    The reply is currently minimized Show
Your Reply