Community Forum

Resolved
0 votes
hi all,
i wanna allow some wireless client to share my internet connection.but i found no wireless AP options in my ClearOS configure.could u tell me how to do?
thx
Sunday, March 07 2010, 07:04 AM
Share this post:
Responses (10)
  • Accepted Answer

    John
    John
    Offline
    Monday, March 08 2010, 01:50 PM - #Permalink
    Resolved
    0 votes
    Hi all,

    You are right Tim ... sorry guys, I got carried away ... :blush:
    I will not need to start a new thread, because you already answered my question.
    My Davolink DV 2020 has no bridge mode option and the clients DNS settings already point to ClearOS.

    Thanks,

    John
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 08 2010, 01:01 PM - #Permalink
    Resolved
    0 votes
    John maybe best covered in a separate thread - as you are at risk of hijacking this one ;)

    But...using the virtual server function of your modem is the best way to forward all traffic to ClearOS (your gateway), if it doesn't have a separate 'bridge' function

    Ideally all your client DNS settings should point to your ClearOS internal LAN IP. Otherwise name resolution within your network will not work. You *can* point them to your ISP servers but you will be unable to access your local machines by the hostnames. Only ClearOS (your gateway device) needs to have the ISP DNS servers.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 08 2010, 12:37 PM - #Permalink
    Resolved
    0 votes
    Lingfeng Xiong wrote:
    hi,

    Unfortunately not all devices have the driver support to enable 'master' AP mode.

    in my FreeBSD and debian linux,i can set it to AP mode.and i hav already install MadWifi Driver in ClearOS.could u give me some advise?thx

    A quick search on madwifi master mode returned the following - see section on creating a virtual AP
    http://madwifi-project.org/wiki/UserDocs/FirstTimeHowTo" target="_blank">http://madwifi-project.org/wiki/UserDocs/FirstTimeHowTo
    http://madwifi-project.org/wiki/UserDocs/ChangingMode" target="_blank">http://madwifi-project.org/wiki/UserDocs/ChangingMode

    You will need to familiarise yourself with how the madwifi configuration is put together manually, as the ClearOS webconfig only uses iwconfig and so will be unable to configure your card automatically.
    http://madwifi-project.org/wiki/UserDocs
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Monday, March 08 2010, 11:11 AM - #Permalink
    Resolved
    0 votes
    Hi Tim,

    I moved my post to this thread.

    Tim Burgess wrote:
    Eeek, that's not normal behaviour - and certainly not the 'norm'

    You can actually run DHCP on the router and not on ClearOS, as long as the gateway and DNS address it gives out points to your ClearOS IP

    I agree, that's why it took me some time before I was able to get my game servers back on-line.

    I set it up as follows:
    The DNS servers of my router are from my ISP.
    The DNS server of my LAN clients is ClearOS.
    DNS servers of eth1 are from my ISP. (or should this my modem ... ?!?)
    DHCP on ClearOS is enabled.

    I know ... it's confusing ... :silly: ... but so far I have had no problems, other than that when my modem / router firmware is updated that my eth1 occasionally gets a new ip address ... :blink: ... but I learned to live with that.
    Even when it means reprogramming the virtual server on my modem / router and that my game servers will not be available on the Internet, until I did this.

    I only recently changed my modem firewall to only let true the ports that I use.
    Before that I disabled it by creating a virtual server for all ports (1 - 65535) that redirected it's traffic to eth1.

    Greetings,

    John

    EDIT:
    Should I change this setup ... I don't know into what ... ?!?
    Please advise.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 08 2010, 11:03 AM - #Permalink
    Resolved
    0 votes
    hi,

    Unfortunately not all devices have the driver support to enable 'master' AP mode.

    in my FreeBSD and debian linux,i can set it to AP mode.and i hav already install MadWifi Driver in ClearOS.could u give me some advise?thx
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Monday, March 08 2010, 10:54 AM - #Permalink
    Resolved
    0 votes
    Hi all,

    Tim Burgess wrote:
    ... disable DHCP / Firewall ...

    When I disabled DHCP on my modem / router (Davolink DV 2020) with the following code in my browser:
    http://<ip modem>/lancfg2Reset.cgi?enblDhcpSrv=0

    My modem / router and phone stopped working 24 hours later ... :blink:
    The only way I was able to get a connection again was by resetting it.
    Changing the lease time from 24 hours to 9999 hours (the maximum possible) did not solve the problem.
    My ISP even send me another modem, but this did not solve it.

    The only way for me to separate the DHCP from my LAN is to create a virtual server on my modem / router that points to my eth1 (Internet) and to use a different ip range on my LAN than my modem / router.
    It's the only way I got it to work, so if you understand this and know a better way to do this ... please tell me.

    Greetings,

    John
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 08 2010, 10:40 AM - #Permalink
    Resolved
    0 votes
    Unfortunately not all devices have the driver support to enable 'master' AP mode. You can however connect it to an existing wireless network but that defeats your objective

    If you haven't seen it already this list gives an idea of what functions various wireless drivers give:-
    http://linuxwireless.org/en/users/Drivers

    Best method is to connect a space ethernet NIC to the LAN port of a cheap wireless router, disable DHCP / Firewall and it's sorted...no messing around compiling drivers etc. Just setup up the wireless router with a different IP from ClearOS but in the same range
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 08 2010, 10:24 AM - #Permalink
    Resolved
    0 votes
    hi,
    i tried to install MadWifi driver.but when i try to set my Wireless NIC as a AP,it shown me an error:


    [root@clearos ~]# iwconfig ath0 mode master
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument.
    [root@clearos ~]#

    and then i tried to use wlanconfig:

    [root@clearos ~]# wlanconfig ath0 destroy
    wlanconfig: ioctl: Operation not supported
    [root@clearos ~]# wlanconfig ath0 create wlandev wifi0 wlanmode adhoc
    wlanconfig: ioctl: No such device
    [root@clearos ~]#


    could u give me some advise?thx!
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, March 07 2010, 12:55 PM - #Permalink
    Resolved
    0 votes
    WiFi is not supported in 5.1. Yet, this link may give you some ideas on how to get it setup manually.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    John
    John
    Offline
    Sunday, March 07 2010, 12:55 PM - #Permalink
    Resolved
    0 votes
    Hi Lingfeng,

    No need to post the same question twice.
    What did you find when searching this forum ... ?!?

    Greetings,

    John
    The reply is currently minimized Show
Your Reply