Forums

Resolved
0 votes
This how to will install BackupPC (http://backuppc.sourceforge.net/info.html) on to your system, and configure a shortcut through the ClearOS webconfig for administration. Please note although the software is stable, there maybe some quirks I have introduced whilst incorporating it into the webconfig so USE AT YOUR OWN RISK, and as always with any backup software, make sure it can restore your data

BackupPC is a high-performance, enterprise-grade system for backing up Linux and WinXX PCs and laptops to a server's disk. BackupPC is highly configurable and easy to install and maintain.

Given the ever decreasing cost of disks and raid systems, it is now practical and cost effective to backup a large number of machines onto a server's local disk or network storage. This is what BackupPC does. For some sites, this might be the complete backup solution. For other sites, additional permanent archives could be created by periodically backing up the server to tape. A variety of Open Source systems are available for doing backup to tape.

BackupPC is written in Perl and extracts backup data via SMB using Samba, tar over ssh/rsh/nfs, or rsync. It is robust, reliable, well documented and freely available as Open Source on SourceForge.


http://backuppc.sourceforge.net/info.html#features" target="_blank">FEATURES

http://starlane.gotdns.org/files/BackupPCServerStatus.png
http://backuppc.sourceforge.net/info.html#screenShots" target="_blank">SCREENSHOTS

Step 1. INSTALL (assumes you have console access either locally, or via SSH)
Setup the community repo as instructed HERE
yum --enablerepo=timb install app-backuppc


2. SETUP/CONFIGURE
Login to the webconfig and browse to System > Backup > BackupPC, set your 'backuppc' user password
service backuppc start

Login to UI by clicking "GO" link in webconfig
Click Edit Config > Schedule from heft hand menu, and review the default global settings for FullKeepCnt, and IncrKeepCnt. These can be adjusted on a per host basis at a later date.

3. SETUP STORAGE
By default it will be configured to save backups to the local machine in /var/lib/BackupPC, which may not be convenient - particularly if you wish to save them onto a mounted drive or another partition say in /mnt/storage. Instructions below show how to generate the directory structure in the backup store to another location.
(Note I suggest you don't move the files from /var/lib/BackupPC so you can use them again if you wish to create another store.)

This assumes you have mounted a drive or folder in a location already. See linux howto's for carrying out this process.

a. New data store location
mkdir /path/to/newstore
chown backuppc /path/to/newstore
cp -ar /var/lib/BackupPC/* /path/to/newstore/
Click Edit config > TopDir -> /path/to/newstore
Click Save
Admin Options - Reload configuration

The last step is required to setup the cpool, pool, pc sub directories within the new storage location - these must be owned by the backuppc user.

b. Moving a data store (NOT REQUIRED FOR INSTALL)
mkdir /path/to/newstore
chown backuppc /path/to/newstore
mv /path/to/oldstore/* /path/to/newstore/
Click Edit config > TopDir -> /path/to/newstore
Click Save
Admin Options - Reload configuration

This is only required for moving a store to a new location - dont' move the original /var/lib/BackupPC files in case you need them again to generate another store.

4. CONFIGURE SIMPLE BACKUP OF LOCALHOST
Edit Hosts, Add > localhost, leave other fields empty. 
Click SAVE
Click STATUS, Select Localhost from drop down box, Edit Config -> Xfer
Change RsyncShareName (add as many entries as you wish, /etc /home /var etC)
Change RsyncClientCmd & RsyncClientRestoreCmd
(Both remove SSH bit to left and add sudo command so it looks like > "/usr/bin/sudo $rsyncPath $argList+")
Click SAVE
Select > Localhost Home, click 'Start Full Backup'
Watch the STATUS page and LOG for errors

The above changes to Rsync commands are required for localhost backups, as you don't need SSH to connect to the path. Note also that /usr/bin/sudo is required for backup of all local files which require root access. The backup process normally runs as user 'backuppc' and will backup all files it has read access too.

The same method above can also be used with 'tar' for localhost backups. Just change the ClientCmd and RestoreCmd fields.
For those addicted to the command line, you can actually configure each host at /etc/BackupPC/pc/<hostname>.pl

MORE...
You can configure BackupPC to backup all sorts of network locations it has access too, either via SSH, rsync, Samba etc!. So you can share a drive you want to be backed up - then configure another host to backup over the network. There is lots in the documentation so please read up on the details
http://backuppc.sourceforge.net/faq/BackupPC.html

5. REMOVING BACKUPS MANUALLY
Sometimes you may need to manually remove a backup, this is how you can do it by hand. Make a note of the host, and backup number first.
cd /path/to/store/pc/<hostname>
rm -rf <backupnumber>
vi backups ##remove each line relating to your removed backups

At midnight it does some 'house cleaning' and will cleanup the 'pool' and other associated files

6. REMOVAL
If you decide you've had enough! you can uninstall it
yum remove app-backuppc backuppc

Your backup store will be left in place, your config.pl will be renamed to config.pl.rpmsave

7. TODO
??

Thanks! enjoy - personally I think a great alternative to Bacula :D
In Backup
Friday, April 30 2010, 11:57 AM
Share this post:
Responses (218)
  • Accepted Answer

    Simon
    Simon
    Offline
    Saturday, June 22 2013, 06:13 PM - #Permalink
    Resolved
    0 votes
    Tim Burgess wrote:
    It appears a recent update to BackupPC trod on my system changes, please re-run the app install script (it shouldn't give any output)
    /usr/clearos/apps/backuppc/deploy/install


    This solved my problem, which was the same as above. Thanks!
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Wednesday, May 29 2013, 03:26 PM - #Permalink
    Resolved
    0 votes
    Hi

    Thank you. That helped - all is back to normal.

    Kind Regards
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, May 29 2013, 12:33 PM - #Permalink
    Resolved
    0 votes
    It appears a recent update to BackupPC trod on my system changes, please re-run the app install script (it shouldn't give any output)
    /usr/clearos/apps/backuppc/deploy/install
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Wednesday, May 29 2013, 09:03 AM - #Permalink
    Resolved
    1 votes
    Hi all,

    Today I have noticed that BackupPC web interface "died" for some reason.

    I have error message displayed every time I try to login:


    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    I haven't changed any server settings this month. It was working fine few days ago.

    yum.log states that app was updated

    May 25 02:32:36 Updated: BackupPC-3.2.1-10.el6.i686


    Hmm...any suggestions what I should do to fix this?

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Thursday, April 04 2013, 10:55 AM - #Permalink
    Resolved
    0 votes
    Hi

    I have done what you suggested Nick, and pings now go through - good tip, thank you.

    I have done it using webconfig. /etc/resolv has now been updated to


    ; generated by /sbin/dhclient-script
    search lan citi.lan
    nameserver 127.0.0.1
    nameserver 8.8.8.8
    nameserver 8.8.4.4



    BackupPC also seems to fine now. One more time thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 03 2013, 11:08 AM - #Permalink
    Resolved
    0 votes
    Not in hosts, in /etc/resolv.conf or through the webconfig (then it restarts dnsmasq for you).
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Wednesday, April 03 2013, 08:55 AM - #Permalink
    Resolved
    0 votes
    Hi

    In etc/hosts I already have 127.0.0.1 first,


    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
    #::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    192.168.2.1 system.citi.lan citi.lan time.lan


    Is there anything else I can check/do?

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 02 2013, 11:30 AM - #Permalink
    Resolved
    0 votes
    Have you tried putting 127.0.0.1 as your first DNS server IP?
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Tuesday, April 02 2013, 08:02 AM - #Permalink
    Resolved
    0 votes
    Hi

    It's hard to believe (at least for me) but the problem was with server DNS settings (in IP Settings). Last Wednesday, I changed it from Google DNS to OpenDNS (208.67.222.222, 208.67.220.220). Never thought that this will stop BackupPC to work,as in my opinion it has nothing to do with LAN connection.

    Another odd thing is that on Google DNS I'm not able to ping clients using client name(IP ping is fine) and BackupPC is working. When I'm on OpenDNS pings to clients using names go through, but BackupPC is "dead".
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 29 2013, 08:24 PM - #Permalink
    Resolved
    0 votes
    Hi Tomas, sounds odd...particularly if you can still ping your clients

    What method are you using to backup your clients? samba? rsync?

    Any recent package changes to your system? (/var/log/yum.log will help)

    Any clues in the client log (within BackupPC)? it should list the all the previous attempts to connect
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Thursday, March 28 2013, 04:53 PM - #Permalink
    Resolved
    0 votes
    Hi all,

    Something strange happened with my BackupPC app yesterday. I have had everything configured properly, nothing changed in configuration and now, suddenly all clients receive error every time BackupPC tries to connect:

    "Last status is state "idle" (backup failed) as of 3/28 16:36.
    Last error is "inet connect: Connection timed out".

    Localhost is fine. Only Windows PC clients are affected.

    We use ESET Endpoint Security on all clients and ESET server policy has not been changed, port is open for trusted LAN zone. Even when I manually disable all ESET protections (that includes firewall), BackupPC still produces this error.

    It worked fine for months on this configuration and now it stopped working.

    I have tried to restart the service, unmount USB storage drive, I even rebooted the server to check if it helps (!) - still :(

    Has anyone have any idea what might be wrong with it?

    [Edit]
    I forgot to add that pings go through to all clients.

    Thx
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 28 2013, 01:31 PM - #Permalink
    Resolved
    0 votes
    Hi Stefan - you are using ClearOS 5.x, this script is only available in ClearOS 6

    To fix in ClearOS 5, simply uninstall app-backuppc and reinstall...or run the following
    /bin/chown backuppc.webconfig /usr/share/BackupPC/sbin/BackupPC_Admin*
    /bin/chmod u+s /usr/share/BackupPC/sbin/BackupPC_Admin
    /bin/chown backuppc.webconfig /etc/BackupPC/config.pl
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 28 2013, 01:46 AM - #Permalink
    Resolved
    0 votes
    Tim Burgess wrote:
    As I posted above, try running
    /usr/clearos/apps/backuppc/deploy/install

    I'm can't find this dir running /usr/clearos/apps/backuppc/deploy/install??
    rpm -q BackupPC
    BackupPC-3.2.1-10.el5
    The reply is currently minimized Show
  • Accepted Answer

    Paul
    Paul
    Offline
    Wednesday, March 27 2013, 04:47 PM - #Permalink
    Resolved
    0 votes
    Running the script and then restarting the service fixed it for me.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 20 2013, 10:01 PM - #Permalink
    Resolved
    0 votes
    As I posted above, try running
    /usr/clearos/apps/backuppc/deploy/install
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 20 2013, 03:49 AM - #Permalink
    Resolved
    0 votes
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    I open my backuppc in https://ipclearos:81/backuppc/
    error internal server error
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 04 2013, 02:51 AM - #Permalink
    Resolved
    0 votes
    The update installed BackupPC-3.2.1-10.el6.x86_64 and that is also what showed when I checked using the rpm -q.

    Rerunning the script solved it!! Thank you for your help. Is there anything you'd recommend I check regarding what caused this to happen on my install and again on the restored image after update?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 04 2013, 12:29 AM - #Permalink
    Resolved
    0 votes
    Hmm what version of BackupPC do you have installed 'rpm -q BackupPC'? perhaps it was upgraded and changed the file permissions on the file

    You can rerun the app install script by running /usr/clearos/apps/backuppc/deploy/install
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, March 03 2013, 10:00 PM - #Permalink
    Resolved
    0 votes
    Hi Tim,

    BackupPC is running but I have restarted the service to be sure. The BackupPC log doesn't have anything out of the ordinary in it but the Webconfig/errorr_log has this :


    Thu Feb 28 11:42:35 2013] [error] [client 192.168.42.173] mod_mime_magic: can't read `/usr/share/BackupPC/sbin/BackupPC_Admin', referer: https://192.168.42.123:81/app/backuppc
    [Sun Mar 03 03:46:08 2013] [notice] SIGHUP received. Attempting to restart


    I have this install in private server mode with 1 nic and am accessing from the same subnet. Prior to whatever borked it was reachable in this manner.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, March 03 2013, 09:34 PM - #Permalink
    Resolved
    0 votes
    Hi Chris, everything seems to be OK this end - any clues in /var/log/webconfig/error_log or /var/log/BackupPC/LOG? is the BackupPC service running? 'service backuppc restart'

    Are you accessing the page from within your LAN? (i.e. from a private IP?) external IP's are blocked by default
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, March 03 2013, 08:50 PM - #Permalink
    Resolved
    0 votes
    I've noticed that a recent round (around feb 24th 2013) of ClearOS updates has broken the BackupPC Webconfig. When I attempt to access the BackupPC Webconfig you are prompted to log in as usual but then I get an "internal server error" page. To confirm the updates caused the issue I rolled back to before the updates confirmed all was working then ran updates and confirmed the Webconfig was then broken.

    Does anyone know what needs to be done to clear this up?

    Thanks!!
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 28 2013, 09:01 PM - #Permalink
    Resolved
    0 votes
    Hi Arnaud, yes glad you found it (for ClearOS 5.2)- it's also possible to create additional admin users, see /etc/BackupPC/config.pl

    For ClearOS 6.x the file is at /etc/BackupPC/apache.users

    $Conf{CgiAdminUsers} = 'backuppc';
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 27 2013, 01:34 PM - #Permalink
    Resolved
    0 votes
    Hello all,

    To be honest, I did not reat the 19 pages before posting (only 11) so I dont know if there's already an answer to this :

    I'm backuping 2 different host using backuppc and it's working great (thanks Tim). but of course, owner of the host #1 dont want that the owner of host#2 can access his backupps. For the while, they're both using the backuppc account.
    I've seen that I can attrib a user for each host but I dont know how and where can I add these users to be recognized by backuppc.
    If someone has an idea :)

    Thanks to all

    Ok, I've found a file in /var/webconfig/reports

    Do I simply have to make a htpasswd -c //var/webconfig/reports/backuppc.user <my_new_account> ?

    Thanks

    :laugh: ok, that was the file to modify. I could create many users and give access to each for 1 host :)
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 26 2013, 09:36 AM - #Permalink
    Resolved
    0 votes
    If you have installed via the command line (which I'm guessing from the information in your post) then run

    service webconfig restart 
    service backuppc start
    ##access https://clearosip:81/backuppc

    Or use the web interface which has a convenient link to the BackupPC interface
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 26 2013, 03:48 AM - #Permalink
    Resolved
    0 votes
    I've installed the app backup but no display on my browser

    https:// [ipserver]: 81/BackupPC /


    Why this?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 26 2013, 03:06 AM - #Permalink
    Resolved
    0 votes
    How do I add a repo to it?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, February 24 2013, 11:44 PM - #Permalink
    Resolved
    0 votes
    Hmm...what repo's do you have enabled?

    You need RPMs perl-Net-FTP-AutoReconnect, and perl-Net-FTP-RetrHandle. Both of which are available in the clearos-contribs repo...which should be enabled if you are trying to install BackupPC via the Marketplace
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 22 2013, 07:31 AM - #Permalink
    Resolved
    0 votes
    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    Package BackupPC needs perl(Net::FTP::AutoReconnect), this is not available.
    Package BackupPC needs perl(Net::FTP::RetrHandle), this is not available.


    Why this error?
    i install appbackup
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, November 20 2012, 04:34 PM - #Permalink
    Resolved
    0 votes
    I actually use autofs to mount shares on from my desktops as needed. It's actually not all that difficult to set up. Once that's done, you can use rsync or tar to backup as though it's a local folder by removing the $host option from the config for each host.
    The reply is currently minimized Show
  • Accepted Answer

    Jeff
    Jeff
    Offline
    Tuesday, October 16 2012, 08:13 PM - #Permalink
    Resolved
    0 votes
    Thanks Tim! I added my local subnet and it is working now. Now to figure out how to make this thing see a windows machine!?!?!
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, October 16 2012, 04:25 PM - #Permalink
    Resolved
    0 votes
    Hi Jeff, default is only local private subnets as defined in /usr/clearos/sandbox/etc/httpd/conf.d/BackupPC.conf

    If you're sure it is OK, then try restarting the webconfig service
    service webconfig restart
    The reply is currently minimized Show
  • Accepted Answer

    Jeff
    Jeff
    Offline
    Tuesday, October 16 2012, 03:53 PM - #Permalink
    Resolved
    0 votes
    Tim,

    Just installed V6 on a virtual machine to test and trying to get the BackupPC working. I too am getting the "You don't have permission to access /backuppc on this server". I am accessing webconfig from the same subnet as the virtual server any ideas on why this is happening or what I can check to get it working? thanks!
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 14 2012, 05:25 PM - #Permalink
    Resolved
    0 votes
    Thanks, Tim. While I was accessing the webconfig on my LAN, my server is standalone and uses a public IP address from my ISP because I use the web server. So, to access my webconfig on my LAN, I use the domain name or the IP address. Perhaps that's why.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 14 2012, 11:27 AM - #Permalink
    Resolved
    0 votes
    Thanks for the feedback - i'll investigate why it occured.

    Glad its working for you now :)
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Friday, September 14 2012, 10:59 AM - #Permalink
    Resolved
    0 votes
    Hi

    The problem was that there was not space between
    clearconsole ALL=NOPASSWD: CLEARCONSOLE
    and
    backuppc ALL=NOPASSWD: /bin/gtar, /usr/bin/rsync
    so it looked like that:

    clearconsole ALL=NOPASSWD: CLEARCONSOLEbackuppc ALL=NOPASSWD: /bin/gtar, /usr/bin/rsync

    Something must have crashed during installation.
    Webconfig is back working now. BackupPC app is listed as not installed in Marketplace.

    I had to remove old backuppc installation using "yum remove backuppc" and install an app to make it work. After that replace config files and it seems alright.

    Thank you
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 14 2012, 08:54 AM - #Permalink
    Resolved
    0 votes
    It just adds the following line if not present to enable BackupPC user to backup the localhost
    backuppc ALL=NOPASSWD: /bin/gtar, /usr/bin/rsync


    My file has the following lines from 121 onwards...what does yours look like?
    webconfig ALL=NOPASSWD: CC
    Cmnd_Alias CLEARCONSOLE = /usr/bin/iptraf, /usr/sbin/console_start, /usr/sbin/tc-yum, /bin/rpm, /sbin/halt, /sbin/reboot, /usr/sbin/app-passwd
    clearconsole ALL=NOPASSWD: CLEARCONSOLE
    backuppc ALL=NOPASSWD: /bin/gtar, /usr/bin/rsync
    The reply is currently minimized Show
  • Accepted Answer

    tomas
    tomas
    Offline
    Friday, September 14 2012, 08:27 AM - #Permalink
    Resolved
    0 votes
    Hi Tim,


    Strange, BackupPC doesn't interfere with the logins only the sudoers file - the change in user/permissions may have stopped the original install working ...a few questions:- can you login as root via the console (alt+F2) or remote SSH?
    does the command 'id backuppc' or 'id' root' produce anything useful? or perhaps clues /var/log/messages or /var/log/secure

    id backuppc

    uid=301(backuppc) gid=301(backuppc) groups=301(backuppc)

    id root

    uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10 (wheel)

    SSH (command line) is working, can login as root no problems.
    Sodoers file was modified when I installed the app. May I ask what changes are made in sudoers during installation?
    What are the defaults?

    var/log/secure gives

    Sep 14 09:06:39 system sudo: root : parse error in /etc/sudoers near line 121 ; TTY=console ; PWD=/ ; COMMAND=/bin/ls
    Sep 14 09:06:39 system sudo: root : no valid sudoers sources found, quitting ; TTY=console ; PWD=/ ; COMMAND=/bin/ls
    Sep 14 09:08:35 system sudo: webconfig : parse error in /etc/sudoers near line 121 ; TTY=unknown ; PWD=/usr/clearos/framework/htdocs/app ; COMMAND=/usr/sbin/app-passwd
    Sep 14 09:08:35 system sudo: webconfig : no valid sudoers sources found, quitting ; TTY=unknown ; PWD=/usr/clearos/framework/htdocs/app ; COMMAND=/usr/sbin/app-passwd
    Sep 14 09:08:57 system sudo: webconfig : parse error in /etc/sudoers near line 121 ; TTY=unknown ; PWD=/usr/clearos/framework/htdocs/app ; COMMAND=/usr/sbin/app-passwd
    Sep 14 09:08:57 system sudo: webconfig : no valid sudoers sources found, quitting ; TTY=unknown ; PWD=/usr/clearos/framework/htdocs/app ; COMMAND=/usr/sbin/app-passwd

    line 121
    [code]Cmnd_Alias CLEARCONSOLE = /usr/bin/iptraf, /usr/sbin/console_start, /usr/sbin/tc-yum, /bin/rpm, /sbin/halt, /sbin/reboot, /usr/sbin/app-passwd
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 14 2012, 05:52 AM - #Permalink
    Resolved
    0 votes
    Hi Dirk,are you connecting from LAN? As a security measure BackupPC is configured to allow access from private subnets only

    If you are try restarting the webconfig service manually
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 14 2012, 02:35 AM - #Permalink
    Resolved
    0 votes
    So, I'm logged in as root after installing backuppc from the marketplace, and I've entered a password for the backuppc under the system menu, but then when I click on "Go To BackupPC Management Tool I get a webpage displaying the infamous "403 Forbidden You don't have permission to access /backuppc on this server" error. What's the deal-e-o?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 13 2012, 09:50 PM - #Permalink
    Resolved
    0 votes
    Strange, BackupPC doesn't interfere with the logins only the sudoers file - the change in user/permissions may have stopped the original install working ...a few questions:-
    can you login as root via the console (alt+F2) or remote SSH?
    does the command 'id backuppc' or 'id' root' produce anything useful?
    or perhaps clues /var/log/messages or /var/log/secure
    The reply is currently minimized Show
Your Reply