Community Forum

Resolved
0 votes
I am moving to 7.2 from 6.8 community (new drive new install) and having a problem with the three network cards. I use one (on motherboard) for my PPOE (DSL) connection and the other two for a private network and lastly a more public one for my wireless access.
During the install the scripts do not find the on-board Ethernet and so I am unable to connect to the internet via DSL.
How do I get the third network card recognized - perhaps during install - so I can set up my DSL?
Many thanks.
Thursday, February 16 2017, 10:22 PM
Share this post:
Responses (14)
  • Accepted Answer

    Monday, February 20 2017, 12:24 PM - #Permalink
    Resolved
    0 votes
    Glad you've got it going. Really it would have been better for the installer to point you your LAN IP. I think your set up made things difficult by directly configuring the WAN as PPPoE as the underlying interface does get a private IP.

    As you see, by default the Webconfig is open to the world. Can I suggest that, once you have LAN access to the webconfig, you remove the incoming webconfig firewall rule (the server is open to everything from the LAN)? Similarly, if there is an incoming ssh rule, remove that as well.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 20 2017, 02:01 AM - #Permalink
    Resolved
    0 votes
    So it looks like the install system was giving me the wrong number or I was not thinking straight. I had a friend of mine connect from BC tonight directly to my static IP ( I don't think I mentioned that I had one). The graphical install interface was apparently not large enough to show me the "next button" after I had updated the network information. Also the IP that was showing (on the graphical setup page) for me to log into was 192.168.1.1:81 ---- BUT this was the first of the two ethernets that I had set up of eth8 and eth9. Wha tthe install page should have showed me - or I should have know - was that I should have been logging into xxx.xxx.xxx.xxx:81 where the x's are my static IP numbers from my ISP.

    ClearOS 7.2 Community is setting up as we speak - many thanks to all the efforts you have put in to educate me...
    Chris.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 10:26 PM - #Permalink
    Resolved
    0 votes
    Can you do an "ifconfig" to see if you have an IP address?
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 10:16 PM - #Permalink
    Resolved
    0 votes
    So I changed the network mode from Gateway to Standalone - added a PC (ChromeBox via KVM) with a similar IP (192.168.1.2) and would not connect to the ClearOs system.
    Rebooted and went back to the first graphical screen with the network configuration on it and was able to use Ctrl-Alt F2 - I recall - to get into a terminal session with the prompt - not sure what I should do now?

    When I do an ls, in the shell screen, there are no directories so still not fully configured - running out of options perhaps try ubuntu?
    .
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 18 2017, 09:09 AM - #Permalink
    Resolved
    0 votes
    If you know your ClearOS LAN IP, connect a PC to it, but give the PC a fixed IP on the same subnet, so perhaps either 192.168.0.10 or 192.168.1.10 (I can't remember which is the default subnet). That should allow you to connect to the Webconfig and stop the wizard.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 11:35 PM - #Permalink
    Resolved
    0 votes
    So today I reinstalled 7.2 and still have no Internet - or so I thought - what is happening is because the install wizard does not complete all the way through none of the applications are being installed. I know I have an internet connection because I did a speed test in the PPOE configuration.

    What I don't have is the DHCP module installed to distribute IP's to both my LAN connections. (dah!)
    At the end of the install wizard it correctly shows me my IP address with the :81 to log in and set up applications. When I highlight the IP address and right mouse click I get a number of options like open in a new window. When I choose this option the screen disappears and goes to a complete white screen and thats it.

    Any suggestions how I can get the wizard to complete so I can have all the applications (DHCP for sure) installed under 7.2?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 07:23 PM - #Permalink
    Resolved
    0 votes
    The first run wizard in the webconfig can be stopped by pointing your browser to https://your_clearos_lan_ip:81/app/base/wizard/stop.

    If it is the installer which is stick then I don't know. I know I had real problems accessing the console GUI when one of my NIC's was disconnected.

    Which cards do you have connected/enabled when you are doing the 7.2 install? If necessary, set the system up in standalone mode if you have only one NIC enabled. It can be flopped to gateway mode later.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 06:14 PM - #Permalink
    Resolved
    0 votes
    Appreciate the help with this and this is what I have today (Friday 17th Feb). I purchased an Intel PCIe Gigabit card and booted to the install of 7.2 - it found it and I added the information for the PPOE connection.

    The 7.2 install wizard does not want to finish and it will not connect to the Internet - do I have to restart the install with the new card in place to be able to connect? This means no DNS or graphical interface through the use of :81 even though the DNS is populated automatically once the DSL connects.

    I go back to my 6.8 install - disabled the Nvidia in the motherboard and re-installed the Intel PCIe card - all works fine including the internet connection so I know all pieces are functioning.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 02:07 PM - #Permalink
    Resolved
    0 votes
    Tony Ellis wrote:
    A r8168 kmod driver rpm is available to download and install which will disable the r8169 driver from being used with the r8168 NIC. Using the r8169 driver with a r8168 based card causes many problems...
    Hi Tony,
    Back in the days when Tim was compiling the r8168 driver I think he put into the post-install script something to blacklist the r8169 driver. I've never bothered to learn how to do this and I'm pretty sure the vanilla kmod-r8168 driver source does not do this either. What I did notice a while back is that the kmod-r8169 driver has the r8168 PCI ID removed from its compatibility list. This is why I recommend to people installing the kmod-r8168 driver to also install the kmod-r8169 driver as it stops the r8169 driver ever loading for an r8168 NIC.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 03:35 AM - #Permalink
    Resolved
    0 votes
    I use several Intel PCIe NICs with ClearOS 6.8 - no problem. Don't have one in a 7.x system yet, but wouldn't expect a problem.

    Nvidia - see https://lists.centos.org/pipermail/centos/2014-July/144190.html and this thread
    https://www.clearos.com/clearfoundation/social/community/kmod-forcedeth-in-clearos-7-2
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 03:07 AM - #Permalink
    Resolved
    0 votes
    I believe the on-board NIC driver is Nvidia as I have looked through the user guide - (I am off site so cannot run the command you recommend till tomorrow) - would I be better going with an Intel PCIe card as they seem to have good support in the Linux world?
    I appreciate you taking the time for this conversation too.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 02:37 AM - #Permalink
    Resolved
    0 votes
    Sure you can add a new NIC - however, be aware many popular PCIe NICs are based on the RTL8111/RTL8168 chipset and are not natively supported by ClearOS.
    A r8168 kmod driver rpm is available to download and install which will disable the r8169 driver from being used with the r8168 NIC. Using the r8169 driver with a r8168 based card causes many problems...
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 02:07 AM - #Permalink
    Resolved
    0 votes
    I will run the command you have offered and read the materials you recommended - I have a PCIe slot available in the computer and wonder if I disable the onboard ethernet and use a new PCIe Gigabit card instead would that also be an option as that way I would have access to much newer (and supported) drivers for version 7.2?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 17 2017, 01:40 AM - #Permalink
    Resolved
    0 votes
    See
    https://linux.web.cern.ch/linux/rhel/releasenotes/RELEASE-NOTES-7.0-x86_64/#removed-packages
    and scroll down to the section entitled "Networking Drivers" within Section 4.4. Discontinued Kernel Drivers, Modules and Features. Redhat cleaned out something like 80+ drivers for old NICs for version 7.0 that are no longer in production or not used in modern enterprise servers...

    Some drivers have been compiled from elrepo ( https://elrepo.org/tiki/Download ) by ClearOS users - notably Nick and are available to download

    Can you show the output of this command please, and we can see what NIC you have and hence the required driver......

    # lspci -vk | grep Eth -A 4
    Like
    1
    The reply is currently minimized Show
Your Reply