Forums

otravier
otravier
Offline
Resolved
0 votes
Happy new year everyone!

This first morning of the new year, I was greeted by the following message in my mailbox from cron

/usr/sbin/timesync

containing a single line

PHP Warning: The license has expired (license file: /var/clearos/clearcenter/license.zl) in Unknown on line 0

If I go ahead and just "type in" the above command, the same message appears at prompt.

Is this anything to worry about?

I have the following version: ClearOS Community release 6.5.0 (Final)
Thursday, January 01 2015, 11:17 AM
Share this post:
Responses (14)
  • Accepted Answer

    fikse
    fikse
    Offline
    Tuesday, January 06 2015, 06:20 AM - #Permalink
    Resolved
    0 votes
    Happy new year to all :)

    Thanks Peter and Ben.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 06 2015, 05:07 AM - #Permalink
    Resolved
    0 votes
    Happy New Year all!

    The license expiration itself is not a fatal problem, it's just a warning. However, part of the Dynamic DNS update script reads the output from a webconfig-php command and the license warning message leads a parse error.

    The bug fix was just pushed through the build system and should be hitting the repos shortly. Essentially, it's just a packaged version of Ben's workaround -- disabling the Zend loader. I'll push that out to clearos-updates after a round of sanity checks, and then the verified updates (Professional) not too long after that.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, January 04 2015, 03:53 PM - #Permalink
    Resolved
    0 votes
    Hi guys,

    This has nothing to do with the EOL of ClearOS Community 6 and everything to do with ZendGuard which was discontinued long ago, for a few apps where code obfuscation was required.

    Running:


    /usr/clearos/sandbox/usr/bin/php -m


    Will tell if you have the extension loaded.

    I've tried this on my box:

    cd /usr/clearos/sandbox/etc/php.d
    mv zendguardloader.ini zendguardloader.ini.bak
    service webconfig restart


    Re-running the first command should show that no Zend Modules are loaded.

    I think this is ultimately the solution to the problem, and I don't see any ill-effects in Webconfig....however, I defer to Peter B. for the last word since I wasn't involved in the ZendGuard license engine. I'll point him to this post...

    B.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 02 2015, 05:21 PM - #Permalink
    Resolved
    0 votes
    I just did a complete clean reinstall of 6.5.0 Final from latest ISO 3 days ago with no modules or packages outside normal release stream and have the same license expiry issue (resolved via manual edit). Oops.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 02 2015, 05:08 PM - #Permalink
    Resolved
    0 votes
    I got this error to when an initial dnsupdate force failed until I changed the date. I assume it's just that the date is incorrect The EOL for ClearOS Community is 9/1/17.

    But even so, what exactly is expiring? I know after EOL that updates will stop, but what about DDNS? My initial update did fail...
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 02 2015, 06:39 AM - #Permalink
    Resolved
    0 votes
    Same here... poor management by Clear to let something like this expire (though not a show stopper) without issuing an update prior to expiry :-)

    Happy New Year everybody
    The reply is currently minimized Show
  • Accepted Answer

    otravier
    otravier
    Offline
    Thursday, January 01 2015, 06:54 PM - #Permalink
    Resolved
    0 votes
    Hey!

    I did the same mod, and there goes the error message for /usr/sbin/timesync...

    So simple. Thank you for the solution! That seems to do it.

    Happy new year! :laugh:
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 01 2015, 06:51 PM - #Permalink
    Resolved
    0 votes
    Happy New Year

    had the same issue.

    modified the expiry date to expire in 2017 in the license.zl file and error message stopped since that modification.

    hth & br, Yvo
    The reply is currently minimized Show
  • Accepted Answer

    otravier
    otravier
    Offline
    Thursday, January 01 2015, 06:02 PM - #Permalink
    Resolved
    0 votes
    Well misery likes company I see... hope someone has the Sorcerer's Stone regarding this...
    The reply is currently minimized Show
  • Accepted Answer

    Wasko Mass
    Wasko Mass
    Offline
    Thursday, January 01 2015, 05:28 PM - #Permalink
    Resolved
    0 votes
    same problem - every 5 Minutes I get this message by cron
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 01 2015, 05:28 PM - #Permalink
    Resolved
    0 votes
    Experience the same on my server.

    If I look into the file:

    Product-Name = ClearCenter_Marketplace
    Registered-To = ClearCenter Marketplace
    Expires = 01-Jan-2015
    Hardware-Locked = No
    Produced-By = ClearCenter
    Verification-Code = xxxxxxxxxxxxx


    Expire date is set to 01-Jan-2015

    Br,
    Wiljon
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 01 2015, 03:22 PM - #Permalink
    Resolved
    0 votes
    Hi, same message here too. I did login to check that my subscription hadnt expired, but it still has some time left. :-)
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, January 01 2015, 02:33 PM - #Permalink
    Resolved
    0 votes
    yup - me too .. and a similar one from spamassasin
    The reply is currently minimized Show
  • Accepted Answer

    P Jones
    P Jones
    Offline
    Thursday, January 01 2015, 02:06 PM - #Permalink
    Resolved
    0 votes
    I'm seeing this too from multiple ClearOS 6.5 Community servers.
    The reply is currently minimized Show
Your Reply