Forums

Resolved
0 votes
Hello,
i have a problem with samba shares.
My lan have 5 macos desktop.
I use a samba share, all work fine. But if i pick up a file from a desktop the file have 770 rights.
This create me some problems.

If i look the files on the server with a ssh login i see thats the file have 775

I used the flexshare and samba default settings with a read/write share.

What can i do ?

Thanks!
Thursday, December 13 2018, 09:18 AM
Share this post:
Responses (6)
  • Accepted Answer

    Friday, December 14 2018, 10:25 PM - #Permalink
    Resolved
    0 votes
    I'm not a Mac user. It may be something to do with with the MacOS. I'll try to ask Dave if I remember as he is a Mac user.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 14 2018, 08:16 AM - #Permalink
    Resolved
    0 votes
    I try third part access but nothing change.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 14 2018, 08:15 AM - #Permalink
    Resolved
    0 votes
    Why do you need 755?
    I don't need it, i configured clearos samba+flexshare with default paramaters and actually in the server files are stored with 755.

    The problem occurs when I pick up a file from the server and save it in the client ( via the smb protocol ). In this case, the files in the client become 640.
    I need them to be at least 644.

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 13 2018, 03:12 PM - #Permalink
    Resolved
    0 votes
    Did you try what I posted?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 13 2018, 02:53 PM - #Permalink
    Resolved
    0 votes
    Thanks for your answer.

    I dont need 755 files, this happen with the default settings.
    I need 644 when i get a file from server to my desktop. The important element is 4 for everyone, 0 create me some problems.

    I do not understand if the problem is related to the server or to the samba client of the macos.

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 13 2018, 10:00 AM - #Permalink
    Resolved
    0 votes
    Why do you need 755? To get that I think you'd need to enable Third Party Access to the share, but I don't know if that will give you execute permissions. Try it.
    The reply is currently minimized Show
Your Reply