Community Forum

stassen
stassen
Offline
Resolved
0 votes
Need some help with the following situation:

A lot of data (1TB) needs to be backupped on NTFS disk and should readable by a windows machine.

A simple NTFS mount does not work in CC5. There is NTFS support available in Linux, but is it in CC5. (ntfs-3g)

If so, how should i mount /sdf1 to /mnt/guest ?


Below my failures ;-)

[root@clarkconnect ~]# mount -t NTFS /dev/sdf1 /mnt/guest
mount: unknown filesystem type 'NTFS'

Or

[root@clarkconnect ~]# mount /dev/sdf1 /mnt/guest -t ntfs -r -o unmask=0222
mount: unknown filesystem type 'ntfs'
Thursday, November 05 2009, 12:58 PM
Share this post:
Responses (17)
  • Accepted Answer

    Monday, September 23 2013, 12:09 PM - #Permalink
    Resolved
    0 votes
    It's in the clearos-core repo (which didn't exist in ClearOS 5.2 when the thread started)
    yum --enablerepo=clearos-core install autofs


    ntfs-3g exists in clearos-extras
    yum --enablerepo=clearos-extras install ntfs-3g


    This comes in handy when you don't know where to look, or what the pakcage might be called
    yum --enablerepo=* search packagetitle
    yum --enablerepo=* list packagename
    The reply is currently minimized Show
  • Accepted Answer

    Monday, September 23 2013, 11:57 AM - #Permalink
    Resolved
    0 votes
    Nick

    Thanks for the reply. You are right, all is now working.

    Thanks again.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 06:40 PM - #Permalink
    Resolved
    0 votes
    Digging further, udev replaced dev. Also autofs is part of the current kernel (do "locate autofs") so you probably do not need to install it.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 06:02 PM - #Permalink
    Resolved
    0 votes
    Perhaps I have confused things by putting this at the end of a discussion on ntfs. My reference is a post on page 1 which refers to "but i have an external USB and could not get it to auto mount. This is what i did to get a 320GB external USB drive to auto mount...."

    Should I open a new query about automount? What I have read in this forum is that to get autofs you have to get rpmforge, which is consistent with what I did for ClearOS 6.3, except this time I get timed out.

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 05:23 PM - #Permalink
    Resolved
    0 votes
    Yes, but as far as I can see packages.sw.be is down. Looking further up the thread the only reason for installing that repo seemed to be to get ntfs-3g. If that is the case the clearos-epel version is far more recent. I can't see any mention of app-autofs in the thread.

    [edit]
    app-autofs is in a linked thread on an old link. I think, but I'm not sure, that autofs was replaced by udev somewhere along the line - perhaps when ClearOS went to version 6.
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 05:15 PM - #Permalink
    Resolved
    0 votes
    Thanks for the answer.

    As I understand I'm seeking to install the precursor to installing ntfs-3g. I.e. it is to get autofs so that I can auto-mount any USB, after which I can read ntfs-3g USBs.

    As I understand it wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm provides access to non-ClearOS-origin ClearOS rpms, in this case app-autofs.

    Does this make sense?

    What I am trying to do is get USBs to automount. Having them plugged in at boot wrecksmy /dev/sdx device allocations by giving the USB /dev/sda and incorrectly incrementing my two storage HDD allocations to /dev/sdc and /dev/sdd and messing-up my mount points. I know that I can get around this by specifying a UUID for the USB but this only works when I know the UUID which requires me to have new USBs plugged in at boot.........

    It is a sub-optimal solution but last time I resolved this with ClearOS 6.3 with the installs given above and I'm just trying to get back to that situation.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 03:03 PM - #Permalink
    Resolved
    0 votes
    Presumably this is for the ntfs-3g rpm? If so there is a later version on clearos-epel. Just use yum with the --enablerepo=clearos-epel switch.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 21 2013, 01:01 PM - #Permalink
    Resolved
    0 votes
    I am trying to get USB auto-mount (autofs) on a new installation of ClearOS 6.4. I got this to work on ClearOS 6.3 by starting with this sequence:
    yum install wget
    wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm" target="_blank">http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm
    rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt
    rpm –i rpmforge-release-0.5.2-2.el6.rf.i686.rpm
    rpm -i rpmforge-release-0.5.2-2.el6.rf.*.rpm

    However, on ClearOS 6.4, this times out:
    (try:20)  http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm" target="_blank">http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm
    Connecting to packages.sw.be|78.46.17.228|:80... failed: Connection timed out.
    Giving up.

    Digging around I saw a suggestion on checking wget timeouts. I have no /home/user/.wgetrc file so looking in /etc/wgetrc everything is hashed out and so I have wget's default timings.

    To check the source site, Firefox timed out when I put http://packages.sw.be/rpmforge-release as the URL.

    Any suggestions on how to overcome this problem (or, ultimately, to get autofs working)?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, April 15 2011, 12:40 PM - #Permalink
    Resolved
    0 votes
    Hello all,

    I'm building a pilot for a company who has 2 usb harddrives to backup their data. So, I installed the automount system on my cOS because they're changing their usb HD every week. The problem i have is that i'd like that the mount point is always the same because I'm using the backuppc system (thanks to Tim Burgess) but I can't for the while (i'm a beginner).
    After having tried several configuration, i saw I cannot use the fstab because the device is not always the same (i checked usind fdisk -l).
    So, is there a way with the automount system to configure that the mount point is always at the same place ? I tried to link it with a flexshare but without success for the while ...

    Thanks very much for your help

    Arnaud
    The reply is currently minimized Show
  • Accepted Answer

    Leon
    Leon
    Offline
    Monday, March 07 2011, 09:52 AM - #Permalink
    Resolved
    0 votes
    Hi grubs

    Thank you for the update and identifying the SOE.
    As 5 seconds worked for me, i did not tinker with it ant longer as my USB is connected, transfer a lot of files at once and then disconnect.
    I shall see tonight, GMT+2, what happens when i change the time-out value. I shall also do some reading before i change it to see what is the best for my set-up.

    Leon
    The reply is currently minimized Show
  • Accepted Answer

    grubs
    grubs
    Offline
    Monday, March 07 2011, 02:05 AM - #Permalink
    Resolved
    0 votes
    That worked for me Leon but only after I sorted out two traps for the unwary.

    1) Step 4 of your instructions should read:

    yum --nogpgcheck localinstall fuse-ntfs-3g-2010.10.2-1.el5.rf.i386.rpm


    2) The instructions given at http://www.ulverston.myzen.co.uk/mini-itx/pages/automount.htm - "Auto-Mounting CD-ROM and USB" have the default unmount timout set at only 5 seconds

    /media/Drives /etc/auto.drives --timeout=5 --ghost


    This made my system almost unworkable as there is a reasonably long delay associated with each mount and unmount operation and with ongoing access the drive access was painfully slow. For my use - I increased the timeout to 5 minutes as my USB drive spends most of its time plugged in as a backup drive, and when I do remove it it tends to be for hours-days.

    /media/Drives /etc/auto.drives --timeout=300 --ghost

    To explain this further for people... the automount utility does not just automount the USB drive when you insert it and then unmount it when you pull it out (this is where I got confused). Automount mounts the drive whenever you *access* the drive to read/write a file...it then unmounts itself after the timout set in the /etc/auto.mount expires. When you next access the file the drive will be mounted again. 5 seconds is too short IMO (the automount docs say as much also) as this means the drive is going to be mounted and unmount on nearly every operation.
    The reply is currently minimized Show
  • Accepted Answer

    Leon
    Leon
    Offline
    Saturday, February 26 2011, 10:52 PM - #Permalink
    Resolved
    0 votes
    Hi All

    The info from Tim above worked perfect, but i have an external USB and could not get it to auto mount.
    This is what i did to get a 320GB external USB drive to auto mount.
    1. Follow the instructions as per http://www.ulverston.myzen.co.uk/mini-itx/pages/automount.htm - "Auto-Mounting CD-ROM and USB"
    2. Before you - "service autofs restart"
    3. Use http://packages.sw.be/fuse-ntfs-3g/fuse-ntfs-3g-2010.10.2-1.el5.rf.i386.rpm instead of the one from Tim above
    4. yum --nogpgcheck localinstall ntfs-3g-200944-el5i686.rpm
    5. service autofs restart
    6. Done...

    No need to manually mount the drive and it auto disconnect after a period of inactivity, see step 1 for info.

    Hope this helps

    Leon
    The reply is currently minimized Show
  • Accepted Answer

    stassen
    stassen
    Offline
    Saturday, November 07 2009, 06:07 AM - #Permalink
    Resolved
    0 votes
    Final conclusion & result -> copied succesfully 0.6TB of data within 8 hrs on this NTFS drive. Tests on XP machine is 100% succesful
    The reply is currently minimized Show
  • Accepted Answer

    stassen
    stassen
    Offline
    Friday, November 06 2009, 03:19 PM - #Permalink
    Resolved
    0 votes
    Yep..

    The last post is doing the job..... ;-) Mounted with limitations, but working.. Let you know the file outcome

    Thanks in advance
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, November 05 2009, 10:41 PM - #Permalink
    Resolved
    0 votes
    Sorry my bad, I had forgotten how to install it
    http://forums.clarkconnect.com/showflat.php?Cat=0&Board=backup&Number=120703&Searchpage=1&Main=120700&Words=%2Bntfs-3g&topic=&Search=true#Post120703
    cd /var/tmp
    wget http://marush.com/wp-content/uploads/2009/04/ntfs-3g-200944-el5i686.rpm
    yum --nogpgcheck localinstall ntfs-3g-200944-el5i686.rpm
    mount -t ntfs-3g /dev/sdf1 /mnt/guest


    EDIT: Amended to use the latest ntfs-3g driver
    The reply is currently minimized Show
  • Accepted Answer

    stassen
    stassen
    Offline
    Thursday, November 05 2009, 05:57 PM - #Permalink
    Resolved
    0 votes
    [root@clarkconnect ~]# yum install ntfs-3g
    Loading "protect-packages" plugin
    base-kernels | 951 B 00:00
    base-updates | 951 B 00:00
    centos-updates | 951 B 00:00
    centos-os | 951 B 00:00
    base-supplements | 951 B 00:00
    base-os | 1.1 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    No package ntfs-3g available.
    Nothing to do
    [root@clarkconnect ~]# mount /dev/sdf1 /mnt/guest
    mount: unknown filesystem type 'ntfs'

    50% closer to a solution..... ;-)

    Reboot system



    Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 121601 976760001 7 HPFS/NTFS


    [root@clarkconnect ~]# mount /dev/sdc1 /mnt/guest

    mount: unknown filesystem type 'ntfs'


    Did I miss something ???
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, November 05 2009, 02:20 PM - #Permalink
    Resolved
    0 votes
    yum install ntfs-3g
    mkdir /mnt/guest #or whatever folder you wish
    mount /dev/sdf1 /mnt/guest


    Add to /etc/fstab to make it permanent:-
    /dev/sdf1 /mnt/guest ntfs-3g defaults 0 0
    The reply is currently minimized Show
Your Reply