Forums

Resolved
0 votes
Hi,

you don a great job with Clearos.
But when are you going to upgrade to mysql 5.1 and php 5.3.x?

Thanks for the answers
Thursday, December 10 2009, 02:48 PM
Share this post:
Responses (6)
  • Accepted Answer

    Saturday, March 13 2010, 12:08 PM - #Permalink
    Resolved
    0 votes
    Tim Burgess wrote:
    Eeeek not for production systems! the clue is in the 'beta' :P anyway, you also need to move over the new config, as the configuration has changed *alot* between 2.6 and 3.1

    hehehehe, i know is not for production system, but dun have more CPU for test, so i do that on production server :laugh:
    mv /etc/squid/squid.conf /etc/squid/squid-2.6.conf
    mv /etc/squid/squid.conf.rpmnew /etc/squid/squid.conf
    service squid restart

    this code for rename the squid configuration
    I would highly recommend you read up on squid and it's configuration if your planning on testing this. It's provided on an 'as is' basis for testing

    more to learn the basic :(
    but im glad be the tester

    more knowledge that I get :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 12 2010, 08:24 PM - #Permalink
    Resolved
    0 votes
    Eeeek not for production systems! the clue is in the 'beta' :P anyway, you also need to move over the new config, as the configuration has changed *alot* between 2.6 and 3.1
    mv /etc/squid/squid.conf /etc/squid/squid-2.6.conf
    mv /etc/squid/squid.conf.rpmnew /etc/squid/squid.conf
    service squid restart

    I would highly recommend you read up on squid and it's configuration if your planning on testing this. It's provided on an 'as is' basis for testing
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 12 2010, 05:55 PM - #Permalink
    Resolved
    0 votes
    Tim Burgess wrote:
    ClearOS uses an updated version of OpenLDAP 2.4 compared to RHEL/CentOS 5.x so you will need to recompile your own from the .src.rpm if you want to upgrade it. Can I ask why you want to?


    Accelerator mode support cleaned up to behave more consistent when combining multiple accelerator mode options

    I've also been experimenting with the Squid 3.1 beta if you fancy trying it out. But note still beta so not without it's problems!
    http://download.clearfoundation.com/community/timb80/squid-3.1BETA/


    I've tried it
    and results : service squid start FAILED :(

    sorry i can't show the log, coz i try that on running server with 50++ online client
    so I must be quick to re-install squid2.6

    PHP5.2.9 can be found here
    http://download.clearfoundation.com/community/timb80/php-5.2.9/
    and a testing version of 5.2.10 is here also
    http://download.clearfoundation.com/community/timb80/php-5.2.10/


    PHP5.2.9 running smothly, but PHP5.2.10 i don't have try it :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 12 2010, 10:27 AM - #Permalink
    Resolved
    0 votes
    ClearOS uses an updated version of OpenLDAP 2.4 compared to RHEL/CentOS 5.x so you will need to recompile your own from the .src.rpm if you want to upgrade it. Can I ask why you want to?

    I've also been experimenting with the Squid 3.1 beta if you fancy trying it out. But note still beta so not without it's problems!
    http://download.clearfoundation.com/community/timb80/squid-3.1BETA/

    PHP5.2.9 can be found here
    http://download.clearfoundation.com/community/timb80/php-5.2.9/
    and a testing version of 5.2.10 is here also
    http://download.clearfoundation.com/community/timb80/php-5.2.10/
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 12 2010, 03:35 AM - #Permalink
    Resolved
    0 votes
    im done with download, but i can't installed squid-2.7.STABLE7-1.el5.i386.rpm

    log of installation :

    [root@system xxx_folder]# yum install squid-2.7.STABLE7-1.el5.i386.rpm
    Loading "protect-packages" plugin
    Loading "kmod" plugin
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
    * base-supplements: download1.clearfoundation.com
    * base-kernels: download1.clearfoundation.com
    * base-updates: download1.clearfoundation.com
    * clearcentos-os: download1.clearfoundation.com
    * base-os: download1.clearfoundation.com
    * clearcentos-updates: download1.clearfoundation.com
    * base-console: download1.clearfoundation.com
    Setting up Install Process
    Parsing package install arguments
    Examining squid-2.7.STABLE7-1.el5.i386.rpm: squid - 7:2.7.STABLE7-1.el5.i386
    Marking squid-2.7.STABLE7-1.el5.i386.rpm as an update to squid - 7:2.6.STABLE21-4.1.v5.i386
    Resolving Dependencies
    --> Running transaction check
    ---> Package squid.i386 7:2.7.STABLE7-1.el5 set to be updated
    --> Processing Dependency: liblber-2.3.so.0 for package: squid
    --> Processing Dependency: libldap-2.3.so.0 for package: squid
    --> Finished Dependency Resolution
    Error: Missing Dependency: libldap-2.3.so.0 is needed by package squid
    Error: Missing Dependency: liblber-2.3.so.0 is needed by package squid


    any suggest or clue ?? :(

    need help ASAP :)
    The reply is currently minimized Show
  • Accepted Answer

    Megrain
    Megrain
    Offline
    Saturday, December 26 2009, 09:38 AM - #Permalink
    Resolved
    0 votes
    Hi Michael
    you can upgrade to php 5.3 and mysql 5.1 maunally by downloading the rpm's for centos 5 and installing them on your server.
    The reply is currently minimized Show
Your Reply