Forums

Sampe
Sampe
Offline
Resolved
0 votes
Hi :)

I have a problem with my sql server on Clearos 6 server

I have not touched any of the configure files for the server yet.

but this is whats happens when i try to start it from terminal.

# service mysqld start
Another MySQL daemon already running with the same unix socket.
Starting mysqld: [FAILED]

Seem to be something with the socket to do.
But i don't know

If anyone know what I can do to fix this problem, please share :)
Thanks
Tuesday, December 03 2013, 01:57 PM
Share this post:
Responses (8)
  • Accepted Answer

    Sunday, December 15 2013, 09:46 PM - #Permalink
    Resolved
    0 votes
    Thanks Peter :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 13 2013, 08:05 PM - #Permalink
    Resolved
    0 votes
    This behavior is new and has been reported upstream:

    https://bugzilla.redhat.com/show_bug.cgi?id=1037650

    The bug has a priority/severity of urgent, so I would expect an upstream update soon. If we don't see anything by Tuesday, we'll provide a temporary workaround -- http://tracker.clearfoundation.com/view.php?id=1461
    The reply is currently minimized Show
  • Accepted Answer

    Friday, December 13 2013, 06:37 PM - #Permalink
    Resolved
    0 votes
    I had this same problem yesterday. Did what Tim said and all is good now.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, December 08 2013, 10:21 PM - #Permalink
    Resolved
    0 votes
    I stumbled across this just recently after a power failure, and the stale socket file was not removed by the service script (minor bug?)
    /var/lib/mysql/mysql.sock

    Manually removing it and restarting the service was all I had to do
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 05 2013, 11:34 PM - #Permalink
    Resolved
    0 votes
    I had the same problem after a power failure, but I had not rebooted the server in days, and I know a few things were updated automatically. hope its just a coincidence. had to disable and enable the socket file from the config file to have the server start again. Odd.
    The reply is currently minimized Show
  • Accepted Answer

    crazym
    crazym
    Offline
    Thursday, December 05 2013, 07:03 PM - #Permalink
    Resolved
    0 votes
    Hi,

    I had the exact same problem...But I was just open the file putting a space, deleting the space and saving the file solved my MySQL problem.

    bye crazym
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 03 2013, 02:25 PM - #Permalink
    Resolved
    0 votes
    Perhaps the service was running already?

    Usually you would do 'service mysqld restart' so that it stops any running process first.
    The reply is currently minimized Show
  • Accepted Answer

    Sampe
    Sampe
    Offline
    Tuesday, December 03 2013, 02:18 PM - #Permalink
    Resolved
    0 votes
    Never mind :)

    I solved the problem

    Addade i my.cnf

    socket = /tmp/mysql.sock
    and put a # on the other one.
    The reply is currently minimized Show
Your Reply