Forums

Pedro
Pedro
Offline
Resolved
0 votes
My MYSQL setup was working but now it has stopped.

In the webconfig it is running, but if I try and install Joomla on the system check it says the database support = No
An existing Joomla installation gives me the error Database connection error (1): The MySQL adapter 'mysqli' is not available.

I have updated my MYSQL but still it doesn't appear to be working.

Thanks in advance.

Pedro
Monday, April 02 2012, 09:28 AM
Share this post:
Responses (4)
  • Accepted Answer

    Pedro
    Pedro
    Offline
    Monday, April 02 2012, 12:56 PM - #Permalink
    Resolved
    0 votes
    Restarted that service and still the same.

    It baffles me because it worked yesterday and I don't know what i have changed that has stopped it from working.

    I upgraded PHP and it still worked.

    I upgraded mysql this morning and I'm fairly sure it worked immediately after doing that.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 02 2012, 12:52 PM - #Permalink
    Resolved
    0 votes
    Its not system-mysql, its just the mysqld service you want (the former is for the webconfig)

    service mysqld restart

    This works on port 3306...and you'll need to create a root password using the webconfig if you haven't already.
    The reply is currently minimized Show
  • Accepted Answer

    Pedro
    Pedro
    Offline
    Monday, April 02 2012, 12:19 PM - #Permalink
    Resolved
    0 votes
    Yes I'm sure I did, I've done it again and restarted system-mysql & htpd services
    But I'm still getting the same errors.
    Maybe I need to reinstall ClearOS, I only installed it yesterday and I've broke it already!

    Just noticed your last line, I have tried setting the existing website to both "mysqli" and "mysql" and nothing.
    With the new site I don't get far enough to choose as the Joomla setup checks detect no database (which is a lie!)
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 02 2012, 12:09 PM - #Permalink
    Resolved
    0 votes
    Have you installed the php-mysql extension?
    yum install php-mysql


    If it still doesn't work - you may have more luck using the 'mysql' database type (note not the same as 'mysqli')
    The reply is currently minimized Show
Your Reply