Forums

Resolved
0 votes
So ive been having some problems with my ISP lately and i decided to install NTOP to help diagnose the issue i followed this guide:
http://www.clearfoundation.com/docs/howtos/bandwidth_reporting_with_ntop
and ive been unable to start the NTOP Service. the exact error message im getting is:
[root@USS-Intrepid ~]# service ntop start
Starting ntop: /bin/bash: line 1: 21438 Segmentation fault /usr/sbin/ntop @/etc/ntop.conf --daemon > /dev/null
[FAILED]

thinking maybe the service wasnt set up correctly i resorted to turning it on manually using just ntop and received this error message:
Fri Jan 30 12:05:52 2015  **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Fri Jan 30 12:05:52 2015 **ERROR** While adding purge_host.seconds_idle_with_no_sessions=60.
Segmentation fault

It spams that ERROR a good minute and then crashes out with the segmentation fault i checked the bugs section of ntop and the only issue that really pertained to a segmentation fault was from a while ago and complety unrelated. ive been diging through mounds of documentation and google to no avail. i installed ntop on ClearOS 6.5 and i recived the segmentation fault so i figured upgrading to to 6.6.0 final would possibly be more stable or fixed after the upgrade im still receiving the same error. i rebooted the gateway/server after the upgrade as a new kernel was installed with the upgrade

System details:
[root@USS-Intrepid ~]# uname -a
Linux USS-Intrepid.MAN.local 2.6.32-504.3.3.v6.x86_64 #1 SMP Thu Jan 8 18:10:05 MST 2015 x86_64 x86_64 x86_64 GNU/Linux

[root@USS-Intrepid ~]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] LPC Controller (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 AC'97 Sound Controller (rev a0)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA [SiS] (rev 01)
00:08.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)
00:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 80)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

[root@USS-Intrepid ~]# lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 1
On-line CPU(s) list: 0
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 1
NUMA node(s): 1
Vendor ID: AuthenticAMD
CPU family: 15
Model: 12
Stepping: 0
CPU MHz: 1808.373
BogoMIPS: 3616.74
L1d cache: 64K
L1i cache: 64K
L2 cache: 256K
NUMA node0 CPU(s): 0

[root@USS-Intrepid ~]# free -m
total used free shared buffers cached
Mem: 868 791 77 0 7 208
-/+ buffers/cache: 574 293
Swap: 1759 318 1441

thank you for the help in advance
~ Admiral Morketh ~
Friday, January 30 2015, 07:14 PM
Share this post:
Responses (4)
  • Accepted Answer

    Monday, February 09 2015, 06:25 PM - #Permalink
    Resolved
    0 votes
    Apon further testing it appears that firefox on ubuntu 10 will view the site just fine however firefox on Windows 7 Ultimate will not.
    I can only guess as to what that could mean.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 06 2015, 05:46 PM - #Permalink
    Resolved
    0 votes
    Some more information that might of use. the Firewall is open on port 3000 and Ntop is still not visible i ran a nmap from another box and these are the results
    Nmap scan report for 192.168.1.1
    Host is up (0.00063s latency).
    Not shown: 991 closed ports
    PORT STATE SERVICE
    22/tcp open ssh
    53/tcp open domain
    81/tcp open hosts2-ns
    82/tcp open xfer
    83/tcp open mit-ml-dev
    636/tcp open ldapssl
    3128/tcp open squid-http
    6000/tcp open X11
    8080/tcp open http-proxy

    at this point im not sure what else to check. ports open service is running (not sure why its running there wasnt any major upgrade for ntop that i could see)
    well i'll be ^_^ i just found the problem the conf file (/etc/ntop.conf) contains a few things for the daemon and ntop service. AND an address to bind to
    # limit ntop to listening on a specific interface and port
    --http-server 127.0.0.1:3000 --https-server 127.0.0.1:3001

    this is what the configuration file has currantly and changing it to:
    # limit ntop to listening on a specific interface and port
    --http-server 192.168.1.1:3000 --https-server 192.168.1.1:3001

    restarting the service and now i get a webpage :( with the fallowing error message:
    Please enable make sure that the ntop html/ directory is properly installed
    Error 400
    The specified request is invalid.

    Received request:

    "GET / HTTP/1.1"


    so i guess at this point we need to locate the web directory for ntop, also i found this troubleshooting tip from Ntop Wiki:
    Please enable make sure that the ntop html/ directory is properly installed

    If you receive this warning while trying to access the web interface, edit /etc/conf.d/ntop to include your IP and restart the daemon. For example:

    NTOP_ARGS="-i enp1s0 -w 127.0.0.1:3000"


    This is the IP you will use to access the web interface.

    now i belive that /etc/conf.d/ntop is not a valid file so in this case im going to place this in the /etc/ntop.conf file
    if you expand the options provided by the ntop wiki you get the following:
    -w | --http-server

    -W | --https-server

    so the options were already in place and the configuration file checks out O_O with the exception of a 400 Error on the website in question (i found refrance to ntop not working with Chrome here in the forums somplace and indeed im using FireFox) IE 11 seems to function just fine after the configuration file was updated >..< im not a fan of Internet Exploder
    aside from the fact that i have to use IE instead of FireFox it seems to be working is there a way to make ntop Work with Firefox on ClearOS? ive installed Ntop on Ubuntu 14 and it ran just fine with out all these headaches.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 03 2015, 03:48 AM - #Permalink
    Resolved
    0 votes
    according to rpmfind its avalible in the EPEL

    ..........

    [root@USS-Intrepid ~]# service ntop status
    ntop (pid 2200) is running...


    ...... and now its working? :huh:
    this is very strange. varifying the log files for the last install/update was January 30th (good handful of them too) logging in today i was going to see if i could find out which repository i had installed it from and
    repoquery -i ntop
    wouldnt provide me with a result. Attempting to start ntop again today gave me an "already running" response so i had to check and see if it was. Seems to be doing alright is this an update provided from upstream? or something else?

    as of right now i cant figure out how to get the WUI up (ports open and navigating to IP_ADDRESS_HERE:3000 gives me "unable to connect")
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, February 01 2015, 04:23 PM - #Permalink
    Resolved
    0 votes
    Looks like the third party package is broken :( I have the same issue here when I tested it... I think it used to be an EPEL RPM?
    The reply is currently minimized Show
Your Reply