Forums

Resolved
0 votes
When I add a new website, I get this error: Oops! Software is not installed.

I'm not sure what software is not installed. The message is too vague. Anyone has any suggestions what is missing?

COS 7.6 all up to date

TIA
Thursday, September 05 2019, 02:21 AM
Share this post:
Responses (8)
  • Accepted Answer

    Tuesday, September 10 2019, 08:00 PM - #Permalink
    Resolved
    0 votes
    Personally I don't mind people knowing my External domain or IP address but you can change them if you want, but be consistent. Your LAN domain and LAN IP's are pretty much useless to anyone if your firewall works.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 10 2019, 04:46 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Get ready to go to the webserver screen then enable webconfig debugging with:
    touch /etc/clearos/webconfig.debug
    Then go to your Web Server screen and get the Ooops. Then delete /etc/clearos/webconfig.debug to stop the debug log building. Have a look at log in /var/log/webconfig/debug.log for errors. There are always a few trivial ones so don't worry about them. The major failure is often quite obvious with a number of failed PHP calls with line numbers.


    Did this and got a big file, not sure what parts I should post here. File is 1.4Mb, and I dont know if i should replace the domain entries with something generic like domain.com. Any suggestions
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 10 2019, 07:18 AM - #Permalink
    Resolved
    0 votes
    Get ready to go to the webserver screen then enable webconfig debugging with:
    touch /etc/clearos/webconfig.debug
    Then go to your Web Server screen and get the Ooops. Then delete /etc/clearos/webconfig.debug to stop the debug log building. Have a look at log in /var/log/webconfig/debug.log for errors. There are always a few trivial ones so don't worry about them. The major failure is often quite obvious with a number of failed PHP calls with line numbers.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, September 09 2019, 12:17 PM - #Permalink
    Resolved
    0 votes
    rpm -qa | egrep '(flexshare|storage).*-core'
    app-flexshare-core-2.4.14-1.v7.noarch
    app-storage-core-2.6.16-1.v7.noarch
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, September 08 2019, 07:54 AM - #Permalink
    Resolved
    0 votes
    What is the output to:
    rpm -qa | egrep '(flexshare|storage).*-core'
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 07 2019, 10:23 PM - #Permalink
    Resolved
    0 votes
    Did a reinstall without removing anything, nothing changed it seems

    yum reinstall app-web-server
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-newyork.clearos.com
    * clearos-centos: download1.clearsdn.com
    * clearos-centos-sclo-rh: download1.clearsdn.com
    * clearos-centos-updates: download1.clearsdn.com
    * clearos-contribs: mirror2-newyork.clearos.com
    * clearos-epel: download1.clearsdn.com
    * clearos-fast-updates: download1.clearsdn.com
    * clearos-infra: mirror2-newyork.clearos.com
    * clearos-updates: mirror2-newyork.clearos.com
    * private-clearcenter-dyndns: download2.clearsdn.com:80
    * private-clearcenter-roundcubemail: download3.clearsdn.com:80
    clearos | 3.7 kB 00:00:00
    clearos-centos | 3.6 kB 00:00:00
    clearos-centos-sclo-rh | 3.0 kB 00:00:00
    clearos-centos-updates | 2.9 kB 00:00:00
    clearos-contribs | 3.5 kB 00:00:00
    clearos-epel | 2.9 kB 00:00:00
    clearos-fast-updates | 3.0 kB 00:00:00
    clearos-infra | 3.5 kB 00:00:00
    clearos-updates | 3.5 kB 00:00:00
    private-clearcenter-dyndns | 3.0 kB 00:00:00
    private-clearcenter-roundcubemail | 3.0 kB 00:00:00
    Resolving Dependencies
    --> Running transaction check
    ---> Package app-web-server.noarch 1:2.5.2-1.v7 will be reinstalled
    --> Finished Dependency Resolution

    Dependencies Resolved

    =================================================================================================================================================
    Package Arch Version Repository Size
    =================================================================================================================================================
    Reinstalling:
    app-web-server noarch 1:2.5.2-1.v7 clearos-updates 18 k

    Transaction Summary
    ================================================================================================================================================

    Reinstall 1 Package

    Total download size: 18 k
    Installed size: 72 k
    Is this ok [y/d/N]: y
    Downloading packages:
    app-web-server-2.5.2-1.v7.noarch.rpm | 18 kB 00:00:00
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Installing : 1:app-web-server-2.5.2-1.v7.noarch 1/1
    Verifying : 1:app-web-server-2.5.2-1.v7.noarch 1/1

    Installed:
    app-web-server.noarch 1:2.5.2-1.v7

    Complete!
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 07 2019, 08:36 PM - #Permalink
    Resolved
    0 votes
    Created the file, nothing written the file so far. but when I create new sites, it does not create the normal sandboxed folders.

    All it does is create the main folder under /var/www/virtual/somesite/ but nothing after that.

    Yes, I have the app installed.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 06 2019, 09:32 AM - #Permalink
    Resolved
    0 votes
    This may sound odd, but do you have the web server app installed? I think Marcel had the same problem. If it is installed you may need to enable webconfig debugging ("touch /etc/clearos/webconfig.debug) to see where it is tripping up. Remove the webconfig.debug file afterwards as it generates a huge amount of logging.
    The reply is currently minimized Show
Your Reply