Community Forum

Resolved
0 votes
Hi people, I have the next problem.

http://i.imgur.com/YOZ6RoZ.png

To specific on each site I put in site.conf the "local 10.10.10.X"
But If I do this, Se servicve doesñt not auto start. I have to start manually.

http://i.imgur.com/Yn7DfTX.png

When I start the service manually all work fine.

http://i.imgur.com/wqMVBwh.png


If I delete de "local 10.10.10.X" from each *.conf, se service work fine but sometimes it use the dinamic interface :(
In OpenVPN
Thursday, July 13 2017, 02:42 PM
Share this post:
Responses (2)
  • Accepted Answer

    Friday, July 14 2017, 03:07 AM - #Permalink
    Resolved
    0 votes
    Depending on what your external facing network is doing, you may need to use the 'float' parameter. This is especially true if your ISP is changing your IP address at all or if multiwan DNS changes it on you.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, July 13 2017, 04:07 PM - #Permalink
    Resolved
    0 votes
    Do your error logs show anything at start up? Also what does the command "service openvpn@XXXXX status" return after boot up. Replace XXXXX with the beginning part of the configuration file you are using in /etc/openvpn/ without the ".conf" bit, so you probably want "service openvpn@clients status". At a guess it is failing because the network has not fully started at the point openvpn is starting. If that is the case, try editing /usr/lib/systemd/system/openvpn@.service and changing the line:
    After=network.target
    to
    After=syslog.target network-online.target


    [edit]
    If this works, please post back and I may be able to file a bug.
    [/edit]
    The reply is currently minimized Show
Your Reply