Forums

Resolved
0 votes
Hi all,

Tried to uninstall and reinstall OpenVPN, marketplace giving a dependency error on reinstall. Tried from the command line and getting the dependency issue. Any thoughts?

Thanks,

James

app-openvpn.noarch : OpenVPN
app-openvpn-core.noarch : OpenVPN - Core
app-openvpn-plugin-core.noarch : OpenVPN Policies - Core

Name and summary matches only, use "search all" for everything.
[root@gateway ~]# yum install app-openvpn.noarch
Loaded plugins: clearcenter-marketplace, fastestmirror
ClearCenter Marketplace: fetching repositories...
ClearCenter Marketplace: hostname 'cos7-ws1.clearsdn.com' doesn't match either of '*.clearcenter.com', '*.clearfoundation.com', '*.clearos.com', '*.clearvm.com', '*.witsbits.com', 'clearcenter.com', 'clearfoundation.com', 'clearos.com', 'clearvm.com', 'witsbits.com'
Loading mirror speeds from cached hostfile
* clearos: mirror1-newyork.clearos.com
* clearos-centos: download3.clearsdn.com
* clearos-centos-sclo-rh: download3.clearsdn.com
* clearos-centos-updates: download3.clearsdn.com
* clearos-contribs: mirror1-newyork.clearos.com
* clearos-fast-updates: download3.clearsdn.com
* clearos-infra: mirror1-newyork.clearos.com
* clearos-updates: mirror1-newyork.clearos.com
Resolving Dependencies
--> Running transaction check
---> Package app-openvpn.noarch 1:2.4.0-1.v7 will be installed
--> Processing Dependency: app-openvpn-core = 1:2.4.0-1.v7 for package: 1:app-openvpn-2.4.0-1.v7.noarch
--> Running transaction check
---> Package app-openvpn-core.noarch 1:2.4.0-1.v7 will be installed
--> Processing Dependency: openvpn >= 2.4.2 for package: 1:app-openvpn-core-2.4.0-1.v7.noarch
--> Processing Dependency: app-openvpn-plugin-core for package: 1:app-openvpn-core-2.4.0-1.v7.noarch
--> Running transaction check
---> Package app-openvpn-core.noarch 1:2.4.0-1.v7 will be installed
--> Processing Dependency: openvpn >= 2.4.2 for package: 1:app-openvpn-core-2.4.0-1.v7.noarch
---> Package app-openvpn-plugin-core.noarch 1:2.1.6-1.v7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:app-openvpn-core-2.4.0-1.v7.noarch (clearos-updates)
Requires: openvpn >= 2.4.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
In OpenVPN
Monday, March 11 2019, 02:55 PM
Share this post:
Responses (1)
  • Accepted Answer

    Monday, March 11 2019, 03:53 PM - #Permalink
    Resolved
    0 votes
    The problem is bigger than that. The certificate is failing, but the devs are close to a fix. You only may have a few minutes to wait.

    [edit]
    And before I hit reply, it appears to be working again.
    {/edit]
    The reply is currently minimized Show
Your Reply