Forums

Resolved
0 votes
Good day why my OPENVPN still use the PUBLIC IP of the network where i connected, not using my IP where i configure the OPENVPN

Thanks
In OpenVPN
Monday, September 23 2019, 03:21 AM
Share this post:

Accepted Answer

Saturday, October 05 2019, 07:37 AM - #Permalink
Resolved
0 votes
Sorry for the delay, but notification e-mails of new posts have been failing so yours got stuck under moderation.

If you want to send all traffic through the OpenVPN then have a look at the app docs (the slanted book icon). There is a one line change you can make to /etc/openvpn/clients.conf. It is planned to add this to the webconfig at some point. Otherwise the only traffic which goes through OpenVPN is traffic destined for your LAN.
The reply is currently minimized Show
Responses (5)
  • Accepted Answer

    Thursday, October 10 2019, 08:19 AM - #Permalink
    Resolved
    0 votes
    All the extra option does is stop pushing DHCP traffic down the VPN. Normally this should stay local as it affects the phone/PC/laptop getting an IP from the LAN it is connected to. I don't know if this affects phones using data connections because they may be PPP and not DHCP. It would affect a phone or PC/Laptop connecting via a LAN.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, October 10 2019, 07:38 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Good.
    push "redirect-gateway def1 bypass-dhcp"
    May be better but I have not seen any real change.


    what is the best way sir? i try using my data in phone then connect to vpn and check my public IP and my server IP appear, which is thats what i want, or different location
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, October 10 2019, 07:28 AM - #Permalink
    Resolved
    0 votes
    Good.
    push "redirect-gateway def1 bypass-dhcp"
    May be better but I have not seen any real change.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, October 10 2019, 05:48 AM - #Permalink
    Resolved
    0 votes
    It's successfull sir thanks i add this parameter

    push "redirect-gateway def1"
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, October 10 2019, 05:19 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Sorry for the delay, but notification e-mails of new posts have been failing so yours got stuck under moderation.

    If you want to send all traffic through the OpenVPN then have a look at the app docs (the slanted book icon). There is a one line change you can make to /etc/openvpn/clients.conf. It is planned to add this to the webconfig at some point. Otherwise the only traffic which goes through OpenVPN is traffic destined for your LAN.



    Thank you sir Nick
    Like
    1
    The reply is currently minimized Show
Your Reply