0 votes
Tonight (14/01/20-15/01/20) the following updated packages are being released:

  • none

* = the package is also being released to Business at the same time.

Packages available for testing

  • The 7.7 installation iso - ClearOS-DVD-x86_64-
  • Big update to the firewall, QoS, MultiWAN and Netify (including Application and Protocol Filters] All components need to be updated together:
  • yum update app-firewall app-qos *netify-* --enablerepo=clearos-updates-testing,clearos-contribs-testing
    The MultiWAN updates are covered by the update to app-firewall.
  • app-network - code merge complete. Seems to work for everything except external VLANs.

    • Now allows you to set up Wireless and Cellular interfaces. You will also need app-wireless to configure a NIC as an access point. Otherwise manual configuration is then needed for WiFi and Cellular devices.
    • I've tweaked it for kernel mode PPPoE (much faster and lower resoures). For the moment we are not forcibly converting PPPoE interfaces over, but if you edit an interface it will switch to kernel mode.
    • Hides irrelevant interfaces from app-network-report such as docker0, veth* and ifb*.
    • Numerous other changes since last 2.6.0
    • Do not use the the update if you use VLAN's on external interfaces.

Unless detailed otherwise, packages available for testing can be installed with:
yum update --enablerepo=clearos-updates-testing {package-name}

Packages being worked on:

  • app-storage
  • app-sia - In theory it worked but does not. Fixes needed. I have an idea to get it working in Gateway mode but it is deathly slow.
  • app-openvpn to add three configuration parameters (client-to-client, "push block-outside-dns" and to force all traffic through the VPN). This is being worked on by an external contributor.
  • app-attack-detector to add a button beside each banned IP to you can unban it. This is being worked on by an external contributor.
  • kimchi 3.0 and wok 3.0. I can build wok and install and get it running with one python error. kimchi will build but cannot install as I am missing a couple of dependencies. This may take a while as I need to try and get EPEL to build them. kimchi is a great VM manager front end for KVM/libvirt.
Tuesday, January 14 2020, 09:56 PM
Share this post:
Responses (3)
  • Accepted Answer

    Tuesday, January 21 2020, 06:39 PM - #Permalink
    0 votes
    Kimchi is really interesting. We talked about it during the community meeting.

    Has anyone tested Kimchi on Centos 8? I know ClearOS 8 is a long way off but I think it interesting to know. I'm dreaming of ClearOS which can handle container and vm's.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2020, 06:26 PM - #Permalink
    0 votes
    You can have kimchi 2.5 which is 2 years old or more. I had one problem with it as the ISO I downloaded ended up with the wrong permissions. Once i changed them kimchi was fine. You do need to create the right bits, Ntwork (possibly), Storage and Template before you can start the VM. Note my set up already had KVM on it so that side of it was already working. What you can't do is create snapshots.

    I have a feeling kimchi/wok 3.0 is going to be a non-starter because of missing python3 dependencies from EPEL.You can still use the command line to manage KVM.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, January 21 2020, 03:34 PM - #Permalink
    0 votes
    Can't wait to get my hands on Kimchi! My son is asking me to deploy a Minecraft server every week now. :)
    The reply is currently minimized Show
Your Reply