Forums

Resolved
0 votes
When RedHat/Centos went to 7.6, the repos for PHP 5.6 were dropped, but PHP 7.2 is now supported.

app-php-engines has now been updated so that if you install it or update it, you also get PHP 7.2. ClearOS 7.6 users can install it now or it will update overnight.

Dave is working on a couple of outstanding issues, but they are not holding back the release:
1 - If you have PHP 5.6 installed, the PHP Engines app should show it available and allow you to start/stop it but it does not
2 - In the Web Server app, in the PHP Engine field, it lists PHP 5.6 in the dropdown whether you have it installed or not.

Please note that PHP 5.6 is no longer supported and has not had any updates for years so must be considered as vulnerable/insecure. If you have any apps still using 5.6, you really need to be looking at updating them.

Please post to this thread if you have any issues with the updated app.
Wednesday, April 24 2019, 05:55 PM
Share this post:
Responses (11)
  • Accepted Answer

    Saturday, June 15 2019, 02:55 PM - #Permalink
    Resolved
    0 votes
    The webconfig uses its own version of php5.4 (webconfig-php).
    5.4 is still the official EL7 version and gets security fixes.
    5.6, 7.0, 7.1 and 7.2 were/are maintained by the special interest group. The stopped supporting 5.6 but, in EL7.6 (so Centos/ClearOS 7.6) they added support for 7.2.

    This means anyone using 5.4 is fine. Anyone using 5.6 should aim to move off it as soon as possible. Any new users of PHP Engines in 7.6 will not get 5.6 installed, but it is possible (but not advised) to install it by manipulating your repos.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 24 2019, 07:39 PM - #Permalink
    Resolved
    0 votes
    So a yum update (with clearos-contribs repository enabled) wants to install app-php-engines and app-php-engines-core, but returns a lot of errors when looking for multiple dependency packages called rh-php72-php*. I'm still using ClearOS 7.5.0 (Final) Business Edition, and my understanding was PHP72 was to go along with 7.6.0. Right now it's holding up any future updates because of the errors, so what repo(s) to I need to enable or disable to successfully install PHP72 or disable its installation?

    Update: I disabled the clearos-contribs repo and was able to install normal updates minus the php stuff. Still, if I wanted to implement PHP2 for ClearOS 7.5, is that feasible or even advantageous?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 24 2019, 08:06 PM - #Permalink
    Resolved
    0 votes
    Have you just been on the intercom chat?

    We were in a catch 22. The app, as it was, was broken for everyone on 7.6. This has been fixed but has broken it for everyone on 7.5. Perhaps there should have been some additional logic somewhere, but it really needed a different repo set up. I have mentioned it to the devs to see what they want to do. If they release 7.6 tonight for Home/Business, the problem will go away.

    What you can probably do is:
    yum update app-php-engines --enablerepo=centos-sclo-rh-unverified
    so you get php7.2. This will allow updates to flow again until 7.6 is released.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 25 2019, 12:29 PM - #Permalink
    Resolved
    0 votes
    Thanks for the reply, Nick. It says no packages marked for update when trying your suggestion. I noticed I had disabled clearos-contribs, so after re-enabling it, your suggestion worked. Restarted Webconfig service and PHP7.2 is showing up under Server->Web->PHP Engines. I'm currently using 7.1 and am hesitant to enable 7.2 and incorporate it into my website. I'll walk gingerly into it.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 25 2019, 04:13 PM - #Permalink
    Resolved
    0 votes
    PHP Engines was a contribution from community members and it is pretty awesome compared to what we used to have. That being said, it has a scalability issue in its design, obviously. Nick's workaround should work well. We will be working on these over the next few days but the app itself needs a bit of a rewrite.

    Currently the app requires the php versions. It should be more liberal and run even if no engines are installed. The engines themselves should be app-ified and placed in the marketplace. They should require php-engines but not the other way around. That way we can poll from the marketplace which ones are available for install and can poll from the installed list. This way it is open ended and the app shouldn't care what is installed or not installed from a dependency standpoint.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, June 06 2019, 11:42 PM - #Permalink
    Resolved
    1 votes
    I have a few servers that are no longer auto-updating. Below is the log:

    Thanks!

    [root@ ~]# yum update
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-newyork.clearos.com
    * clearos-centos: download1.clearsdn.com
    * clearos-centos-sclo-rh: download1.clearsdn.com
    * clearos-centos-updates: download1.clearsdn.com
    * clearos-contribs: mirror2-newyork.clearos.com
    * clearos-epel: download1.clearsdn.com
    * clearos-fast-updates: download1.clearsdn.com
    * clearos-infra: mirror2-newyork.clearos.com
    * clearos-updates: mirror2-newyork.clearos.com
    * private-clearcenter-dyndns: download3.clearsdn.com:80
    Resolving Dependencies
    --> Running transaction check
    ---> Package GeoIP.x86_64 0:1.5.0-11.el7 will be updated
    ---> Package GeoIP.x86_64 0:1.5.0-13.el7 will be an update
    ---> Package alsa-lib.x86_64 0:1.1.4.1-2.el7 will be updated
    ---> Package alsa-lib.x86_64 0:1.1.6-2.el7 will be an update
    ---> Package app-base.noarch 1:2.5.42-1.v7 will be updated
    ---> Package app-base.noarch 1:2.6.9-2.v7 will be an update
    ---> Package app-base-core.noarch 1:2.5.42-1.v7 will be updated
    ---> Package app-base-core.noarch 1:2.6.9-2.v7 will be an update
    ---> Package app-dns.noarch 1:2.3.24-1.v7 will be updated
    ---> Package app-dns.noarch 1:2.4.2-1.v7 will be an update
    ---> Package app-dns-core.noarch 1:2.3.24-1.v7 will be updated
    ---> Package app-dns-core.noarch 1:2.4.2-1.v7 will be an update
    ---> Package app-lets-encrypt.noarch 1:1.10.5-1.v7 will be updated
    ---> Package app-lets-encrypt.noarch 1:1.10.7-1.v7 will be an update
    ---> Package app-lets-encrypt-core.noarch 1:1.10.5-1.v7 will be updated
    ---> Package app-lets-encrypt-core.noarch 1:1.10.7-1.v7 will be an update
    ---> Package app-marketplace.noarch 1:2.6.1-1.v7 will be updated
    ---> Package app-marketplace.noarch 1:2.6.4-1.v7 will be an update
    ---> Package app-marketplace-core.noarch 1:2.6.1-1.v7 will be updated
    ---> Package app-marketplace-core.noarch 1:2.6.4-1.v7 will be an update
    ---> Package app-php-engines.noarch 1:1.1.7-1.v7 will be updated
    ---> Package app-php-engines.noarch 1:1.2.0-1.v7 will be an update
    ---> Package app-php-engines-core.noarch 1:1.1.7-1.v7 will be updated
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package app-samba-core.noarch 1:3.5.2-1.v7 will be updated
    ---> Package app-samba-core.noarch 1:3.5.3-1.v7 will be an update
    ---> Package app-web-server.noarch 1:2.5.0-1.v7 will be updated
    ---> Package app-web-server.noarch 1:2.5.2-1.v7 will be an update
    ---> Package app-web-server-core.noarch 1:2.5.0-1.v7 will be updated
    ---> Package app-web-server-core.noarch 1:2.5.2-1.v7 will be an update
    ---> Package audit.x86_64 0:2.8.1-3.el7_5.1 will be updated
    ---> Package audit.x86_64 0:2.8.4-4.el7 will be an update
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package audit-libs.x86_64 0:2.8.4-4.el7 will be an update
    ---> Package bash.x86_64 0:4.2.46-30.el7 will be updated
    ---> Package bash.x86_64 0:4.2.46-31.el7 will be an update
    ---> Package bind-libs.x86_64 32:9.9.4-61.el7_5.1 will be updated
    ---> Package bind-libs.x86_64 32:9.9.4-73.el7_6 will be an update
    ---> Package bind-libs-lite.x86_64 32:9.9.4-61.el7_5.1 will be updated
    ---> Package bind-libs-lite.x86_64 32:9.9.4-73.el7_6 will be an update
    ---> Package bind-license.noarch 32:9.9.4-61.el7_5.1 will be updated
    ---> Package bind-license.noarch 32:9.9.4-73.el7_6 will be an update
    ---> Package bind-utils.x86_64 32:9.9.4-61.el7_5.1 will be updated
    ---> Package bind-utils.x86_64 32:9.9.4-73.el7_6 will be an update
    ---> Package binutils.x86_64 0:2.27-28.base.el7_5.1 will be updated
    ---> Package binutils.x86_64 0:2.27-34.base.el7 will be an update
    ---> Package cairo.x86_64 0:1.14.8-2.el7 will be updated
    ---> Package cairo.x86_64 0:1.15.12-3.el7 will be an update
    --> Processing Dependency: libGL.so.1()(64bit) for package: cairo-1.15.12-3.el7.x86_64
    --> Processing Dependency: libEGL.so.1()(64bit) for package: cairo-1.15.12-3.el7.x86_64
    ---> Package clearos-framework.noarch 0:7.5.42-1.v7 will be updated
    ---> Package clearos-framework.noarch 0:7.6.1-1.v7 will be an update
    ---> Package clearos-release.x86_64 0:7-5.5.v7 will be updated
    ---> Package clearos-release.x86_64 0:7-6.3.v7 will be an update
    ---> Package coreutils.x86_64 0:8.22-21.el7 will be updated
    ---> Package coreutils.x86_64 0:8.22-23.el7 will be an update
    ---> Package cronie.x86_64 0:1.4.11-19.el7 will be updated
    ---> Package cronie.x86_64 0:1.4.11-20.el7_6 will be an update
    ---> Package cronie-anacron.x86_64 0:1.4.11-19.el7 will be updated
    ---> Package cronie-anacron.x86_64 0:1.4.11-20.el7_6 will be an update
    ---> Package cryptsetup-libs.x86_64 0:1.7.4-4.el7 will be updated
    ---> Package cryptsetup-libs.x86_64 0:2.0.3-3.el7 will be an update
    ---> Package csplugin-events.x86_64 0:1.2-2.v7 will be updated
    ---> Package csplugin-events.x86_64 0:1.2-3.v7 will be an update
    ---> Package csplugin-filewatch.x86_64 0:1.0-19.v7 will be updated
    ---> Package csplugin-filewatch.x86_64 0:1.2-2.v7 will be an update
    ---> Package curl.x86_64 0:7.29.0-46.el7 will be updated
    ---> Package curl.x86_64 0:7.29.0-51.el7 will be an update
    ---> Package dbus.x86_64 1:1.10.24-7.el7 will be updated
    ---> Package dbus.x86_64 1:1.10.24-13.el7_6 will be an update
    ---> Package dbus-libs.x86_64 1:1.10.24-7.el7 will be updated
    ---> Package dbus-libs.x86_64 1:1.10.24-13.el7_6 will be an update
    ---> Package device-mapper.x86_64 7:1.02.146-4.el7 will be updated
    ---> Package device-mapper.x86_64 7:1.02.149-10.el7_6.7 will be an update
    ---> Package device-mapper-libs.x86_64 7:1.02.146-4.el7 will be updated
    ---> Package device-mapper-libs.x86_64 7:1.02.149-10.el7_6.7 will be an update
    ---> Package dmidecode.x86_64 1:3.0-5.el7 will be updated
    ---> Package dmidecode.x86_64 1:3.1-2.el7 will be an update
    ---> Package dracut.x86_64 0:033-535.el7_5.1 will be updated
    ---> Package dracut.x86_64 0:033-554.el7 will be an update
    ---> Package dracut-config-rescue.x86_64 0:033-535.el7_5.1 will be updated
    ---> Package dracut-config-rescue.x86_64 0:033-554.el7 will be an update
    ---> Package dracut-network.x86_64 0:033-535.el7_5.1 will be updated
    ---> Package dracut-network.x86_64 0:033-554.el7 will be an update
    ---> Package e2fsprogs.x86_64 0:1.42.9-12.el7_5 will be updated
    ---> Package e2fsprogs.x86_64 0:1.42.9-13.el7 will be an update
    ---> Package e2fsprogs-libs.x86_64 0:1.42.9-12.el7_5 will be updated
    ---> Package e2fsprogs-libs.x86_64 0:1.42.9-13.el7 will be an update
    ---> Package elfutils-default-yama-scope.noarch 0:0.170-4.el7 will be updated
    ---> Package elfutils-default-yama-scope.noarch 0:0.172-2.el7 will be an update
    ---> Package elfutils-libelf.x86_64 0:0.170-4.el7 will be updated
    ---> Package elfutils-libelf.x86_64 0:0.172-2.el7 will be an update
    ---> Package elfutils-libs.x86_64 0:0.170-4.el7 will be updated
    ---> Package elfutils-libs.x86_64 0:0.172-2.el7 will be an update
    ---> Package ethtool.x86_64 2:4.8-7.el7 will be updated
    ---> Package ethtool.x86_64 2:4.8-9.el7 will be an update
    ---> Package file.x86_64 0:5.11-33.el7 will be updated
    ---> Package file.x86_64 0:5.11-35.el7 will be an update
    ---> Package file-libs.x86_64 0:5.11-33.el7 will be updated
    ---> Package file-libs.x86_64 0:5.11-35.el7 will be an update
    ---> Package findutils.x86_64 1:4.5.11-5.el7 will be updated
    ---> Package findutils.x86_64 1:4.5.11-6.el7 will be an update
    ---> Package firewalld.noarch 0:0.4.4.4-15.el7_5 will be updated
    ---> Package firewalld.noarch 0:0.5.3-5.el7 will be an update
    ---> Package firewalld-filesystem.noarch 0:0.4.4.4-15.el7_5 will be updated
    ---> Package firewalld-filesystem.noarch 0:0.5.3-5.el7 will be an update
    ---> Package fontconfig.x86_64 0:2.10.95-11.el7 will be updated
    ---> Package fontconfig.x86_64 0:2.13.0-4.3.el7 will be an update
    --> Processing Dependency: dejavu-sans-fonts for package: fontconfig-2.13.0-4.3.el7.x86_64
    ---> Package freetype.x86_64 0:2.4.11-15.el7 will be updated
    ---> Package freetype.x86_64 0:2.8-12.el7_6.1 will be an update
    ---> Package glib-networking.x86_64 0:2.50.0-1.el7 will be updated
    ---> Package glib-networking.x86_64 0:2.56.1-1.el7 will be an update
    ---> Package glib2.x86_64 0:2.54.2-2.el7 will be updated
    ---> Package glib2.x86_64 0:2.56.1-2.el7 will be an update
    ---> Package glibc.x86_64 0:2.17-222.el7 will be updated
    ---> Package glibc.x86_64 0:2.17-260.el7_6.4 will be an update
    ---> Package glibc-common.x86_64 0:2.17-222.el7 will be updated
    ---> Package glibc-common.x86_64 0:2.17-260.el7_6.4 will be an update
    ---> Package gnutls.x86_64 0:3.3.26-9.el7 will be updated
    ---> Package gnutls.x86_64 0:3.3.29-9.el7_6 will be an update
    ---> Package gobject-introspection.x86_64 0:1.50.0-1.el7 will be updated
    ---> Package gobject-introspection.x86_64 0:1.56.1-1.el7 will be an update
    ---> Package grub2.x86_64 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2.x86_64 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-common.noarch 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-common.noarch 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-pc.x86_64 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-pc.x86_64 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-pc-modules.noarch 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-pc-modules.noarch 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-tools.x86_64 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-tools.x86_64 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-tools-extra.x86_64 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-tools-extra.x86_64 1:2.02.2-0.76.v7 will be an update
    ---> Package grub2-tools-minimal.x86_64 1:2.02-0.65.v7.2 will be updated
    ---> Package grub2-tools-minimal.x86_64 1:2.02.2-0.76.v7 will be an update
    ---> Package grubby.x86_64 0:8.28-23.el7 will be updated
    ---> Package grubby.x86_64 0:8.28-25.el7 will be an update
    ---> Package gsettings-desktop-schemas.x86_64 0:3.24.1-2.el7_5 will be updated
    ---> Package gsettings-desktop-schemas.x86_64 0:3.28.0-2.el7 will be an update
    ---> Package harfbuzz.x86_64 0:1.3.2-1.el7 will be updated
    ---> Package harfbuzz.x86_64 0:1.7.5-2.el7 will be an update
    ---> Package hwdata.x86_64 0:0.252-8.8.el7 will be updated
    ---> Package hwdata.x86_64 0:0.252-9.1.el7 will be an update
    ---> Package initscripts.x86_64 0:9.49.41-1.v7.3 will be updated
    ---> Package initscripts.x86_64 0:9.49.46-1.v7 will be an update
    ---> Package iproute.x86_64 0:4.11.0-14.el7 will be updated
    ---> Package iproute.x86_64 0:4.11.0-14.el7_6.2 will be an update
    ---> Package iprutils.x86_64 0:2.4.15.1-1.el7 will be updated
    ---> Package iprutils.x86_64 0:2.4.16.1-1.el7 will be an update
    ---> Package ipset.x86_64 0:6.29-1.el7 will be updated
    ---> Package ipset.x86_64 0:6.38-3.el7_6 will be an update
    ---> Package ipset-libs.x86_64 0:6.29-1.el7 will be updated
    ---> Package ipset-libs.x86_64 0:6.38-3.el7_6 will be an update
    ---> Package iptables.x86_64 0:1.4.21-24.1.v7 will be updated
    ---> Package iptables.x86_64 0:1.4.21-28.v7 will be an update
    ---> Package iw.x86_64 0:4.3-1.el7 will be updated
    ---> Package iw.x86_64 0:4.3-2.el7 will be an update
    ---> Package iwl100-firmware.noarch 0:39.31.5.1-62.2.el7_5 will be updated
    ---> Package iwl100-firmware.noarch 0:39.31.5.1-69.el7 will be an update
    ---> Package iwl1000-firmware.noarch 1:39.31.5.1-62.2.el7_5 will be updated
    ---> Package iwl1000-firmware.noarch 1:39.31.5.1-69.el7 will be an update
    ---> Package iwl105-firmware.noarch 0:18.168.6.1-62.2.el7_5 will be updated
    ---> Package iwl105-firmware.noarch 0:18.168.6.1-69.el7 will be an update
    ---> Package iwl135-firmware.noarch 0:18.168.6.1-62.2.el7_5 will be updated
    ---> Package iwl135-firmware.noarch 0:18.168.6.1-69.el7 will be an update
    ---> Package iwl2000-firmware.noarch 0:18.168.6.1-62.2.el7_5 will be updated
    ---> Package iwl2000-firmware.noarch 0:18.168.6.1-69.el7 will be an update
    ---> Package iwl2030-firmware.noarch 0:18.168.6.1-62.2.el7_5 will be updated
    ---> Package iwl2030-firmware.noarch 0:18.168.6.1-69.el7 will be an update
    ---> Package iwl3160-firmware.noarch 0:22.0.7.0-62.2.el7_5 will be updated
    ---> Package iwl3160-firmware.noarch 0:22.0.7.0-69.el7 will be an update
    ---> Package iwl3945-firmware.noarch 0:15.32.2.9-62.2.el7_5 will be updated
    ---> Package iwl3945-firmware.noarch 0:15.32.2.9-69.el7 will be an update
    ---> Package iwl4965-firmware.noarch 0:228.61.2.24-62.2.el7_5 will be updated
    ---> Package iwl4965-firmware.noarch 0:228.61.2.24-69.el7 will be an update
    ---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-62.2.el7_5 will be updated
    ---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-69.el7 will be an update
    ---> Package iwl5150-firmware.noarch 0:8.24.2.2-62.2.el7_5 will be updated
    ---> Package iwl5150-firmware.noarch 0:8.24.2.2-69.el7 will be an update
    ---> Package iwl6000-firmware.noarch 0:9.221.4.1-62.2.el7_5 will be updated
    ---> Package iwl6000-firmware.noarch 0:9.221.4.1-69.el7 will be an update
    ---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-62.2.el7_5 will be updated
    ---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-69.el7 will be an update
    ---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-62.2.el7_5 will be updated
    ---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-69.el7 will be an update
    ---> Package iwl6050-firmware.noarch 0:41.28.5.1-62.2.el7_5 will be updated
    ---> Package iwl6050-firmware.noarch 0:41.28.5.1-69.el7 will be an update
    ---> Package iwl7260-firmware.noarch 0:22.0.7.0-62.2.el7_5 will be updated
    ---> Package iwl7260-firmware.noarch 0:22.0.7.0-69.el7 will be an update
    ---> Package kbd.x86_64 0:1.15.5-13.el7 will be updated
    ---> Package kbd.x86_64 0:1.15.5-15.el7 will be an update
    ---> Package kbd-legacy.noarch 0:1.15.5-13.el7 will be updated
    ---> Package kbd-legacy.noarch 0:1.15.5-15.el7 will be an update
    ---> Package kbd-misc.noarch 0:1.15.5-13.el7 will be updated
    ---> Package kbd-misc.noarch 0:1.15.5-15.el7 will be an update
    ---> Package kernel.x86_64 0:3.10.0-957.10.1.v7 will be installed
    ---> Package kernel-tools.x86_64 0:3.10.0-862.11.6.v7 will be updated
    ---> Package kernel-tools.x86_64 0:3.10.0-957.10.1.v7 will be an update
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-862.11.6.v7 will be updated
    ---> Package kernel-tools-libs.x86_64 0:3.10.0-957.10.1.v7 will be an update
    ---> Package kexec-tools.x86_64 0:2.0.15-13.el7_5.2 will be updated
    ---> Package kexec-tools.x86_64 0:2.0.15-21.el7_6.3 will be an update
    ---> Package kmod.x86_64 0:20-21.el7 will be updated
    ---> Package kmod.x86_64 0:20-23.el7 will be an update
    ---> Package kmod-libs.x86_64 0:20-21.el7 will be updated
    ---> Package kmod-libs.x86_64 0:20-23.el7 will be an update
    ---> Package kpartx.x86_64 0:0.4.9-119.el7_5.1 will be updated
    ---> Package kpartx.x86_64 0:0.4.9-123.el7 will be an update
    ---> Package krb5-libs.x86_64 0:1.15.1-19.el7 will be updated
    ---> Package krb5-libs.x86_64 0:1.15.1-37.el7_6 will be an update
    ---> Package libX11.x86_64 0:1.6.5-1.el7 will be updated
    ---> Package libX11.x86_64 0:1.6.5-2.el7 will be an update
    ---> Package libX11-common.noarch 0:1.6.5-1.el7 will be updated
    ---> Package libX11-common.noarch 0:1.6.5-2.el7 will be an update
    ---> Package libblkid.x86_64 0:2.23.2-52.el7_5.1 will be updated
    ---> Package libblkid.x86_64 0:2.23.2-59.el7_6.1 will be an update
    ---> Package libcom_err.x86_64 0:1.42.9-12.el7_5 will be updated
    ---> Package libcom_err.x86_64 0:1.42.9-13.el7 will be an update
    ---> Package libcroco.x86_64 0:0.6.11-1.el7 will be updated
    ---> Package libcroco.x86_64 0:0.6.12-4.el7 will be an update
    ---> Package libcurl.x86_64 0:7.29.0-46.el7 will be updated
    ---> Package libcurl.x86_64 0:7.29.0-51.el7 will be an update
    ---> Package libdrm.x86_64 0:2.4.83-2.el7 will be updated
    ---> Package libdrm.x86_64 0:2.4.91-3.el7 will be an update
    ---> Package libfastjson.x86_64 0:0.99.4-2.el7 will be updated
    ---> Package libfastjson.x86_64 0:0.99.4-3.el7 will be an update
    ---> Package libgcc.x86_64 0:4.8.5-28.el7_5.1 will be updated
    ---> Package libgcc.x86_64 0:4.8.5-36.el7_6.2 will be an update
    ---> Package libgomp.x86_64 0:4.8.5-28.el7_5.1 will be updated
    ---> Package libgomp.x86_64 0:4.8.5-36.el7_6.2 will be an update
    ---> Package libjpeg-turbo.x86_64 0:1.2.90-5.el7 will be updated
    ---> Package libjpeg-turbo.x86_64 0:1.2.90-6.el7 will be an update
    ---> Package libmount.x86_64 0:2.23.2-52.el7_5.1 will be updated
    ---> Package libmount.x86_64 0:2.23.2-59.el7_6.1 will be an update
    ---> Package libselinux.x86_64 0:2.5-12.el7 will be updated
    ---> Package libselinux.x86_64 0:2.5-14.1.el7 will be an update
    ---> Package libselinux-python.x86_64 0:2.5-12.el7 will be updated
    ---> Package libselinux-python.x86_64 0:2.5-14.1.el7 will be an update
    ---> Package libselinux-utils.x86_64 0:2.5-12.el7 will be updated
    ---> Package libselinux-utils.x86_64 0:2.5-14.1.el7 will be an update
    ---> Package libsemanage.x86_64 0:2.5-11.el7 will be updated
    --> Processing Dependency: libsemanage = 2.5-11.el7 for package: libsemanage-python-2.5-11.el7.x86_64
    ---> Package libsemanage.x86_64 0:2.5-14.el7 will be an update
    ---> Package libsepol.x86_64 0:2.5-8.1.el7 will be updated
    ---> Package libsepol.x86_64 0:2.5-10.el7 will be an update
    ---> Package libsmbclient.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package libsmbclient.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package libsoup.x86_64 0:2.56.0-6.el7 will be updated
    ---> Package libsoup.x86_64 0:2.62.2-2.el7 will be an update
    ---> Package libss.x86_64 0:1.42.9-12.el7_5 will be updated
    ---> Package libss.x86_64 0:1.42.9-13.el7 will be an update
    ---> Package libssh2.x86_64 0:1.4.3-10.el7_2.1 will be updated
    ---> Package libssh2.x86_64 0:1.4.3-12.el7_6.2 will be an update
    ---> Package libstdc++.x86_64 0:4.8.5-28.el7_5.1 will be updated
    ---> Package libstdc++.x86_64 0:4.8.5-36.el7_6.2 will be an update
    ---> Package libteam.x86_64 0:1.27-4.el7 will be updated
    ---> Package libteam.x86_64 0:1.27-5.el7 will be an update
    ---> Package libuuid.x86_64 0:2.23.2-52.el7_5.1 will be updated
    ---> Package libuuid.x86_64 0:2.23.2-59.el7_6.1 will be an update
    ---> Package libwayland-client.x86_64 0:1.14.0-2.el7 will be updated
    ---> Package libwayland-client.x86_64 0:1.15.0-1.el7 will be an update
    ---> Package libwayland-server.x86_64 0:1.14.0-2.el7 will be updated
    ---> Package libwayland-server.x86_64 0:1.15.0-1.el7 will be an update
    ---> Package libwbclient.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package libwbclient.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package libxcb.x86_64 0:1.12-1.el7 will be updated
    ---> Package libxcb.x86_64 0:1.13-1.el7 will be an update
    ---> Package linux-firmware.noarch 0:20180220-62.2.git6d51311.el7_5 will be updated
    ---> Package linux-firmware.noarch 0:20180911-69.git85c5d90.el7 will be an update
    ---> Package lm_sensors-libs.x86_64 0:3.4.0-4.20160601gitf9185e5.el7 will be updated
    ---> Package lm_sensors-libs.x86_64 0:3.4.0-6.20160601gitf9185e5.el7 will be an update
    ---> Package man-db.x86_64 0:2.6.3-9.el7 will be updated
    ---> Package man-db.x86_64 0:2.6.3-11.el7 will be an update
    ---> Package mesa-libEGL.x86_64 0:17.2.3-8.20171019.el7 will be updated
    ---> Package mesa-libEGL.x86_64 0:18.0.5-4.el7_6 will be an update
    ---> Package mesa-libGL.x86_64 0:17.2.3-8.20171019.el7 will be updated
    ---> Package mesa-libGL.x86_64 0:18.0.5-4.el7_6 will be an update
    ---> Package mesa-libgbm.x86_64 0:17.2.3-8.20171019.el7 will be updated
    ---> Package mesa-libgbm.x86_64 0:18.0.5-4.el7_6 will be an update
    ---> Package mesa-libglapi.x86_64 0:17.2.3-8.20171019.el7 will be updated
    ---> Package mesa-libglapi.x86_64 0:18.0.5-4.el7_6 will be an update
    ---> Package net-tools.x86_64 0:2.0-0.22.20131004git.el7 will be updated
    ---> Package net-tools.x86_64 0:2.0-0.24.20131004git.el7 will be an update
    ---> Package newrelic-daemon.x86_64 0:8.6.0.238-1 will be updated
    ---> Package newrelic-daemon.x86_64 0:8.7.0.242-1 will be an update
    ---> Package newrelic-php5.x86_64 0:8.6.0.238-1 will be updated
    ---> Package newrelic-php5.x86_64 0:8.7.0.242-1 will be an update
    ---> Package newrelic-php5-common.noarch 0:8.6.0.238-1 will be updated
    ---> Package newrelic-php5-common.noarch 0:8.7.0.242-1 will be an update
    ---> Package nscd.x86_64 0:2.17-222.el7 will be updated
    ---> Package nscd.x86_64 0:2.17-260.el7_6.4 will be an update
    ---> Package nss.x86_64 0:3.36.0-7.el7_5 will be updated
    ---> Package nss.x86_64 0:3.36.0-7.1.el7_6 will be an update
    ---> Package nss-pem.x86_64 0:1.0.3-4.el7 will be updated
    ---> Package nss-pem.x86_64 0:1.0.3-5.el7_6.1 will be an update
    ---> Package nss-sysinit.x86_64 0:3.36.0-7.el7_5 will be updated
    ---> Package nss-sysinit.x86_64 0:3.36.0-7.1.el7_6 will be an update
    ---> Package nss-tools.x86_64 0:3.36.0-7.el7_5 will be updated
    ---> Package nss-tools.x86_64 0:3.36.0-7.1.el7_6 will be an update
    ---> Package nss-util.x86_64 0:3.36.0-1.el7_5 will be updated
    ---> Package nss-util.x86_64 0:3.36.0-1.1.el7_6 will be an update
    ---> Package openldap.x86_64 0:2.4.44-15.v7 will be updated
    ---> Package openldap.x86_64 0:2.4.44-20.v7 will be an update
    ---> Package openldap-clients.x86_64 0:2.4.44-15.v7 will be updated
    ---> Package openldap-clients.x86_64 0:2.4.44-20.v7 will be an update
    ---> Package openldap-servers.x86_64 0:2.4.44-15.v7 will be updated
    ---> Package openldap-servers.x86_64 0:2.4.44-20.v7 will be an update
    ---> Package openssl.x86_64 1:1.0.2k-12.el7 will be updated
    ---> Package openssl.x86_64 1:1.0.2k-16.el7_6.1 will be an update
    ---> Package openssl-libs.x86_64 1:1.0.2k-12.el7 will be updated
    ---> Package openssl-libs.x86_64 1:1.0.2k-16.el7_6.1 will be an update
    ---> Package pango.x86_64 0:1.40.4-1.el7 will be updated
    ---> Package pango.x86_64 0:1.42.4-2.el7_6 will be an update
    --> Processing Dependency: fribidi(x86-64) >= 1.0 for package: pango-1.42.4-2.el7_6.x86_64
    --> Processing Dependency: libfribidi.so.0()(64bit) for package: pango-1.42.4-2.el7_6.x86_64
    ---> Package perl.x86_64 4:5.16.3-292.el7 will be updated
    ---> Package perl.x86_64 4:5.16.3-294.el7_6 will be an update
    ---> Package perl-Pod-Escapes.noarch 1:1.04-292.el7 will be updated
    ---> Package perl-Pod-Escapes.noarch 1:1.04-294.el7_6 will be an update
    ---> Package perl-libs.x86_64 4:5.16.3-292.el7 will be updated
    ---> Package perl-libs.x86_64 4:5.16.3-294.el7_6 will be an update
    ---> Package perl-macros.x86_64 4:5.16.3-292.el7 will be updated
    ---> Package perl-macros.x86_64 4:5.16.3-294.el7_6 will be an update
    ---> Package php-mcrypt.x86_64 0:5.4.16-7.el7 will be updated
    ---> Package php-mcrypt.x86_64 0:5.4.16-9.el7 will be an update
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package policycoreutils.x86_64 0:2.5-29.el7_6.1 will be an update
    ---> Package polkit.x86_64 0:0.112-14.el7 will be updated
    ---> Package polkit.x86_64 0:0.112-18.el7_6.1 will be an update
    ---> Package postfix.x86_64 2:2.10.1-6.el7 will be updated
    ---> Package postfix.x86_64 2:2.10.1-7.el7 will be an update
    ---> Package procps-ng.x86_64 0:3.3.10-17.el7_5.2 will be updated
    ---> Package procps-ng.x86_64 0:3.3.10-23.el7 will be an update
    ---> Package python.x86_64 0:2.7.5-69.el7_5 will be updated
    ---> Package python.x86_64 0:2.7.5-77.el7_6 will be an update
    ---> Package python-firewall.noarch 0:0.4.4.4-15.el7_5 will be updated
    ---> Package python-firewall.noarch 0:0.5.3-5.el7 will be an update
    ---> Package python-libs.x86_64 0:2.7.5-69.el7_5 will be updated
    ---> Package python-libs.x86_64 0:2.7.5-77.el7_6 will be an update
    ---> Package python-linux-procfs.noarch 0:0.4.9-3.el7 will be updated
    ---> Package python-linux-procfs.noarch 0:0.4.9-4.el7 will be an update
    ---> Package python-perf.x86_64 0:3.10.0-862.11.6.v7 will be updated
    ---> Package python-perf.x86_64 0:3.10.0-957.10.1.v7 will be an update
    ---> Package python-urlgrabber.noarch 0:3.10-8.el7 will be updated
    ---> Package python-urlgrabber.noarch 0:3.10-9.el7 will be an update
    ---> Package python-zope-component.noarch 1:4.1.0-3.el7 will be updated
    ---> Package python-zope-component.noarch 1:4.1.0-5.el7 will be an update
    ---> Package python2-crypto.x86_64 0:2.6.1-13.el7 will be updated
    ---> Package python2-crypto.x86_64 0:2.6.1-16.el7 will be an update
    ---> Package python2-future.noarch 0:0.16.0-6.el7 will be updated
    ---> Package python2-future.noarch 0:0.16.0-7.el7 will be an update
    ---> Package python2-psutil.x86_64 0:2.2.1-4.el7 will be updated
    ---> Package python2-psutil.x86_64 0:2.2.1-5.el7 will be an update
    ---> Package rpm.x86_64 0:4.11.3-32.el7 will be updated
    ---> Package rpm.x86_64 0:4.11.3-35.el7 will be an update
    ---> Package rpm-build-libs.x86_64 0:4.11.3-32.el7 will be updated
    ---> Package rpm-build-libs.x86_64 0:4.11.3-35.el7 will be an update
    ---> Package rpm-libs.x86_64 0:4.11.3-32.el7 will be updated
    ---> Package rpm-libs.x86_64 0:4.11.3-35.el7 will be an update
    ---> Package rpm-python.x86_64 0:4.11.3-32.el7 will be updated
    ---> Package rpm-python.x86_64 0:4.11.3-35.el7 will be an update
    ---> Package rsyslog.x86_64 0:8.24.0-16.el7_5.4 will be updated
    ---> Package rsyslog.x86_64 0:8.24.0-34.el7 will be an update
    ---> Package samba.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-client.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-client.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-client-libs.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-common.noarch 0:4.7.1-9.v7 will be updated
    ---> Package samba-common.noarch 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-common-libs.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-common-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-common-tools.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-common-tools.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-dc.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-dc.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-dc-libs.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-dc-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-libs.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-python.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-python.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-winbind.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind-clients.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-winbind-clients.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package samba-winbind-modules.x86_64 0:4.7.1-9.v7 will be updated
    ---> Package samba-winbind-modules.x86_64 0:4.8.3-4.4.v7 will be an update
    ---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.6 will be updated
    ---> Package selinux-policy.noarch 0:3.13.1-229.el7_6.12 will be an update
    ---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.6 will be updated
    ---> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.12 will be an update
    ---> Package setup.noarch 0:2.8.71-9.el7 will be updated
    ---> Package setup.noarch 0:2.8.71-10.el7 will be an update
    ---> Package shadow-utils.x86_64 2:4.1.5.1-24.el7 will be updated
    ---> Package shadow-utils.x86_64 2:4.1.5.1-25.el7_6.1 will be an update
    ---> Package sudo.x86_64 0:1.8.19p2-14.el7_5 will be updated
    ---> Package sudo.x86_64 0:1.8.23-3.el7 will be an update
    ---> Package system-base.x86_64 0:7.5.2-1.v7 will be updated
    ---> Package system-base.x86_64 0:7.6.5-1.v7 will be an update
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd.x86_64 0:219-62.el7_6.6 will be an update
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-62.el7_6.6 will be an update
    ---> Package systemd-sysv.x86_64 0:219-57.el7_5.3 will be updated
    ---> Package systemd-sysv.x86_64 0:219-62.el7_6.6 will be an update
    ---> Package syswatch.noarch 0:7.4.0-1.v7 will be updated
    ---> Package syswatch.noarch 0:7.4.1-1.v7 will be an update
    ---> Package tar.x86_64 2:1.26-34.el7 will be updated
    ---> Package tar.x86_64 2:1.26-35.el7 will be an update
    ---> Package teamd.x86_64 0:1.27-4.el7 will be updated
    ---> Package teamd.x86_64 0:1.27-5.el7 will be an update
    ---> Package tuned.noarch 0:2.9.0-1.el7_5.2 will be updated
    ---> Package tuned.noarch 0:2.10.0-6.el7_6.3 will be an update
    ---> Package tzdata.noarch 0:2018f-2.el7 will be updated
    ---> Package tzdata.noarch 0:2019a-1.el7 will be an update
    ---> Package util-linux.x86_64 0:2.23.2-52.el7_5.1 will be updated
    ---> Package util-linux.x86_64 0:2.23.2-59.el7_6.1 will be an update
    --> Processing Dependency: libsmartcols = 2.23.2-59.el7_6.1 for package: util-linux-2.23.2-59.el7_6.1.x86_64
    --> Processing Dependency: libsmartcols.so.1(SMARTCOLS_2.25)(64bit) for package: util-linux-2.23.2-59.el7_6.1.x86_64
    --> Processing Dependency: libsmartcols.so.1()(64bit) for package: util-linux-2.23.2-59.el7_6.1.x86_64
    ---> Package vim-minimal.x86_64 2:7.4.160-4.el7 will be updated
    ---> Package vim-minimal.x86_64 2:7.4.160-5.el7 will be an update
    ---> Package webconfig-httpd.x86_64 0:2.4.6-80.v7 will be updated
    ---> Package webconfig-httpd.x86_64 0:2.4.6-88.v7 will be an update
    ---> Package webconfig-httpd-tools.x86_64 0:2.4.6-80.v7 will be updated
    ---> Package webconfig-httpd-tools.x86_64 0:2.4.6-88.v7 will be an update
    ---> Package webconfig-mod_ssl.x86_64 1:2.4.6-80.v7 will be updated
    ---> Package webconfig-mod_ssl.x86_64 1:2.4.6-88.v7 will be an update
    ---> Package webconfig-php.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-cli.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-cli.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-common.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-common.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-gd.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-gd.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-ldap.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-ldap.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-mbstring.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-mbstring.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-mysql.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-mysql.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-pdo.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-pdo.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-process.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-process.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package webconfig-php-xml.x86_64 0:5.4.16-45.v7 will be updated
    ---> Package webconfig-php-xml.x86_64 0:5.4.16-46.v7 will be an update
    ---> Package xfsprogs.x86_64 0:4.5.0-15.el7 will be updated
    ---> Package xfsprogs.x86_64 0:4.5.0-19.el7_6 will be an update
    ---> Package yum.noarch 0:3.4.3-158.el7.centos will be updated
    ---> Package yum.noarch 0:3.4.3-161.el7.centos will be an update
    ---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-46.el7_5 will be updated
    ---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-50.el7 will be an update
    ---> Package yum-utils.noarch 0:1.1.31-46.el7_5 will be updated
    ---> Package yum-utils.noarch 0:1.1.31-50.el7 will be an update
    ---> Package zabbix-agent.x86_64 0:4.2.0-1.el7 will be updated
    ---> Package zabbix-agent.x86_64 0:4.2.3-1.el7 will be an update
    ---> Package zlib.x86_64 0:1.2.7-17.el7 will be updated
    ---> Package zlib.x86_64 0:1.2.7-18.el7 will be an update
    --> Running transaction check
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package dejavu-sans-fonts.noarch 0:2.33-6.el7 will be installed
    --> Processing Dependency: dejavu-fonts-common = 2.33-6.el7 for package: dejavu-sans-fonts-2.33-6.el7.noarch
    ---> Package fribidi.x86_64 0:1.0.2-1.el7 will be installed
    ---> Package libglvnd-egl.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
    --> Processing Dependency: libglvnd(x86-64) = 1:1.0.1-0.8.git5baa1e5.el7 for package: 1:libglvnd-egl-1.0.1-0.8.git5baa1e5.el7.x86_64
    --> Processing Dependency: libGLdispatch.so.0()(64bit) for package: 1:libglvnd-egl-1.0.1-0.8.git5baa1e5.el7.x86_64
    ---> Package libglvnd-glx.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
    ---> Package libsemanage.i686 0:2.5-11.el7 will be installed
    --> Processing Dependency: libustr-1.0.so.1(USTR_1.0.1) for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libustr-1.0.so.1(USTR_1.0) for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libustr-1.0.so.1 for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libsepol.so.1(LIBSEPOL_1.1) for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libsepol.so.1 for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libselinux.so.1 for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libc.so.6(GLIBC_2.8) for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libbz2.so.1 for package: libsemanage-2.5-11.el7.i686
    --> Processing Dependency: libaudit.so.1 for package: libsemanage-2.5-11.el7.i686
    ---> Package libsemanage.x86_64 0:2.5-11.el7 will be updated
    ---> Package libsmartcols.x86_64 0:2.23.2-59.el7_6.1 will be installed
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    --> Running transaction check
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package audit-libs.i686 0:2.8.1-3.el7 will be installed
    --> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.8.1-3.el7.i686
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
    ---> Package dejavu-fonts-common.noarch 0:2.33-6.el7 will be installed
    ---> Package glibc.i686 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-common = 2.17-222.el7 for package: glibc-2.17-222.el7.i686
    --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-222.el7.i686
    --> Processing Dependency: libfreebl3.so for package: glibc-2.17-222.el7.i686
    ---> Package glibc.x86_64 0:2.17-222.el7 will be updated
    ---> Package glibc.x86_64 0:2.17-222.el7 will be updated
    ---> Package libglvnd.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
    ---> Package libselinux.i686 0:2.5-12.el7 will be installed
    --> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-12.el7.i686
    ---> Package libselinux.x86_64 0:2.5-12.el7 will be updated
    ---> Package libselinux.x86_64 0:2.5-12.el7 will be updated
    ---> Package libsepol.i686 0:2.5-8.1.el7 will be installed
    ---> Package libsepol.x86_64 0:2.5-8.1.el7 will be updated
    ---> Package libsepol.x86_64 0:2.5-8.1.el7 will be updated
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package ustr.i686 0:1.0.4-16.el7 will be installed
    --> Running transaction check
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package glibc.i686 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-common = 2.17-222.el7 for package: glibc-2.17-222.el7.i686
    ---> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
    ---> Package nss-softokn-freebl.i686 0:3.34.0-2.el7 will be installed
    ---> Package pcre.i686 0:8.32-17.el7 will be installed
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
    --> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
    --> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.32-17.el7.i686
    --> Processing Dependency: libgcc_s.so.1 for package: pcre-8.32-17.el7.i686
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    --> Running transaction check
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package glibc.i686 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-common = 2.17-222.el7 for package: glibc-2.17-222.el7.i686
    ---> Package libgcc.i686 0:4.8.5-28.el7 will be installed
    ---> Package libstdc++.i686 0:4.8.5-28.el7 will be installed
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    --> Finished Dependency Resolution
    --> Running transaction check
    ---> Package app-php-engines-core.noarch 1:1.2.0-1.v7 will be an update
    --> Processing Dependency: rh-php72-php-bcmath for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-cli for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-common for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-fpm for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-gmp for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-intl for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-json for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-ldap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mbstring for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-mysqlnd for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-opcache for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pdo for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-pear for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-process for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-soap for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-xml for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    --> Processing Dependency: rh-php72-php-zip for package: 1:app-php-engines-core-1.2.0-1.v7.noarch
    ---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be updated
    --> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7_5.1 for package: audit-libs-python-2.8.1-3.el7_5.1.x86_64
    ---> Package glibc.i686 0:2.17-222.el7 will be installed
    --> Processing Dependency: glibc-common = 2.17-222.el7 for package: glibc-2.17-222.el7.i686
    ---> Package kernel.x86_64 0:3.10.0-693.11.6.v7 will be erased
    ---> Package policycoreutils.x86_64 0:2.5-22.el7 will be updated
    --> Processing Dependency: policycoreutils = 2.5-22.el7 for package: policycoreutils-python-2.5-22.el7.x86_64
    ---> Package samba-client-libs.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libldb.so.1(LDB_1.3.0)(64bit) for package: samba-client-libs-4.8.3-4.4.v7.x86_64
    ---> Package samba-winbind.x86_64 0:4.8.3-4.4.v7 will be an update
    --> Processing Dependency: libtevent.so.0(TEVENT_0.9.36)(64bit) for package: samba-winbind-4.8.3-4.4.v7.x86_64
    ---> Package systemd.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    ---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be updated
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: libgudev1-219-57.el7_5.3.x86_64
    --> Processing Dependency: systemd-libs = 219-57.el7_5.3 for package: systemd-python-219-57.el7_5.3.x86_64
    --> Finished Dependency Resolution
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-pear
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-bcmath
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-intl
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-xml
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-soap
    Error: Package: audit-libs-python-2.8.1-3.el7_5.1.x86_64 (@clearos-centos-updates)
    Requires: audit-libs(x86-64) = 2.8.1-3.el7_5.1
    Removing: audit-libs-2.8.1-3.el7_5.1.x86_64 (@clearos-centos-updates)
    audit-libs(x86-64) = 2.8.1-3.el7_5.1
    Updated By: audit-libs-2.8.4-4.el7.x86_64 (clearos)
    audit-libs(x86-64) = 2.8.4-4.el7
    Available: audit-libs-2.8.1-3.el7.x86_64 (clearos-centos)
    audit-libs(x86-64) = 2.8.1-3.el7
    Error: Package: policycoreutils-python-2.5-22.el7.x86_64 (@clearos-centos)
    Requires: policycoreutils = 2.5-22.el7
    Removing: policycoreutils-2.5-22.el7.x86_64 (@clearos-centos)
    policycoreutils = 2.5-22.el7
    Updated By: policycoreutils-2.5-29.el7_6.1.x86_64 (clearos)
    policycoreutils = 2.5-29.el7_6.1
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-gd
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-common
    Error: Package: libgudev1-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    Requires: systemd-libs = 219-57.el7_5.3
    Removing: systemd-libs-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    systemd-libs = 219-57.el7_5.3
    Updated By: systemd-libs-219-62.el7_6.6.x86_64 (clearos)
    systemd-libs = 219-62.el7_6.6
    Available: systemd-libs-219-57.el7.i686 (clearos-centos)
    systemd-libs = 219-57.el7
    Available: systemd-libs-219-57.el7_5.1.x86_64 (clearos-centos-updates)
    systemd-libs = 219-57.el7_5.1
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-cli
    Error: Package: systemd-python-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    Requires: systemd-libs = 219-57.el7_5.3
    Removing: systemd-libs-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    systemd-libs = 219-57.el7_5.3
    Updated By: systemd-libs-219-62.el7_6.6.x86_64 (clearos)
    systemd-libs = 219-62.el7_6.6
    Available: systemd-libs-219-57.el7.i686 (clearos-centos)
    systemd-libs = 219-57.el7
    Available: systemd-libs-219-57.el7_5.1.x86_64 (clearos-centos-updates)
    systemd-libs = 219-57.el7_5.1
    Error: Package: samba-client-libs-4.8.3-4.4.v7.x86_64 (clearos-updates)
    Requires: libldb.so.1(LDB_1.3.0)(64bit)
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-pdo
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-mbstring
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-ldap
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-opcache
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-mysqlnd
    Error: Package: systemd-python-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    Requires: systemd = 219-57.el7_5.3
    Removing: systemd-219-57.el7_5.3.x86_64 (@clearos-centos-updates)
    systemd = 219-57.el7_5.3
    Updated By: systemd-219-62.el7_6.6.x86_64 (clearos)
    systemd = 219-62.el7_6.6
    Available: systemd-219-57.el7.x86_64 (clearos-centos)
    systemd = 219-57.el7
    Available: systemd-219-57.el7_5.1.x86_64 (clearos-centos-updates)
    systemd = 219-57.el7_5.1
    Error: Package: samba-winbind-4.8.3-4.4.v7.x86_64 (clearos-updates)
    Requires: libtevent.so.0(TEVENT_0.9.36)(64bit)
    Error: Package: glibc-2.17-222.el7.i686 (clearos-centos)
    Requires: glibc-common = 2.17-222.el7
    Removing: glibc-common-2.17-222.el7.x86_64 (@clearos-centos)
    glibc-common = 2.17-222.el7
    Updated By: glibc-common-2.17-260.el7_6.4.x86_64 (clearos)
    glibc-common = 2.17-260.el7_6.4
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-json
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-zip
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-gmp
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-fpm
    Error: Package: 1:app-php-engines-core-1.2.0-1.v7.noarch (clearos-contribs)
    Requires: rh-php72-php-process
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [root@~]#
    The reply is currently minimized Show
  • Accepted Answer

    Friday, June 07 2019, 07:31 AM - #Permalink
    Resolved
    0 votes
    Hello Marc,
    Because of a circular dependency you can't do a manual update from 7.5 to 7.6 in one go, but the automatic updates should work. If you are getting this problem with automatic updates, please can I ask you to hang on until I speak to Dave. We were going to do an updated app-software-updates to change a little the way automatic updates worked to positively program round the issue. There is an app-software-updates in clearos-updates-testing but I don't know if it is ready to roll. If it is, it would be great to test it.

    If you don't want to wait, please do:
    yum update app-base
    yum clean all
    yum update


    The root cause of this is that PHP7.2 is only in the centos-7.6 repos, but you are not configured to use the 7.6 centos and sclo repos until app-base updates and changes your repo configuration for you. The automatic updates should be able to get round this over a couple of nights but we'd like to change that so it does the upgrade in one night.

    BTW, this is one reason why we'd like to split the PHP Engines app into multiple apps - a top level app to handle the webconfig, and individual apps for each version of PHP.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, June 07 2019, 06:38 PM - #Permalink
    Resolved
    0 votes
    Nick is correct. The problem is that these dependencies come from an upstream sclo structure that is fixed by the app-base package. Our new method of breaking these packages out to individual php version is the way to fix it since older version will just deprecate and newer versions can be made available independent of the app- package.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, June 15 2019, 11:55 AM - #Permalink
    Resolved
    0 votes
    Hi,

    I see still php 5.4.16 when check the version on COS 7.6.
    php -v
    PHP 5.4.16 (cli) (built: Oct 30 2018 19:30:51)


    Is still needed for COS webconfig ? or how does this work.

    Since the older version are depreciated is this version still valid ?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, June 16 2019, 09:49 AM - #Permalink
    Resolved
    0 votes
    ownCloud’s occ command (ownCloud console) says it requires at least PHP 5.6. I was using 5.4.16 so changed it to 7.0, but from command line still says 5.4.16 even though in webconfig settings for web server & php it says 7.0. also unable to disable PHP 5.4.16, because no option for this. I understand why now since webconfig requires it.

    Since can't disable older version cannot use the occ command. I need it to try and reset the admin password.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, June 17 2019, 12:45 PM - #Permalink
    Resolved
    0 votes
    Since can't disable older version cannot use the occ command. I need it to try and reset the admin password.


    I don't use OwnCloud, nor do I have it installed. However, when glancing at online docs for it, it looks like it uses whatever the web server is using, which makes sense. Since you have your version selected in your Webconfig, do you also have the web server installed and running (i.e. Apache)? Additionally, in ClearOS, the command line will always show 5.4 as the php version, unless you run a version command for your choice of php engine, i.e. /opt/rh/rh-php70/root/usr/bin/php -v. The web server will use the one you've selected and have running in your Webconfig. Make sure to restart your two associated services at command line after changing the php version:
    systemctl restart rh-php70-php-fpm.service httpd.service


    Perhaps the config/config.php script for your Owncloud installation has a parameter in there that has to match your web server's php version?
    The reply is currently minimized Show
Your Reply