0 votes
Hi folks

In a nutshell I need to know where to add -a to /usr/bin/fetchmail routine.

Running Clearos mail Retrieval app behind a Sophos UTM I get the error "couldn't fetch headers". According to the Sophos/Astaro forums this seems to have been an issue for a long time and their solution is to use "/usr/bin/fetchmail -a". I have tested this from the command line and can confirm that this works :)
runuser - fetchmail -s /bin/sh -c '/usr/bin/fetchmail -a -f /etc/fetchmail --syslog'
which I gleaned from this thread

So if someone can point me to where I can add the -a I will be a very happy camper :)

Thursday, March 24 2016, 04:36 AM
Share this post:

Accepted Answer

Thursday, March 24 2016, 08:24 AM - #Permalink
0 votes
Thanks for the prompt reply Nick :)

I'll give that a go!
The reply is currently minimized Show
Responses (1)
  • Accepted Answer

    Thursday, March 24 2016, 07:37 AM - #Permalink
    0 votes
    This still uses the old style init file rather than systemd and it does not use a parameter file in /etc/sysconfig, so add it to the "args" line in /etc/rc.d/init.d/fetchmail. Just note that ClearOS can overwrite this file if fetchmail gets updated. It is pretty unlikely, but can be prevented by setting the immutable bit "chattr +i /etc/rc.d/init.d/fetchmail". If you ever need to change the file you'll need to unset the bit "chattr -i /etc/rc.d/init.d/fetchmail".
    The reply is currently minimized Show
Your Reply