Community Forum

Resolved
0 votes
I have installed ClearOS 7.3 on a Zotaz Nano AD12 with no problems. It came up with a DHCP address from my firewall. I connected to that address, port 81 successfully and logged in as root.

First step was to change the ethernet interface to a static address. When I went in to edit the address, I saw the option to modify the address and to set the hostname. I chose to edit the address first. I successfully changed to a static address (outside my firewall's DHCP range) and then had to relogin on this new address. Got back to the interfaces page, but now I can's see to change the hostname. So I am still localhost.localdomain.

OK. I proceed. The DNS test of my internal DNS server was successful. I proceed and select Community Edition. Next screen fails with the DNS lookup. /etc/resolv.conf only has 127.0.0.1 (note that prior to setting static address, it also had the addr of my DNS server).

So right now two blocking issues:

How do I set the hostname.

More importantly, how do I get this registration step done. Why is it failing on DNS test when prior page's DNS test was successful?

thank you

One note, from the console tty2, I modifed /etc/ssh/sshd_config to use the TCP port I use for all my servers and to all root login via SSH (as I have not added a user ID yet). This worked, and I have an ssh connection to the server, logged in as root.
Sunday, May 21 2017, 07:53 PM
Share this post:

Accepted Answer

Sunday, May 21 2017, 10:46 PM - #Permalink
Resolved
0 votes
yes, the first time running the wizard. Thanks for showing my how to turn off the wizard...

AH, figured out my DNS problem. I have set this server up on a 'new' subnet, and I had to added in to the acl on my internal DNS server.

Sometimes we get too smart for our own good!
The reply is currently minimized Show
Responses (1)
  • Accepted Answer

    Sunday, May 21 2017, 08:34 PM - #Permalink
    Resolved
    0 votes
    Is your problem during the first-run wizard?

    If you set a static IP you need to set DNS servers manually. You can do it through the webconfig > Network > Settings > IP Settings > Your WAN interface (in standalone mode use the WAN interface) > Uncheck Automatic DNS servers and Update. You should the be able to edit the DNS servers on the webconfig > Network > Settings > IP Settings page. And, not the settings are kept in /etc/resolv-peerdns.conf and not resolv.conf.

    Note you can stop the wizard by navigating to https://your_clearos_lan_ip:81/app/base/wizard/stop. You can then finish off configuration manually.
    The reply is currently minimized Show
Your Reply