0 votes
Hello all,
With COS 5.3, I had a small script to copy my data on a external HD and send the result via mail : this was working fine :

rsync -a --stats --ignore-errors --delete --exclude "*Thumbs*" /var/flexshare/shares/ /media/drives/USB/kwsa 2>&1 | mail -s "Backup KWSA" "" -- -r ""

I had to use sasl_password file and my provier as relay.

I migrate last night to the last COS version and this stopped working. I was looking for my file. Whne I realised then I did not create the root certificate for my server, I did it and reloaded/restarted postfix. Till there, nothing is written anymore in my /var/log/maillog file

I checked my postfix service and it's running, so I'm wondering why nothing comes in my file .... I checked the debug level and it's on 2...

what else could I check to find why my maillog file remains empty ?

Thanks to all for your help
In Mail
Tuesday, February 25 2014, 03:30 PM
Share this post:
Responses (3)
  • Accepted Answer

    Wednesday, February 26 2014, 12:07 PM - #Permalink
    0 votes
    Ok, I've found the solution but can't explain why I had to do this :

    At the end of my file, I had to add the following line :

    sender_canonical_maps = hash:/etc/postfix/sender_canonical

    In that file, I had to add a line to replace the root account with the default email sender. Now, everytime a mail is sent, the sender is the one I defined in this file.

    This is completely new for me. I already configured severa files for smtp authentification and this is the first time I've to add this line. It seems that, when I send and email with the option -- -r "Senderemail_address", this doesn't work anymore-

    Can someone confirm this ?

    Thanks to all for your help

    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 25 2014, 07:08 PM - #Permalink
    0 votes
    Hello Ben,

    Thanks for your answer. In fact, that was the service rsyslog that was stopped. Now it's working again but for a reason I dont know (I just copy my old file), this is not working anymore. I've configured the mail relay, created the password for authentication to my provider and test with the following command :

    echo "test" | mail -s "Backup KWSA" "" -- -f

    the address is the one I made the sasl_password file for the authentication to my provider. Here's the error :

    ... status=bounced (host[] said: 553 <root@kwsa.lan> unable to verify address (in reply to MAIL FROM command))

    It seems that the -- -f is not used as the sender, but doesnt know why. I already tried to change the -r by -f but no change

    I've this error, too :

    to=<root@kwsa.lan>, relay=mailpostfilter, delay=0.21, delays=0.05/0.01/0/0.15, dsn=4.3.0, status=deferred (temporary failure. Command output: Failed to connect socket: Connection refused, original code )

    if someone has an idea....

    thanks to all
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, February 25 2014, 05:21 PM - #Permalink
    0 votes
    What do you see when you type:

    Your messages? What are the delivery failure notes?

    Postfix started?

    service postfix restart

    The reply is currently minimized Show
Your Reply