0 votes
At some point, Roundcube stopped working on our server. I don't know when. I recently updated our SSL certificate, don't know whether this might have had something to do with it.
Webconfig works fine with the new cert. But when I go to the address for Roundcube, I get no response.
When I I go to Roundcube in Webconfig, I get:
Roundcube Webmail
The Web Server is not running - webmail not available.

And there is a button for "Configure Web Server".
I click that and am taken to the web server config, where I can click to change the name, or go into a bunch of settings, which look OK to me (I don't remember ever configuring them before). The "Digital Certificate" shown is correct.
To the right it says Web Server Status: Stopped, and when I click the Start button, it doesn't work--Stopped comes back.
Why do I have to fix a broken web server, and how do I do it? The only "web site" on this machine, besides Webconfig, is Roundcube.
Tuesday, January 15 2019, 04:41 AM
Share this post:

Accepted Answer

Tuesday, January 15 2019, 08:25 AM - #Permalink
0 votes
Webconfig and Roundcube are on different Web Servers. The Webconfig runs on a sandboxed one and Roundcube on the one we can normally alter.

I have no idea what has changed and it would have been easier to understand if you'd noticed at the time when it failed, but if you're like me with modern tech, there I rarely use Roundcube now so I wouldn't notice either.

The Webconfig does not use the standard certificate and its certificate is chosen in Webconfig > System > Settings >General Settings. Please don't change it for the moment as, if you have a certificate problem, you may kill the Webconfig as well.

Please can you look in the logs in /var/log/httpd for errors when you try to start it.

When you uploaded your new certificate, what did you upload? Certificate, Intermediate Certificate and Key? Or were the Certificate and Intermediate Certificate combined into a single file? What is the contents of /etc/clearos/certificate_manager.d?
The reply is currently minimized Show
Responses (1)
  • Accepted Answer

    Wednesday, January 16 2019, 03:22 AM - #Permalink
    0 votes
    That was helpful. /var/log/httpd indicated that the certificate file could not be read. After some fumbling around, I figured out the formatting issue and was able to install the certificate in a correct format. A restart of httpd, and everything miraculously worked again. I guess I did not suspect that a malformed cert would prevent the webserver from working altogether. Always something to learn.
    Thanks again!
    The reply is currently minimized Show
Your Reply