Forums

Resolved
0 votes
I recently installed the Roundcube app from the marketplace, it has been running great for the last few weeks with no issues. Today, I'm unable to login. I'm greeted with a "Connection to storage server failed" error. I checked the server logs to find this:

/var/log/messages
Mar 7 11:58:09 server01 roundcube: <hjkr94j1> IMAP Error: Login failed for user01 from 172.16.5.6. Could not connect to ssl://localhost:993: Unknown reason in /usr/share/roundcubemail/program/lib/Roundcube/rcube_imap.php on line 193 (POST /webmail/?_task=login&_action=login)

/var/log/maillog
Mar 7 11:57:12 server01 imaps[30235]: Fatal error: tls_start_servertls() failed
Mar 7 11:58:09 server01 imaps[30237]: imaps TLS negotiation failed: localhost [127.0.0.1]

The strange thing is, both my phone app and Thunderbird can connect just fine using TLS. This issue just happened out of the blue, uninstalling / re-installing app makes no difference.

Any ideas?
Tuesday, March 07 2017, 08:03 PM
Share this post:
Responses (4)
  • Accepted Answer

    Wednesday, March 08 2017, 09:31 PM - #Permalink
    Resolved
    0 votes
    I also found that post but as you hadn't had any updates I don't know why you'd need those changes. I'm on Business so my updates are behind yours, but I have nothing like that in my config.inc.php. Can you just check your yum.log and also give the result of "rpm -qa | grep ^roundc"? I have "roundcubemail-1.2.3-3.v7.noarch".

    [edit]
    Was your $config['default_host'] localhost or ssl://localhost?
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 08 2017, 09:00 PM - #Permalink
    Resolved
    2 votes
    I figured it out after running across a similar issue here:

    https://bbs.archlinux.org/viewtopic.php?id=187063

    I added the following to my config.inc.php file.

    $config['imap_conn_options'] = array(
    'ssl' => array(
    'verify_peer' => false,
    'verfify_peer_name' => false,
    ),
    );

    I also had to change the 'default_host' from "localhost" to: "ssl://localhost.localdomain"

    $config['default_host'] = 'ssl://localhost.localdomain';

    Seems to be working just fine now.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 08 2017, 05:33 PM - #Permalink
    Resolved
    0 votes
    No, nothing at all. Automatic updates are enabled though. During troubleshooting, I removed and re-created the certificates, still same error.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, March 08 2017, 05:03 PM - #Permalink
    Resolved
    0 votes
    Have you changed anything recently? If Webconfig > Server > Messaging > IMAP and POP Server still set to allow Secure IMAP? Have you changed any certificates?
    The reply is currently minimized Show
Your Reply