Community Forum

Resolved
0 votes
Hi everyone!

I have a small server that mainly serves as storage, mail server and domain logons for some machines.
Everything so far is rock-solid... but the Samba speed.
So far I found out that windows10 is using dialect 1.5 for connecting to Samba and I suspect that this could be a coulprit.
smb.conf

[global]
unix password sync = Yes
# General
netbios name = one
workgroup = office
server string = MyServer
security = user
#max protocol = SMB2

# Logging
syslog = 0
log level = 1
log file = /var/log/samba/%L-%m
max log size = 0
utmp = Yes

# Network
bind interfaces only = No
interfaces = lo eth0
smb ports = 139

# Printing
printcap name = /etc/printcap
load printers = Yes

# Security settings
guest account = guest
#restrict anonymous = 2

# WINS
wins support = Yes
wins server =
dns proxy = yes

# PDC/BDC
domain logons = Yes
add machine script = /usr/sbin/samba-add-machine "%u"
logon drive = U:
logon script = logon.cmd
logon path = \\%L\profiles\%U
logon home = \\%L\%U

# Winbind
idmap config * : backend = ldap
idmap config * : range = 20000000-29999999
winbind enum users = Yes
winbind enum groups = Yes
winbind offline logon = false
winbind use default domain = true
winbind separator = +
template homedir = /home/%U
template shell = /sbin/nologin

# Other
preferred master = Yes
domain master = Yes
passwd program = /usr/sbin/userpasswd %u
passwd chat = *password:* %n\n *password:* %n\n *successfully.*
passwd chat timeout = 10
username map = /etc/samba/smbusers
wide links = No
allow trusted domains = No

# LDAP settings
include = /etc/samba/smb.ldap.conf

# Winbind LDAP settings
include = /etc/samba/smb.winbind.conf


Windows Get-SmbConnection
PS C:\Windows\system32> Get-SmbConnection

ServerName ShareName UserName Credential Dialect NumOpens
---------- --------- -------- ---------- ------- --------
192.168.201.3 offic OFFICE\tec OFFICE\tec 1.5 1
192.168.201.3 prodfloor OFFICE\tec OFFICE\tec 1.5 1
192.168.201.3 pullmax OFFICE\tec OFFICE\tec 1.5 1
192.168.201.3 tec OFFICE\tec OFFICE\tec 1.5 1
ONE tec OFFICE\tec OFFICE\tec 1.5 1


Is there anything I can try to improve this situation without braking current install?
Would it be wise to move to 7. release instead?
Thursday, May 18 2017, 09:21 AM
Share this post:
Responses (11)
  • Accepted Answer

    Monday, May 22 2017, 07:33 AM - #Permalink
    Resolved
    0 votes
    As you say, your disk looks fine. On my gigabit network I get 60-100MB/s for big files not scanned by the client AV.

    You can probably comment out the line "smb ports = 139" in your config but I've no idea if it will make any difference. There have been some posts about it in the past and I run without it (it defaults to "139 445").
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 22 2017, 07:12 AM - #Permalink
    Resolved
    0 votes
    Sorry, did not see that message.
    " Timing buffered disk reads: 378 MB in 3.00 seconds = 125.90 MB/sec"
    That is a speed of my RAID. I tested with ssd, just to be shure that it was not the bottleneck.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 04:22 PM - #Permalink
    Resolved
    0 votes
    Did you see my append to run the hdparm command - a basic disk speed test?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 03:29 PM - #Permalink
    Resolved
    0 votes
    Sorry, my typo as i thought that e1000 does not exist anymore.
    Managed to install kernel headers and driver compiled successfully - will wait for a good time to reboot and hopefully it is all well.
    I also tested network with iperf and it seemed more or less ok at about 950mbits. Then again Samba might be more sensitive to some network unstabilities.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 08:37 AM - #Permalink
    Resolved
    0 votes
    I don't know if it is a typo, but it is the e1000e driver and not the e1000 driver that you want. If you can't get hold of the relevant kernel headers you may get pushed down the route of upgrading the kernel and, depending on which you choose, it may come with a later driver.

    Also please note that I am not making any promises that this will solve the issue.

    Can I ask if you have done a speed test with something like FTP just to prove it is a samba issue? Don't try to test with with ssh like with WinSCP as the encryption speed will be the limiting factor.

    [edit]
    What is the output of "hdparm -tT /dev/sdX" where sdX is your hard disk device name?
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 08:02 AM - #Permalink
    Resolved
    0 votes
    Thanks! I will get fresh e1000 driver - should not be a problem.
    QOS and Bandwidth is not neccesary at the moment. hopefully, the box will be migrated to 7.x by then.
    I remember trying all sorts of combinations of switches, before running off to 3.x kernel - none worked - i even suspected hardware problem.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 07:04 AM - #Permalink
    Resolved
    0 votes
    I've never done kernel replacement and there are risks. If you use a vanilla ElRepo kernel, QoS and Bandwidth control will not work.

    The 82574L with drivers up to about 2.3.2 used to have issues. Are you either able to install a later kernel which will contain a more recent kernel or compile a more recent e1000e driver? Drivers up to 3.3.4 currently exist. I think even the standard ClearOS kernel comes with a more recent driver, but I'll need to check when I'm home.

    If you revert to a ClearOS kernel you'll be back on the 2.6.32 kernel line. Do you know if there are any kernel switches which will disable the power management features of the kernel which don't work with the APU?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 19 2017, 06:49 AM - #Permalink
    Resolved
    0 votes
    Thank you for more info!
    Would you suggest replacing kernel with different? I am using Elrepo kernel - it was most sane match I could find at that moment.
    More info:
    filename: /lib/modules/3.13.2-1.clearos.x86_64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
    version: 2.3.2-k
    license: GPL
    description: Intel(R) PRO/1000 Network Driver
    author: Intel Corporation, <linux.nics@intel.com>
    srcversion: FAFC167239309C03F11F440

    I will visit the site on monday to do some troubleshooting and try possible combinations.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 18 2017, 04:23 PM - #Permalink
    Resolved
    0 votes
    Samba is v3.6.23 so SMB2 should work.

    Are you using the ElRepo kernel Tim compiled a while ago? The 82574L had issues with early drivers. What is the driver version reported by "modinfo e1000e" or "ethtool -i your_NIC_interface_like_eth0"
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 18 2017, 01:48 PM - #Permalink
    Resolved
    0 votes
    Thank you Nick!
    I remember uncommenting it and losing access, but I will try again later. Maybe I missed some other setting like ports or so.

    [root@one ~]# lspci -k | grep Eth -A 3
    02:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
    Subsystem: Intel Corporation Gigabit CT Desktop Adapter
    Kernel driver in use: e1000e
    Kernel modules: e1000e

    I got Intel and disabled built-in realtek, so I don't have to struggle with modules and stability.

    3.13.2-1.clearos.x86_64

    I had to replace kernel, as i have AMD APU and 2.6. kernels are simply no-go - system crashes due to power management.

    I tested network at first and I get solid 950Mbits, but samba starts at 60-70MB/s and drops to <10MB/s on large files. On small files we cannot expect grat results anyway. Slowe speeds would be fine if not for our drawing guy and his large tech drawings.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, May 18 2017, 12:52 PM - #Permalink
    Resolved
    0 votes
    If the samba version >= 3.6.16 then you can uncomment "max protocol = SMB2"

    As an outside question, what is the result of:
    lspci -k | grep Eth -A 3
    uname -r
    The reply is currently minimized Show
Your Reply